This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 706885 - libvirt: Failure to start libvirt-guest service (unknown cause)
libvirt: Failure to start libvirt-guest service (unknown cause)
Status: CLOSED DUPLICATE of bug 680270
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
15
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Libvirt Maintainers
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-23 07:16 EDT by Yaniv Kaul
Modified: 2013-07-03 22:30 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-06 20:17:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Yaniv Kaul 2011-05-23 07:16:20 EDT
Description of problem:
systemctl status libvirt-guests.service
libvirt-guests.service - LSB: suspend/resume libvirt guests on shutdown/boot
	  Loaded: loaded (/etc/rc.d/init.d/libvirt-guests)
	  Active: failed since Mon, 23 May 2011 14:06:54 +0300; 2min 34s ago
	 Process: 15653 ExecStart=/etc/rc.d/init.d/libvirt-guests start (code=exited, status=1/FAILURE)
	  CGroup: name=systemd:/system/libvirt-guests.service


sudo /etc/rc.d/init.d/libvirt-guests start
Starting libvirt-guests (via systemctl):  Job failed. See system logs and 'systemctl status' for details.
                                                           [FAILED]


I don't know which logs to look at to diagnose it further.
Version-Release number of selected component (if applicable):
libvirt-0.8.8-4.fc15.x86_64

How reproducible:
Always, on my laptop.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Henry Rust 2011-05-29 03:54:10 EDT
I also get this error:

libvirt-guests.service - LSB: suspend/resume libvirt guests on shutdown/boot
          Loaded: loaded (/etc/rc.d/init.d/libvirt-guests)
          Active: failed since Sun, 29 May 2011 09:39:24 +0200; 12min ago
         Process: 1192 ExecStart=/etc/rc.d/init.d/libvirt-guests start (code=exited, status=1/FAILURE)
          CGroup: name=systemd:/system/libvirt-guests.service

But I think this from /var/log/messages is interesting: 

May 29 09:39:24 henrydesktop libvirtd: 09:39:24.125: 1181: info : libvirt version: 0.8.8, package: 4.fc15 (Fedora Project, 2011-04-05-19:58:51, x86-01.phx2.fedoraproject.org)
May 29 09:39:24 henrydesktop libvirtd: 09:39:24.125: 1181: error : virGetHostname:2634 : internal error getaddrinfo failed for 'henrydesktop': Name or service not known
May 29 09:39:24 henrydesktop systemd[1]: libvirt-guests.service: control process exited, code=exited status=1
May 29 09:39:24 henrydesktop systemd[1]: Unit libvirt-guests.service entered failed state.

Seems libvirt fails, because it can't resolve my hostname henrydesktop with getaddrinfo.
Comment 2 Roger Johnson 2011-06-08 12:51:11 EDT
I've also experienced the issue and have a solution for at least one variant of the problem.

After initial installation of a Fedora 15 x86_64 system, I get the following error trying to start libvirt-guests:

[root@my-hyp ~]# service libvirt-guests start
Starting libvirt-guests (via systemctl):  Job failed. See system logs and 'systemctl status' for details.
                                                           [FAILED]

Checking systemctl shows:

[root@my-hyp ~]# systemctl status libvirt-guests.service
libvirt-guests.service - LSB: suspend/resume libvirt guests on shutdown/boot
          Loaded: loaded (/etc/rc.d/init.d/libvirt-guests)
          Active: failed since Wed, 08 Jun 2011 16:40:30 +0000; 27s ago
         Process: 19338 ExecStop=/etc/rc.d/init.d/libvirt-guests stop (code=exited, status=1/FAILURE)
         Process: 19447 ExecStart=/etc/rc.d/init.d/libvirt-guests start (code=exited, status=1/FAILURE)
          CGroup: name=systemd:/system/libvirt-guests.service


And looking at /var/log/messages:

Jun  8 16:40:30 localhost systemd[1]: libvirt-guests.service: control process exited, code=exited status=1
Jun  8 16:40:30 localhost systemd[1]: Unit libvirt-guests.service entered failed state.


Obvious failures...  I lucked into the cause, however by running "service libvirt-guests status" which produces:

[root@denethor-hyp ~]# service libvirt-guests status
/etc/init.d/libvirt-guests: line 37: /usr/bin/gettext.sh: No such file or directory


And doing a "yum provides '/usr/bin/gettext.sh'" shows that it's the "gettext" package that is missing.  Install "gettext" and two dependencies (gettext-libs and libgomp) and the service starts normally.


I looked at the --requires entries for "libvirt-client-0.8.8-4.fc15.x86_64" and indeed "gettext" isn't listed.  The .rpm packaging needs to be fixed.  There may be other missing dependencies, but this is an obvious one.
Comment 3 Henry Rust 2011-06-09 01:43:30 EDT
According to Roger Johnson's solution, I installed the package 'gettext' and this fixed the start of the service.
But I'm still getting this in /var/log/messages:
Jun  9 07:38:44 henrydesktop libvirtd: 07:38:44.776: 1129: error : virGetHostname:2634 : internal error getaddrinfo failed for 'henrydesktop': Name or service not known

I guess this is a different issue, and I should open a new bug report for it.
Comment 4 Fedora Admin XMLRPC Client 2011-09-22 13:52:21 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 5 Fedora Admin XMLRPC Client 2011-09-22 13:55:37 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 6 Fedora Admin XMLRPC Client 2011-11-30 15:02:04 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 7 Fedora Admin XMLRPC Client 2011-11-30 15:02:15 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 8 Fedora Admin XMLRPC Client 2011-11-30 15:06:55 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 9 Fedora Admin XMLRPC Client 2011-11-30 15:07:01 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 10 Siddharth Jain 2011-12-07 06:28:39 EST
@FedoraAdmin XMLRPC Client   ::
Do you mean that we should have different usernames on both the host machines ??
Need help i am getting the same error/
Comment 11 Cole Robinson 2012-06-06 20:17:22 EDT
This should already be fixed in f15. Closing as dup of the fixed bug.

*** This bug has been marked as a duplicate of bug 680270 ***

Note You need to log in before you can comment on or make changes to this bug.