Bug 680270 - libvirt-client is missing some dependencies
libvirt-client is missing some dependencies
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
15
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Daniel Veillard
Fedora Extras Quality Assurance
:
: 687949 706777 706885 717957 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-02-24 16:04 EST by Eric Blake
Modified: 2012-06-06 20:24 EDT (History)
12 users (show)

See Also:
Fixed In Version: libvirt-0.8.8-7.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-07-12 00:59:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Blake 2011-02-24 16:04:17 EST
Description of problem:
The libvirt-client package is missing some dependencies

Version-Release number of selected component (if applicable):
libvirt-client-0.8.8-2.fc15.x86_64

How reproducible:
100:

Steps to Reproduce:
1. On a bare-bones F15 or rawhide installation, 'yum install libvirt-client'
2. Reboot
3. Run virt-pki-validate
  
Actual results:
2. during bootup, the init script fails:
/etc/rc.d/init.d/libvirt-guests: line 37: /usr/bin/gettext.sh: No such file or directory
3. virt-pki-validate starts with a line "Found ", which is due to bogus logic in the script as well as a dependency bug

Expected results:
Installation of the package should drag in all prerequisites (gettext, gnutls-utils), and virt-pki-validate should fix the logic bug.

Additional info:
Fixed by these upstream commits, two of which need to be factored into the .spec file for building the rpm:

commit 39164c11d3f8c6523902f6810431f0d12169b240
Author: Osier Yang <jyang@redhat.com>
Date:   Fri Feb 18 13:45:13 2011 +0800

    Requires gettext for client package

commit e57f834547dbbdb4a2b445ece5ab51e6777b9ee5
Author: Eric Blake <eblake@redhat.com>
Date:   Mon Feb 21 10:43:29 2011 -0700

    build: add dependency on gnutls-utils

commit 9b47915914a2754753c0401a56b67f4c908c94fb
Author: Dan Kenigsberg <danken@redhat.com>
Date:   Sun Feb 20 22:29:25 2011 +0200

    virt-pki-validate: behave when CERTTOOL is missing
Comment 1 Michal Schmidt 2011-04-02 16:45:07 EDT
*** Bug 687949 has been marked as a duplicate of this bug. ***
Comment 2 Fedora Update System 2011-07-06 11:57:06 EDT
libvirt-0.8.8-7.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/libvirt-0.8.8-7.fc15
Comment 3 Fedora Update System 2011-07-06 17:31:33 EDT
Package libvirt-0.8.8-7.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libvirt-0.8.8-7.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/libvirt-0.8.8-7.fc15
then log in and leave karma (feedback).
Comment 4 Fedora Update System 2011-07-12 00:59:21 EDT
libvirt-0.8.8-7.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 5 Eric Blake 2011-12-06 08:46:38 EST
*** Bug 717957 has been marked as a duplicate of this bug. ***
Comment 6 Eric Blake 2011-12-06 08:46:55 EST
*** Bug 706777 has been marked as a duplicate of this bug. ***
Comment 7 Cole Robinson 2012-06-06 20:17:22 EDT
*** Bug 706885 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.