Bug 70689 - Apply placement algorithm to windows which start up maximized
Summary: Apply placement algorithm to windows which start up maximized
Status: CLOSED UPSTREAM
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: metacity (Show other bugs)
(Show other bugs)
Version: 8.0
Hardware: i386 Linux
medium
low
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact:
URL:
Whiteboard:
Keywords: MoveUpstream, Triaged
: 72180 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-08-04 01:45 UTC by Deng Guang
Modified: 2008-05-01 15:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-13 03:59:11 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fix un-maximize problem (448 bytes, patch)
2003-02-05 09:11 UTC, Julien Olivier
no flags Details | Diff

Description Deng Guang 2002-08-04 01:45:07 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020724

Description of problem:
After  start a app such as mozilla which window maximized at the end of last
use, you will not restore the window correctly by click the maximize button to
restore the window. The window goes beyond the desktop border.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. start mozilla and maximize it.
2. close mozilla
3. start mozilla again
4. click the maximized button to restore it
	

Actual Results:  the window streched out of the desktop border.

Expected Results:  place the window and it's border within the desktop

Additional info:

Comment 1 Havoc Pennington 2002-08-07 20:59:45 UTC
Need to apply placement algorithm to the window on first unmaximize, probably.

Comment 2 Havoc Pennington 2003-01-12 22:07:06 UTC
*** Bug 72180 has been marked as a duplicate of this bug. ***

Comment 3 Havoc Pennington 2003-01-13 03:59:11 UTC
Upstream as http://bugzilla.gnome.org/show_bug.cgi?id=103318


Comment 4 Julien Olivier 2003-02-05 09:11:34 UTC
Created attachment 89853 [details]
Fix un-maximize problem

If the application started in maximized/fullscreen size, this patch sets the
saved size to a default size (proportional to the screen's size).


Note You need to log in before you can comment on or make changes to this bug.