This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 707203 - Installer exits abnormally after checking for disks
Installer exits abnormally after checking for disks
Status: CLOSED DUPLICATE of bug 704669
Product: Fedora
Classification: Fedora
Component: parted (Show other bugs)
15
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-24 07:49 EDT by Jean-Pierre Cloup
Modified: 2012-06-01 14:14 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-26 09:43:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
The installer closes right after that step. (24.82 KB, image/png)
2011-05-25 09:14 EDT, Jean-Pierre Cloup
no flags Details
Comment (748.99 KB, text/plain)
2011-05-30 15:03 EDT, Tommy Surbakti
no flags Details

  None (edit)
Description Jean-Pierre Cloup 2011-05-24 07:49:52 EDT
Description of problem:
I cannot install Fedora 15 on my computer (Brand new, 1 day old!), installer stops after disk check (the step just after choosing my keyboard layout) the window closes and the mouse icon turns to a circle, but nothing happens.
It happens on all the .iso i tested (i686, x86_64, on the live and install media) Livecd works perfectly well, i can test fedora 15 but not install it.

Version-Release number of selected component (if applicable):
Fedora 15 beta 

How reproducible:


Steps to Reproduce:
1.Download a .iso from fedoraproject.org/get-prerelease (the gnome one or the install media, bug happens on i686 and x86_64)
2.Copy it to a usb key (i tested from unetbootin on my ubuntu laptop, and fedora liveusbcreator from my windows 7 desktop pc)
3.Boot the usb key
4.On the live .iso click "install to disk", on install dvd i just followed the install process
5.I choose french as my langage and fr_latin9 as my keyboard layout
6.and i click "next" to check the partitions
  
Actual results:
Anaconda stops!

Expected results:
Choose how to partition my hdd.

Additional info:
I'm using a asus eeepc 1215t (amd v-105, ati radeon hd4250), and everything seems to work fine when testing the livecd. But i cannot install fedora to hard drive.
When i try to install fedora 15 from the install DVD, after the bug occured it says "anaconda exits abnormally".

I hope i was clear enough, and i apologize for my poor english, im french...
Comment 1 Chris Lumens 2011-05-24 10:00:22 EDT
If you are getting a traceback, please attach it here.  If you're getting some other error message, please at the least take a screenshot so we have some idea what's going on.
Comment 2 Jean-Pierre Cloup 2011-05-24 20:35:40 EDT
this time i was able to complete the install process by burning the livecd iso to a DVD, instead of a USB key. Ill try again tomorrow to see if i can send more info.
Comment 3 Jean-Pierre Cloup 2011-05-25 09:12:54 EDT
If i launch the installation from a terminal : 

[liveuser@localhost ~]$ liveinst
Backtrace has 20 calls on stack:
  20: /lib/libparted.so.0(ped_assert+0x2a) [0x487ccca]
  19: /lib/libparted.so.0(+0x41065) [0x48b2065]
  18: /lib/libparted.so.0(+0x41924) [0x48b2924]
  17: /lib/libparted.so.0(+0x42433) [0x48b3433]
  16: /lib/libparted.so.0(+0x1029f) [0x488129f]
  15: /lib/libparted.so.0(ped_disk_add_partition+0x202) [0x4884802]
  14: /lib/libparted.so.0(+0x443cd) [0x48b53cd]
  13: /lib/libparted.so.0(+0x4560f) [0x48b660f]
  12: /lib/libparted.so.0(ped_disk_new+0x62) [0x4884ce2]
  11: /usr/lib/python2.7/site-packages/_pedmodule.so(_ped_Disk_init+0x89) [0xc9d909]
  10: /usr/lib/libpython2.7.so.1.0(+0x84bcb) [0x280bcb]
  9: /usr/lib/libpython2.7.so.1.0(PyObject_Call+0x65) [0x228095]
  8: /usr/lib/libpython2.7.so.1.0(PyEval_EvalFrameEx+0x3cad) [0x2c293d]
  7: /usr/lib/libpython2.7.so.1.0(PyEval_EvalCodeEx+0x862) [0x2c58a2]
  6: /usr/lib/libpython2.7.so.1.0(+0x5333e) [0x24f33e]
  5: /usr/lib/libpython2.7.so.1.0(PyObject_Call+0x65) [0x228095]
  4: /usr/lib/libpython2.7.so.1.0(PyEval_EvalFrameEx+0x31c0) [0x2c1e50]
  3: /usr/lib/libpython2.7.so.1.0(PyEval_EvalCodeEx+0x862) [0x2c58a2]
  2: /usr/lib/libpython2.7.so.1.0(+0x5333e) [0x24f33e]
  1: /usr/lib/libpython2.7.so.1.0(PyObject_Call+0x65) [0x228095]
/usr/sbin/liveinst: line 108:  2178 Aborted                 (core dumped) anaconda-cleanup $ANACONDA $*
localuser:root being added to access control list
13:09:03 Starting graphical installation.
Loading /lib/kbd/keymaps/i386/azerty/fr.map.gz
assuming iso-8859-1 cedilla
assuming iso-8859-1 acute
assuming iso-8859-1 diaeresis
assuming iso-8859-1 brokenbar
assuming iso-8859-1 threequarters
assuming iso-8859-1 currency
assuming iso-8859-1 onehalf
assuming iso-8859-1 onequarter
Backtrace has 20 calls on stack:
  20: /lib/libparted.so.0(ped_assert+0x2a) [0x1b40cca]
  19: /lib/libparted.so.0(+0x41065) [0x1b76065]
  18: /lib/libparted.so.0(+0x41924) [0x1b76924]
  17: /lib/libparted.so.0(+0x42433) [0x1b77433]
  16: /lib/libparted.so.0(+0x1029f) [0x1b4529f]
  15: /lib/libparted.so.0(ped_disk_add_partition+0x202) [0x1b48802]
  14: /lib/libparted.so.0(+0x443cd) [0x1b793cd]
  13: /lib/libparted.so.0(+0x4560f) [0x1b7a60f]
  12: /lib/libparted.so.0(ped_disk_new+0x62) [0x1b48ce2]
  11: /usr/lib/python2.7/site-packages/_pedmodule.so(_ped_Disk_init+0x89) [0xfa9909]
  10: /usr/lib/libpython2.7.so.1.0(+0x84bcb) [0x479bcb]
  9: /usr/lib/libpython2.7.so.1.0(PyObject_Call+0x65) [0x421095]
  8: /usr/lib/libpython2.7.so.1.0(PyEval_EvalFrameEx+0x3cad) [0x4bb93d]
  7: /usr/lib/libpython2.7.so.1.0(PyEval_EvalCodeEx+0x862) [0x4be8a2]
  6: /usr/lib/libpython2.7.so.1.0(+0x5333e) [0x44833e]
  5: /usr/lib/libpython2.7.so.1.0(PyObject_Call+0x65) [0x421095]
  4: /usr/lib/libpython2.7.so.1.0(PyEval_EvalFrameEx+0x31c0) [0x4bae50]
  3: /usr/lib/libpython2.7.so.1.0(PyEval_EvalCodeEx+0x862) [0x4be8a2]
  2: /usr/lib/libpython2.7.so.1.0(+0x5333e) [0x44833e]
  1: /usr/lib/libpython2.7.so.1.0(PyObject_Call+0x65) [0x421095]
Comment 4 Jean-Pierre Cloup 2011-05-25 09:14:14 EDT
Created attachment 500805 [details]
The installer closes right after that step.
Comment 5 Brian Lane 2011-05-25 09:29:49 EDT
This looks like another instance of the CHS guessing bug. Could you switch to tty2 after running the installer and run 'parted -l' and attach the output here.
Comment 6 Alex Hudson (Fedora Address) 2011-05-26 03:29:31 EDT
Hi,

We just had a visitor on #fedora who seems to be hitting this exact bug - the backtrace is identical. I had them run 'parted -l' and that's falling over as well, the output is below. It ends up falling over on an assert on the head size. 

I've got his permission to include him on the CC: in case further testing is needed.

Model: ATA ST3250310AS (scsi)
Disk /dev/sda: 250GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number  Start   End     Size    Type      File system  Flags
 1      32.3kB  21.0GB  21.0GB  primary   ext3
 2      21.0GB  41.9GB  21.0GB  primary   ext2
 3      41.9GB  62.9GB  21.0GB  primary   ntfs         boot
 4      62.9GB  250GB   187GB   extended
 5      62.9GB  83.9GB  21.0GB  logical   ext3
 6      83.9GB  147GB   62.9GB  logical   ext4
 7      147GB   189GB   41.9GB  logical   ext2
 8      189GB   191GB   2097MB  logical
 9      191GB   250GB   59.2GB  logical   ext4


Backtrace has 14 calls on stack:
  14: /lib/libparted.so.0(ped_assert+0x2a) [0x4a7cca]
  13: /lib/libparted.so.0(+0x41065) [0x4dd065]
  12: /lib/libparted.so.0(+0x41924) [0x4dd924]
  11: /lib/libparted.so.0(+0x42433) [0x4de433]
  10: /lib/libparted.so.0(+0x1029f) [0x4ac29f]
  9: /lib/libparted.so.0(ped_disk_add_partition+0x202) [0x4af802]
  8: /lib/libparted.so.0(+0x443cd) [0x4e03cd]
  7: /lib/libparted.so.0(+0x4560f) [0x4e160f]
  6: /lib/libparted.so.0(ped_disk_new+0x62) [0x4afce2]
  5: parted() [0x804e65f]
  4: parted() [0x804f690]
  3: parted(main+0x1947) [0x804d4b7]
  2: /lib/libc.so.6(__libc_start_main+0xf3) [0x25a513]
  1: parted() [0x804d509]
                                                                          

You found a bug in GNU Parted! Here's what you have to do:

Don't panic! The bug has most likely not affected any of your data.
Help us to fix this bug by doing the following:

Check whether the bug has already been fixed by checking
the last version of GNU Parted that you can find at:

  http://ftp.gnu.org/gnu/parted/

Please check this version prior to bug reporting.

If this has not been fixed yet or if you don't know how to check,
please visit the GNU Parted website:

  http://www.gnu.org/software/parted

for further information.

Your report should contain the version of this release (2.3)
along with the error message below, the output of

  parted DEVICE unit co print unit s print

and the following history of commands you entered.
Also include any additional information about your setup you
consider important.

Assertion (head_size <= 63) at dos.c:661 in function probe_partition_for_geom()
failed.

Aborted
Comment 7 Brian Lane 2011-05-26 09:43:12 EDT
This typically happens with a USB stick plugged in. You can fix it by wiping out the previous partitions (and the data) with dd if=/dev/zero of=/dev/DEVICE bs=1M count=1

parted should then run fine and you can re-partition it.

*** This bug has been marked as a duplicate of bug 704669 ***
Comment 8 Tommy Surbakti 2011-05-30 15:03:02 EDT
Created attachment 915319 [details]
Comment

(This comment was longer than 65,535 characters and has been moved to an attachment by Red Hat Bugzilla).

Note You need to log in before you can comment on or make changes to this bug.