Bug 707351 - parted crash while attempting F14->F15 preupgrade
parted crash while attempting F14->F15 preupgrade
Status: CLOSED DUPLICATE of bug 704669
Product: Fedora
Classification: Fedora
Component: parted (Show other bugs)
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2011-05-24 15:29 EDT by Kyle Pablo
Modified: 2011-05-27 16:58 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2011-05-27 15:18:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
ks.cfg (293 bytes, text/plain)
2011-05-24 15:30 EDT, Kyle Pablo
no flags Details
syslog (99.25 KB, text/plain)
2011-05-24 15:32 EDT, Kyle Pablo
no flags Details
screenshot (29.37 KB, image/jpeg)
2011-05-24 15:33 EDT, Kyle Pablo
no flags Details
anaconda.log (4.46 KB, text/plain)
2011-05-24 15:36 EDT, Kyle Pablo
no flags Details
program.log (1.77 KB, text/plain)
2011-05-24 15:36 EDT, Kyle Pablo
no flags Details
storage.log (8.18 KB, text/plain)
2011-05-24 15:37 EDT, Kyle Pablo
no flags Details
X.log (24.90 KB, text/plain)
2011-05-24 15:37 EDT, Kyle Pablo
no flags Details
better screenshot? (1.75 MB, image/jpeg)
2011-05-24 18:42 EDT, Kyle Pablo
no flags Details
parted -l output (29.00 KB, application/msword)
2011-05-24 22:35 EDT, Kyle Pablo
no flags Details
screentshot actual output (29.50 KB, application/msword)
2011-05-24 22:37 EDT, Kyle Pablo
no flags Details

  None (edit)
Description Kyle Pablo 2011-05-24 15:29:57 EDT
Description of problem:
Preupgrade failed on reboot due to parted crash.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. preupgrade
2. reboot
3. parted crashes
Actual results:

Expected results:

Additional info:
Comment 1 Kyle Pablo 2011-05-24 15:30:34 EDT
Created attachment 500682 [details]
Comment 2 Kyle Pablo 2011-05-24 15:32:32 EDT
Created attachment 500683 [details]
Comment 3 Kyle Pablo 2011-05-24 15:33:30 EDT
Created attachment 500684 [details]
Comment 4 Kyle Pablo 2011-05-24 15:36:02 EDT
Created attachment 500685 [details]
Comment 5 Kyle Pablo 2011-05-24 15:36:40 EDT
Created attachment 500686 [details]
Comment 6 Kyle Pablo 2011-05-24 15:37:10 EDT
Created attachment 500687 [details]
Comment 7 Kyle Pablo 2011-05-24 15:37:47 EDT
Created attachment 500688 [details]
Comment 8 James Laska 2011-05-24 15:39:17 EDT
(In reply to comment #3)
> Created attachment 500684 [details]
> screenshot

Another screenshot is available at http://yfrog.com/i3100mediaimag0015j
Comment 9 Brian Lane 2011-05-24 16:28:06 EDT
That tiny image is really quite useless. Can you get a better one?

Also, on the running system what does parted -l do? If this is the CHS guessing bug then it should blow up as well.
Comment 10 Kyle Pablo 2011-05-24 18:42:51 EDT
Created attachment 500711 [details]
better screenshot?

This one should be better.  The original was compressed in size and resolution.
Comment 11 Kyle Pablo 2011-05-24 18:46:18 EDT
Does it matter if I do 'parted -l' or 'parted /dev/sda -s p | tee /mnt/usb/parted.sda'
Comment 12 Brian Lane 2011-05-24 18:52:57 EDT
Either is fine, if it is the CHS bug it will be obvious.
Comment 13 Kyle Pablo 2011-05-24 22:35:56 EDT
Created attachment 500722 [details]
parted -l output
Comment 14 Kyle Pablo 2011-05-24 22:37:46 EDT
Created attachment 500723 [details]
screentshot actual output
Comment 15 James Laska 2011-05-25 08:32:35 EDT
(In reply to comment #13)
> Created attachment 500722 [details]
> parted -l output

Hi Kyle, thanks for the attachment.  Please note, most developers aren't huge
fans of attaching text/plain output as a word document.  I've converted your
attachment to a simple text document, and included it below to aid any other tests in finding this issue when searching for known failures.

Number Start   End    Size   Type     File system  Flags

1      1049kB  525MB  524MB  primary  ext4         boot
2      525MB   160GB  160GB  primary               lvm
Backtrace has 13 calls on stack:
13: /lib64/libparted.so.0(ped_assert+0x2e) [0x7f2c8002babe]
12: /lib64/libparted.so.0(+0x3c036) [0x7f2c80055036]
11: /lib64/libparted.so.0(+0x3c41e) [0x7f2c8005541e]
10: /lib64/libparted.so.0(+0x3cae6) [0x7f2c80055ae6]
9: /lib64/libparted.so.0(ped_disk_add_partition+0x1a3) [0x7f2c80031873]
8: /lib64/libparted.so.0(+0x3e279) [0x7f2c80057279]
7: /lib64/libparted.so.0(+0x3ef95) [0x7f2c80057f95]
6: /lib64/libparted.so.0(ped_disk_new+0x58) [0x7f2c80031cd8]
5: parted() [0x4071b1]
4: parted() [0x407f7a]
3: parted(main+0x1483) [0x4063c3]
2: /lib64/libc.so.6(__libc_start_main+0xed) [0x7f2c7f83243d]
1: parted() [0x406411]

You found a bug in GNU Parted! Here's what you have to do:
Don't panic! The bug has most likely not affected any of your data.
Help us to fix this bug by doing the following:
Check whether the bug has already been fixed by checking
the last version of GNU Parted that you can find at:
Please check this version prior to bug reporting.
If this has not been fixed yet or if you don't know how to check,
please visit the GNU Parted website:
for further information.
Your report should contain the version of this release (2.3)
along with the error message below, the output of
parted DEVICE unit co print unit s print
and the following history of commands you entered.
Also include any additional information about your setup you
consider important.
Assertion (head_size <= 63) at dos.c:661 in function probe_partition_for_geom()
Aborted (core dumped)
Comment 16 Kyle Pablo 2011-05-27 13:29:30 EDT
Can we get an update on this bug?
Comment 17 Brian Lane 2011-05-27 15:18:01 EDT
Do you have a USB flash drive plugged in? This error is usually seen with factory partitioned USB sticks, and in that case the work around is to erase the partition table using dd if=/dev/zero of=/dev/DEVICE bs=1M count=1 and re-partition it.

I have a new build of parted for f15 in updates-testing that fixes this by removing the assertion when the CHS guess fails.

*** This bug has been marked as a duplicate of bug 704669 ***
Comment 18 Kyle Pablo 2011-05-27 16:40:23 EDT
Yes I do have a a USB flash drive plugged in.  If I unplug it the problem will go away?
Comment 19 Brian Lane 2011-05-27 16:58:55 EDT
Probably so.

Note You need to log in before you can comment on or make changes to this bug.