Bug 707408 - jpegtrans dependency problem
Summary: jpegtrans dependency problem
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: jhead
Version: 15
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Adrian Reber
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-05-24 23:38 UTC by Lane
Modified: 2011-05-29 23:20 UTC (History)
1 user (show)

Fixed In Version: jhead-2.90-4.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-05-25 07:53:01 UTC
Type: ---


Attachments (Terms of Use)

Description Lane 2011-05-24 23:38:36 UTC
It seems there is a dependency problem with jhead in Fedora 15. I used yum to install jhead, tried to auto rotate some images, but got an error about jpegtran not being found. So I used yum to install libjpeg-turbo-utils, and then auto rotate started working. See my command history below:


$ sudo yum install -y jhead
$ jhead -autorot *
sh: jpegtran: command not found

Error : Problem executing specified command
in file 'IMG_0273.JPG'

$ sudo yum provides "*jpegtran"

$ sudo yum install libjpeg-turbo-utils
$ jhead -autorot *
Modified: IMG_0273.JPG

Comment 1 Adrian Reber 2011-05-25 07:53:01 UTC
This has been fixed in rawhide. Also pushing that change to F15. Thanks for the reminder.

*** This bug has been marked as a duplicate of bug 673808 ***

Comment 2 Fedora Update System 2011-05-25 07:57:46 UTC
jhead-2.90-4.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/jhead-2.90-4.fc15

Comment 3 Fedora Update System 2011-05-29 23:20:35 UTC
jhead-2.90-4.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.