Bug 70743 - crash when started with unsupported card
crash when started with unsupported card
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: redhat-config-xfree86 (Show other bugs)
limbo
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Mike A. Harris
:
: 70745 (view as bug list)
Depends On:
Blocks: 67218
  Show dependency treegraph
 
Reported: 2002-08-04 15:17 EDT by Dr. Tilmann Bubeck
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-11 05:25:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lspci -vv (3.51 KB, text/plain)
2002-08-04 16:15 EDT, Dr. Tilmann Bubeck
no flags Details
lspci -vvn (3.12 KB, text/plain)
2002-08-04 16:16 EDT, Dr. Tilmann Bubeck
no flags Details
xf86config as created by redhat-config-xfree86 (3.43 KB, text/plain)
2002-08-04 16:16 EDT, Dr. Tilmann Bubeck
no flags Details
stderr of redhat-config-xfree86 (404 bytes, text/plain)
2002-08-04 16:17 EDT, Dr. Tilmann Bubeck
no flags Details
stderr of startx (5.39 KB, text/plain)
2002-08-04 16:22 EDT, Dr. Tilmann Bubeck
no flags Details
/proc/pci (1.46 KB, text/plain)
2002-08-06 15:24 EDT, Dr. Tilmann Bubeck
no flags Details

  None (edit)
Description Dr. Tilmann Bubeck 2002-08-04 15:17:26 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0.0) Gecko/20020529

Description of problem:
I use a Miro 20 SV graphics card, which is only supported by XFree 3.3.6 and not
4.2. During installation I made a mistake configuring the card, so I wanted to
use redhat-config-xfree86 to configure the card after installation.

I ran into 2 problems:
  
(a) using the old configuration did not start the program but freezes
(b) using --reconfig probed PCI and found a S3 968 (which is right) and tries to
start XFree86 with s3 driver. Because my card is not supported, I ran into
freeze again.

So I had no way to change configuration to make my system work. Maybe there
should be:
(a) a fall back to VGA/VESA if configuration fails
(b) an additional command line option (--vga?) to specify standards to use.




Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Use Miro 20 SV
2. start
3. freeze
	

Actual Results:  Freeze

Expected Results:  Configuration program showing

Additional info:
Comment 1 Mike A. Harris 2002-08-04 15:20:28 EDT
alexl, I'll take this one...  pcitable/Cards db stuff...
Comment 2 Mike A. Harris 2002-08-04 15:21:47 EDT
Please attach your X server config file, and log file from a failed
session start attempt.  Also attach the output of the following commands:

lspci -vvn
lspci -vv

I need both.  Then I can tweak the hw databases to default to a saner
driver.

Thanks in advance.
Comment 3 Dr. Tilmann Bubeck 2002-08-04 16:14:36 EDT
OK, here are the files. However, I dont  think, that you succeed in the PCI
table. I have already looked into the linux kernel source to check how this card
is detected (PCI vendor..). I recognized, that this card tells "S3 968". This is
right (it contains this chip) but this is not enough. It is a "Miro 20 SV" with
a BT485 Ramdac.

I didnt find a way to see, that this PCI card is in fact a "Miro 20 SV" and not
an arbitrary other "S3 968" based.

Hopefully you find a better answer.

Comment 4 Dr. Tilmann Bubeck 2002-08-04 16:15:30 EDT
Created attachment 68824 [details]
lspci -vv
Comment 5 Dr. Tilmann Bubeck 2002-08-04 16:16:10 EDT
Created attachment 68825 [details]
lspci -vvn
Comment 6 Dr. Tilmann Bubeck 2002-08-04 16:16:59 EDT
Created attachment 68826 [details]
xf86config as created by redhat-config-xfree86
Comment 7 Dr. Tilmann Bubeck 2002-08-04 16:17:42 EDT
Created attachment 68827 [details]
stderr of redhat-config-xfree86
Comment 8 Dr. Tilmann Bubeck 2002-08-04 16:22:28 EDT
Created attachment 68828 [details]
stderr of startx
Comment 9 Jeremy Katz 2002-08-04 23:15:07 EDT
*** Bug 70745 has been marked as a duplicate of this bug. ***
Comment 10 Mike A. Harris 2002-08-06 02:13:58 EDT
The linux kernel doesn't have anything to do with detecting
video hardware.  The hwdata package contains the PCI VENDOR/DEVICE ID
translations to device/vendor names, and mappings to drivers.

Your lspci information above appears incomplete.  I need to know the
exact PCI device/vendor and subdevice/subvendor of this specific card
in order to make any hardware database changes that only affect this
card.

00:0b.0 Class 0300: 5333:88f0
	Control: I/O+ Mem+ BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr- Stepping+
SERR- FastB2B-
	Status: Cap- 66Mhz- UDF- FastB2B- ParErr- DEVSEL=medium >TAbort- <TAbort-
<MAbort- >SERR- <PERR-
	Interrupt: pin A routed to IRQ 9
	Region 0: Memory at 10000000 (32-bit, non-prefetchable) [size=64M]
	Expansion ROM at <unassigned> [disabled] [size=64K]


There is no "Subsystem" field present.
Comment 11 Mike A. Harris 2002-08-06 02:20:15 EDT
Here is the closest entry I've found

0x5333  0x88f0  "Card:S3 968 (generic)" "S3 Inc.|86c968 [Vision 968 VRAM] rev 0"

And a Cards db entry of:

NAME Miro Crystal 20SV
CHIPSET S3 964
SERVER S3
DRIVER s3
CLOCKCHIP icd2061a

Once I've got the sub ID's I can add a specific entry tied to the "vesa"
driver.  XFree86 is dead - permanently dead.
Comment 12 Dr. Tilmann Bubeck 2002-08-06 15:20:27 EDT
Thats what I wanted to say. If you look at /usr/src/linux/include/linux/pci_id.h
then you find the same mappings of PCI Vendor/DEVICE. And it says S3/968 and NOT
Miro... However.

Sorry. I havn't changed the output of lspci in any way. I did not delete
subsystem or anything else.

How can I send you the information you are requesting?

I attached /proc/pci in case this helps..

Comment 13 Dr. Tilmann Bubeck 2002-08-06 15:24:53 EDT
Created attachment 69144 [details]
/proc/pci
Comment 14 Mike A. Harris 2002-08-11 05:22:29 EDT
The company who made the "card" is not important (Miro).  What is important,
is what the video chipset on the card is "S3 xxx".  The chip is programmed,
and the name of the company can be anything, the chip is still the same
chip.  That is why it does not say "Miro", because there is no such thing
as a "Miro" graphics chip.
Comment 15 Mike A. Harris 2002-08-11 05:24:59 EDT
Oops:

>Once I've got the sub ID's I can add a specific entry tied to the "vesa"
>driver.  XFree86 is dead - permanently dead.

I meant to say "XFree86 3.3.6 is dead" not "XFree86 is dead"... duh duh duh.

;O)
Comment 16 Mike A. Harris 2002-08-11 05:33:51 EDT
The hwdata Cards database has been updated to point this card entry
to use the "vesa" driver.  hwdata 0.42 in rawhide contains this update

Note You need to log in before you can comment on or make changes to this bug.