Bug 70760 - eth0/eth1 swapped in Anaconda vs regular post-install boot
Summary: eth0/eth1 swapped in Anaconda vs regular post-install boot
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: kernel (Show other bugs)
(Show other bugs)
Version: limbo
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
: 70761 (view as bug list)
Depends On:
Blocks: 67218
TreeView+ depends on / blocked
 
Reported: 2002-08-04 23:49 UTC by Dax Kelson
Modified: 2007-04-18 16:45 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-14 19:07:30 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Dax Kelson 2002-08-04 23:49:06 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020712

Description of problem:
This is with limbo2:

On a new Dell Inspiron 4150 with builtin 10/100 ethernet and wireless ethernet
ALT-F4 showed the wireless as eth0 and wired as eth1)

After the install finished, I booted into Limbo and the wired interface was eth0
and the wireless eth1!

The wired interface (using module 3c59x, lspci -v):

02:00.0 Ethernet controller: 3Com Corporation 3c905C-TX/TX-M [Tornado] (rev 78)
        Subsystem: Dell Computer Corporation: Unknown device 012a
        Flags: bus master, medium devsel, latency 32, IRQ 11
        I/O ports at ec80 [size=128]
        Memory at f8fffc00 (32-bit, non-prefetchable) [size=128]
        Expansion ROM at f9000000 [disabled] [size=128K]
        Capabilities: <available only to root>

The wireless interface (using wvlan_cs, cardctl ident):

Socket 2:
  product info: "Dell", "TrueMobile 1150 Series PC Card", "Version 01.01", ""
  manfid: 0x0156, 0x0002
  function: 6 (network)


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Commence installation of Limbo2
2.Make note of eth0/eth1 mappings to hardware
3.After install, boot into Limbo2 and note different mappings
	

Actual Results:  In Anaconoda:
* eth0 == Wireless card
* eth1 == 3Com card

After the installation, they were swapped.

Expected Results:  I would expect that Anaconda's detection of and presentation
of ethernet interfaces to be exactly the same as a regular, post-install boot.

Additional info:

Comment 1 Jeremy Katz 2002-08-05 03:19:53 UTC
How did you boot the installer?  Using one bootnet.img/pcmcia.img or the CD?

Comment 2 Dax Kelson 2002-08-05 04:12:33 UTC
The CD. 
 
Also, on a completely different desktop machine with a RealTek PCI card, and a Cisco 
wireless Aironet PCI card, I observed the same behavior of eth0/eth1 swapping. That 
machine was booted via the CD and used "askmethod" for an NFS install.

Comment 3 Barry K. Nathan 2002-08-08 10:55:11 UTC
FWIW, I've observed this with Red Hat 7.3 (booting from CD) but never got a
chance to report it...

Comment 4 Dax Kelson 2002-08-12 04:53:32 UTC
I did another clean install of Limbo2 on my lapotp. I booted from the cdrom, 
and did a cdrom install (custom).

When it got the network configuration screen, I went out the kernel dmesg 
screen (ALT-F4??) and verified that they were swapped compared to what post 
install is.

Dax

Comment 5 Michael Fulbright 2002-08-14 16:36:37 UTC
This has to do with the different order we probe in a laptop display for network
hw, and on post-install where we bring up pcmcia network hw later.

We'll remove wvlan from the modules in the installer since we don't support it
anyways.

Comment 6 Michael Fulbright 2002-08-14 16:37:44 UTC
*** Bug 70761 has been marked as a duplicate of this bug. ***

Comment 7 Dax Kelson 2002-08-14 19:03:19 UTC
Please note that I have ALSO observed the behavior (see 2nd comment) on a
desktop PC that had two PCI network cards, one of them was a 802.11b PCI card.

Comment 8 Jeremy Katz 2002-08-14 19:07:26 UTC
wireless modules pulled from install disks

Comment 9 Jay Turner 2002-09-04 14:53:54 UTC
All wireless modules have indeed been removed.  Closing out.


Note You need to log in before you can comment on or make changes to this bug.