Bug 707699 - [abrt] ibus-1.3.99.20110408-3.fc15: connection.py:630:call_blocking:DBusException: org.freedesktop.DBus.Error.Failed: Can not find engine mozc-jp.
[abrt] ibus-1.3.99.20110408-3.fc15: connection.py:630:call_blocking:DBusExcep...
Status: CLOSED DUPLICATE of bug 707370
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
15
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: fujiwara
Fedora Extras Quality Assurance
abrt_hash:ea973684df2742e45b524a22f36...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-25 13:49 EDT by Vincent Beers
Modified: 2011-05-25 22:13 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-25 22:13:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vincent Beers 2011-05-25 13:49:13 EDT
abrt version: 2.0.1
architecture:   x86_64
cmdline:        /usr/bin/python /usr/share/ibus/ui/gtk/main.py
comment:        Errored when I tried to select the Mozc Japanese input method shortly after I added it to the list of input methods.
component:      ibus
executable:     /usr/share/ibus/ui/gtk/main.py
kernel:         2.6.38.6-27.fc15.x86_64
os_release:     Fedora release 15 (Lovelock)
package:        ibus-1.3.99.20110408-3.fc15
reason:         connection.py:630:call_blocking:DBusException: org.freedesktop.DBus.Error.Failed: Can not find engine mozc-jp.
time:           Wed May 25 19:41:43 2011
uid:            500
username:       vincent

backtrace:
:connection.py:630:call_blocking:DBusException: org.freedesktop.DBus.Error.Failed: Can not find engine mozc-jp.
:
:Traceback (most recent call last):
:  File "/usr/share/ibus/ui/gtk/panel.py", line 526, in __im_menu_item_activate_cb
:    self.__focus_ic.set_engine(engine)
:  File "/usr/lib/python2.7/site-packages/ibus/inputcontext.py", line 238, in set_engine
:    return self.__context.SetEngine(engine.name)
:  File "/usr/lib/python2.7/site-packages/dbus/proxies.py", line 140, in __call__
:    **keywords)
:  File "/usr/lib/python2.7/site-packages/dbus/connection.py", line 630, in call_blocking
:    message, timeout)
:DBusException: org.freedesktop.DBus.Error.Failed: Can not find engine mozc-jp.
:
:Local variables in innermost frame:
:byte_arrays: False
:self: <dbus.connection.Connection object at 0x2e2fad0>
:args: (dbus.String(u'mozc-jp'),)
:utf8_strings: False
:bus_name: 'org.freedesktop.IBus'
:get_args_opts: {'byte_arrays': False, 'utf8_strings': False}
:object_path: dbus.ObjectPath('/org/freedesktop/IBus/InputContext_1')
:timeout: -1.0
:signature: u's'
:dbus_interface: 'org.freedesktop.IBus.InputContext'
:message: <dbus.lowlevel.MethodCallMessage object at 0x2d97a50>
:method: 'SetEngine'
Comment 1 fujiwara 2011-05-25 22:13:17 EDT
Very curious. I could see the similar bugs in this month but I cannot reproduce your problem at all.
How do you reproduce your problem?
Which text application do you use?
Does it depend on the machine spec?

*** This bug has been marked as a duplicate of bug 707370 ***

Note You need to log in before you can comment on or make changes to this bug.