Bug 707370 - [abrt] ibus-1.3.99.20110408-3.fc15: connection.py:630:call_blocking:DBusException: org.freedesktop.DBus.Error.Failed: Can not find engine xkb:layout:fr.
[abrt] ibus-1.3.99.20110408-3.fc15: connection.py:630:call_blocking:DBusExcep...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
15
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: fujiwara
Fedora Extras Quality Assurance
abrt_hash:7a053d8d28cadbd95384f531005...
:
: 707699 709313 709836 710991 717845 720567 722682 723731 727073 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-24 16:40 EDT by Laurent Wandrebeck
Modified: 2011-08-18 22:27 EDT (History)
15 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-18 22:27:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Hardware info Vincent Beers (54.06 KB, text/plain)
2011-08-01 10:40 EDT, Vincent Beers
no flags Details

  None (edit)
Description Laurent Wandrebeck 2011-05-24 16:40:24 EDT
abrt version: 2.0.1
architecture:   x86_64
cmdline:        /usr/bin/python /usr/share/ibus/ui/gtk/main.py
comment:        trying to switch from fr keyboard layout under gnome 3 to fr (bpo). gnome asked me to disconnect so ibus could be restarted. did so, still in fr in gdm, logged into gnome, clicked on the keyboard icon top right, selected fr, got this error.
component:      ibus
executable:     /usr/share/ibus/ui/gtk/main.py
kernel:         2.6.38.6-27.fc15.x86_64
os_release:     Fedora release 15 (Lovelock)
package:        ibus-1.3.99.20110408-3.fc15
reason:         connection.py:630:call_blocking:DBusException: org.freedesktop.DBus.Error.Failed: Can not find engine xkb:layout:fr.
time:           Tue May 24 22:36:40 2011
uid:            500
username:       low

backtrace:
:connection.py:630:call_blocking:DBusException: org.freedesktop.DBus.Error.Failed: Can not find engine xkb:layout:fr.
:
:Traceback (most recent call last):
:  File "/usr/share/ibus/ui/gtk/panel.py", line 526, in __im_menu_item_activate_cb
:    self.__focus_ic.set_engine(engine)
:  File "/usr/lib/python2.7/site-packages/ibus/inputcontext.py", line 238, in set_engine
:    return self.__context.SetEngine(engine.name)
:  File "/usr/lib/python2.7/site-packages/dbus/proxies.py", line 140, in __call__
:    **keywords)
:  File "/usr/lib/python2.7/site-packages/dbus/connection.py", line 630, in call_blocking
:    message, timeout)
:DBusException: org.freedesktop.DBus.Error.Failed: Can not find engine xkb:layout:fr.
:
:Local variables in innermost frame:
:byte_arrays: False
:self: <dbus.connection.Connection object at 0x2269ad0>
:args: (dbus.String(u'xkb:layout:fr'),)
:utf8_strings: False
:bus_name: 'org.freedesktop.IBus'
:get_args_opts: {'byte_arrays': False, 'utf8_strings': False}
:object_path: dbus.ObjectPath('/org/freedesktop/IBus/InputContext_1')
:timeout: -1.0
:signature: u's'
:dbus_interface: 'org.freedesktop.IBus.InputContext'
:message: <dbus.lowlevel.MethodCallMessage object at 0x241fb58>
:method: 'SetEngine'
Comment 1 fujiwara 2011-05-24 21:41:42 EDT
Which text applications do you use to see your problem?
Do you always encounter your problem?

I cannot reproduce your problem. I guess you use GNOME but not KDE.
The IBus engine enables the layouts when the engine is enabled with Ctrl+Space.
If you'd like to configure the default layout, you could launch 'gnome-control-center region' or use the 'Advanced' tab in ibus-setup.
Comment 2 fujiwara 2011-05-25 22:13:17 EDT
*** Bug 707699 has been marked as a duplicate of this bug. ***
Comment 3 Jens Petersen 2011-05-26 01:44:25 EDT
Could you please describe in detail step-by-step how to reproduce this?
Comment 4 Vincent Beers 2011-05-26 02:53:22 EDT
For me (from duplicate bug #707699) it went like this:

1. Install Fedora 15 from a 64-bit install disk.
2. Choose to install additional packages during install.
3. Select ibus mozc-jp and ibus Anthy packages.
4. Have Fedora re-own an old /home partition that was previously used in Ubuntu.
5. Once everything has installed and booted properly, add the input methods in the configuration (because they weren't there).
6. Try switching to the input method using the top-right icon. You don't actually have to press ctrl+space yet, just select it from the list.

mozc-jp did not work. Anthy shows up but doesn't seem to work (input is set to Hiragana but I'd still type plain text in all apps).

It also has to be noted that I deleted ~/.local, ~/.config and ~/.gnome2 afterwards, and I haven't tested if mozc-jp now works yet.

I'm not sure if I somehow botched ~ beyond repair because I migrated it from Ubuntu. I may add a test account to check if that fixes anything.
Comment 5 fujiwara 2011-05-26 05:35:53 EDT
Hi

(In reply to comment #4)
> For me (from duplicate bug #707699) it went like this:

I guess your steps are not related with your problem.

Which text application do you use?
Does your problem depend on the machine spec?
Does XKB work on your host?

% /usr/libexec/ibus-xkb --get
layout: us,jp
model: ,
option: ctrl:swapcaps,grp:shift_caps_toggle

How about running ibus-daemon by manual?

1. Choose [Quit] on ibus panel right click menu.
2. Run ibus-daemon
% ibus-daemon --xim
Comment 6 Vincent Beers 2011-05-26 06:10:43 EDT
(In reply to comment #5)
> Which text application do you use?
The text applications I have tried are Firefox, Geany, Xfce terminal. It doesn't seem to be a part of the problem.

$ /usr/libexec/ibus-xkb --get
layout: us,jp
model: intl,
option: grp:shift_caps_toggle

jp wasn't there at first so I installed it using Fedora's region settings (as a keyboard layout, probably the wrong way to go about it but it worked).

I uninstalled all Japanese input engines and ibus itself, then reinstalled both ibus and just Anthy. It seems to have had zero effect - it still crashes with "can not find Anthy".

Surprisingly, ibus also no longer starts by itself. I actually have to start ibus-daemon in a terminal. Including or excluding --xim doesn't seem to make a difference.

> Does your problem depend on the machine spec?
I have no clue what to look for, but I am installing x86_64 packages on a 64-bit machine.
Comment 7 fujiwara 2011-05-26 23:59:38 EDT
Thanks for the check but your condition is still not clarified for me.

(In reply to comment #6)
> > Which text application do you use?
> The text applications I have tried are Firefox, Geany, Xfce terminal. It
> doesn't seem to be a part of the problem.

OK, I see. I don't see any problems with firefox and geany and gnome-terminal.
Which desktop do you use? GNOME, XFCE or KDE?

# rpm -qa | grep imsettings
imsettings-libs-1.2.2-3.fc15.x86_64
imsettings-xfce-1.2.2-3.fc15.x86_64
imsettings-gnome-1.2.2-3.fc15.x86_64
imsettings-1.2.2-3.fc15.x86_64
imsettings-qt-1.2.2-3.fc15.x86_64

How about setting GTK_IM_MODULE?
% env GTK_IM_MODULE=ibus gnome-terminal --disable-factory

> keyboard layout, probably the wrong way to go about it but it worked).

Looks good.

> I uninstalled all Japanese input engines and ibus itself, then reinstalled both
> ibus and just Anthy. It seems to have had zero effect - it still crashes with
> "can not find Anthy".
> 
> Surprisingly, ibus also no longer starts by itself. I actually have to start
> ibus-daemon in a terminal. Including or excluding --xim doesn't seem to make a
> difference.

I guess your installation might be failed.
If you run im-chooser, does it set ibus?
% cat $HOME/.xinputrc

Do you see any errors in $HOME/.imsettings.log ?

I wonder if there are any different errors between auto-run and ibus-daemon by manual.

> > Does your problem depend on the machine spec?
> I have no clue what to look for, but I am installing x86_64 packages on a
> 64-bit machine.

I mean, I'm interested if your machine spec is too faster or too slower as I don't see any problems.
Comment 8 Vincent Beers 2011-05-27 10:23:14 EDT
I use GNOME and Xfce, and also have LXDE installed in case I need something light.

~/.xinputrc didn't exist so I touched it. ~/.imsettings.log only shows a warning about how it can't load the LXDE config file. im-chooser was set to "None", so I fixed that and logged in again.

Initially, it couldn't find Anthy, but when I switched to English (US) and then back to Anthy, it suddenly started working! I'm thinking there was indeed a problem with my install (possibly to do with migrating /home from a different distro install, even though a clean user had the same errors).

So it works now after im-chooser and creating ~/.xinputrc, but if you still need all the info you requested I'll provide it.
Comment 9 fujiwara 2011-05-30 03:01:08 EDT
(In reply to comment #8)
> Initially, it couldn't find Anthy, but when I switched to English (US) and then
> back to Anthy, it suddenly started working! I'm thinking there was indeed a
> problem with my install (possibly to do with migrating /home from a different
> distro install, even though a clean user had the same errors).

Do you mean the SetEngine error is reported in comment #0 whenever you log into GNOME desktop?

> (In reply to comment #0)
> > :  File "/usr/lib/python2.7/site-packages/dbus/connection.py", line 630, in
> > :DBusException: org.freedesktop.DBus.Error.Failed: Can not find engine
> > 
> > :method: 'SetEngine'

How about restarting ibus?
1. Right click on ibus panel icon.
2. Choose "Restart" menu item

Are you able to test your GNOME desktop with a new account besides the current account?

> but if you still need all the info you requested I'll provide it.

Yes, it still makes sense to evaluate your problem.
Comment 10 fujiwara 2011-06-01 21:25:59 EDT
*** Bug 709313 has been marked as a duplicate of this bug. ***
Comment 11 fujiwara 2011-06-15 01:14:22 EDT
*** Bug 710991 has been marked as a duplicate of this bug. ***
Comment 12 James 2011-06-17 11:35:16 EDT
Package: ibus-1.3.99.20110408-2.fc15
Architecture: i686
OS Release: Fedora release 15 (Lovelock)


Comment
-----
enable ibus and Pinyin
restart ibus
click Pinyin then crash
Comment 13 falsedust 2011-07-07 02:18:10 EDT
Package: ibus-1.3.99.20110419-7.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)

Comment
-----
changing from english input to chinese pinyin, also the ctrl+space doesn't work to change the input method.
Comment 14 falsedust 2011-07-07 02:20:47 EDT
Package: ibus-1.3.99.20110419-7.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)

Comment
-----
changing from english input to chinese pinyin, also the ctrl+space doesn't work to change the input method.
Comment 15 fujiwara 2011-07-21 21:33:51 EDT
*** Bug 709836 has been marked as a duplicate of this bug. ***
Comment 16 fujiwara 2011-07-21 21:36:22 EDT
*** Bug 717845 has been marked as a duplicate of this bug. ***
Comment 17 fujiwara 2011-07-31 22:27:07 EDT
*** Bug 723731 has been marked as a duplicate of this bug. ***
Comment 18 fujiwara 2011-07-31 22:28:31 EDT
*** Bug 722682 has been marked as a duplicate of this bug. ***
Comment 19 fujiwara 2011-07-31 22:29:39 EDT
*** Bug 720567 has been marked as a duplicate of this bug. ***
Comment 20 Vincent Beers 2011-08-01 10:40:28 EDT
Created attachment 516157 [details]
Hardware info Vincent Beers

Sorry for this late reply. I've been very busy and almost forgot about the bug!

I had to reinstall Fedora at some point. This time, I made sure to do an install that's as clean as possible (no extra packages selected during install), however, the same problem still exists.

I have since found that the error is kind of random: sometimes, ibus will crash with messages similar to what's posted earlier in this thread. This happens on *any* input method installed. Then, other times, it will suddenly "accept" the fact that there *is* something install and properly switch to Anthy (or even just default the English US input, if I select it). It also has to be noted that I have more success getting it to run in Gnome 3 than anything else (I use Enlightenment a lot nowadays, which has some other integration issues anyway).

A hardinfo report is attached (because I totally forgot the terminal command that outputs hardware info... Scatterbrain).
Comment 21 fujiwara 2011-08-08 04:05:11 EDT
*** Bug 727073 has been marked as a duplicate of this bug. ***
Comment 22 fujiwara 2011-08-15 04:00:11 EDT
I added an enhancement for SetEngine method.
It would be nice to try ibus-1.3.99.20110419-13.fc15 .
Comment 23 Vincent Beers 2011-08-16 10:10:24 EDT
The enhancement seems to be working! I have switched and entered text with two different input engines and with the default "disabled" engine successfully so far, in Xfce. Thank you very much.

I will test in Enlightenment soon, too, but I get the feeling there is a different problem here. I should probably file/find a bug about that if the input method switching still doesn't work at all in there.
Comment 24 Vincent Beers 2011-08-16 12:58:56 EDT
Enlightenment fails, but I get the feeling that this is not necessarily ibus's problem.
Comment 25 Akira TAGOH 2011-08-17 01:21:18 EDT
How did it fail? better attach .imsettings.log into the bug. that would speed up to investigate the issue.
Comment 26 fujiwara 2011-08-17 01:37:17 EDT
(In reply to comment #24)
> Enlightenment fails, but I get the feeling that this is not necessarily ibus's
> problem.

I could enable ibus with Enlightenment.
Left click on desktop -> Configuration -> Configuration Panel -> Language -> Setting Input Method -> Advanced -> New

Name: IBus
Exec command: ibus-daemon --xim
Configuration command: ibus-setup
GTK_IM_MODULE: ibus
QT_IM_MODULE: ibus
XMODIFIERS: ibus

I can use ibus without any problems with Enlightenment.
Comment 27 Vincent Beers 2011-08-17 14:36:43 EDT
(In reply to comment #26)
Thank you! That did indeed help. Just running ibus-daemon from the terminal and trying the "input method selector" menu option wouldn't work in Enlightenment, but defining it in the input method config for Enlightenment itself does the trick.

I have stumbled across a new bug, though. Cross-window manager. I have "share the same input among all applications" checked, but every time I open a new tab or window it automatically switches to Anthy (Japanese input), anyway, even if the other window was set to English or none.

Should I file a new bug instead? I am not sure if it is related at all to this specific bug, which seems to be fixed, after all. (The IM will always start up now without complaining.)
Comment 28 fujiwara 2011-08-18 22:27:03 EDT
(In reply to comment #27)
> I have stumbled across a new bug, though. Cross-window manager. I have "share
> the same input among all applications" checked, but every time I open a new tab
> or window it automatically switches to Anthy (Japanese input), anyway, even if
> the other window was set to English or none.
> 
> Should I file a new bug instead? I am not sure if it is related at all to this
> specific bug, which seems to be fixed, after all. (The IM will always start up
> now without complaining.)

Thanks. I thinks it's bug 731610. Will fix it asap.

Note You need to log in before you can comment on or make changes to this bug.