Bug 70780 - ATI Radeon Mobility LW (AGP) screen garbled after resume
ATI Radeon Mobility LW (AGP) screen garbled after resume
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
8.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
: 72183 (view as bug list)
Depends On:
Blocks: 82776
  Show dependency treegraph
 
Reported: 2002-08-05 01:28 EDT by Dax Kelson
Modified: 2007-04-18 12:45 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-04-26 22:20:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
My anaconda generated /etc/X11/XF86Config (3.24 KB, text/plain)
2002-08-13 11:05 EDT, Dax Kelson
no flags Details
My normal XF86 log, without trying a suspend, everything is ok (26.92 KB, text/plain)
2002-08-13 23:49 EDT, Dax Kelson
no flags Details

  None (edit)
Description Dax Kelson 2002-08-05 01:28:25 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020724

Description of problem:
With limbo2

On this brand new Dell Inspiron 4150 with a ATI Radeon Mobility 7500, after a
standby or suspend, the screen is completely garbled and changing in a
psychedelic orgy. The machine isn't wedged though, and I can do a CNTRL-ATL-F1,
and then CTRL-ALT-DEL to do a graceful reboot.

PCI:*(1:0:0) ATI Radeon Mobility M7 LW rev 0, Mem @ 0xe0000000/27,
0xfcff0000/16, I/O @ 0xc000/8

1:00.0 VGA compatible controller: ATI Technologies Inc Radeon Mobility M7 LW
(prog-if 00 [VGA])
        Subsystem: Dell Computer Corporation: Unknown device 012b
        Flags: bus master, VGA palette snoop, stepping, 66Mhz, medium devsel,
latency 32, IRQ 11
        Memory at e0000000 (32-bit, prefetchable) [size=128M]
        I/O ports at c000 [size=256]
        Memory at fcff0000 (32-bit, non-prefetchable) [size=64K]
        Expansion ROM at <unassigned> [disabled] [size=128K]
        Capabilities: [58] AGP version 2.0
        Capabilities: [50] Power Management version 2


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Boot to runlevel 5
2.Wait until the screen blanks
3.Move the mouse, observe the chaos.
	

Actual Results:  see above

Expected Results:  no screen garbling.

Additional info:

I'm running at 1400 x 1050. The card has 32MB of ram. As long as I don't let it
standby/suspend, everything seems great. I've tried some of the included 3D apps
like TuxRacer, and other with no problems.

If I go to a text terminal (CTRL-ATL-F1), before the suspend/standby then after
it resumes, can go back to X (CTRL-ALT-F7) and it restores OK.
Comment 1 Mike A. Harris 2002-08-06 01:27:56 EDT
Attach Logs+configs using the link below please.
Comment 2 Dax Kelson 2002-08-13 11:05:03 EDT
Created attachment 70364 [details]
My anaconda generated /etc/X11/XF86Config
Comment 3 Dax Kelson 2002-08-13 23:49:15 EDT
Created attachment 70486 [details]
My normal XF86 log, without trying a suspend, everything is ok
Comment 4 Dax Kelson 2002-08-21 02:16:29 EDT
Hurray! In Null suspend/resume/standby etc work great. The video restores 
properly.
Comment 5 Mike A. Harris 2002-08-21 08:50:53 EDT
For the record, nothing has changed in X which would result in this
problem being resolved.  Whatever the problem was, it must have been
fixed by kernel update/apmd update or something else.

Glad it's working for you now, but just wanted you to know it was
not an XFree86 bug likely.
Comment 6 Dax Kelson 2002-08-22 03:18:20 EDT
Ok, although the graphics restore properly after a 'apm -s' or 'apm -S', the 
graphics do NOT restore after a screen blank. 
 
I started celebrating to early. 
 
I'm able to do a CTL-ALT-F1, and then do a CTRL-ALT-DEL to do a graceful 
shutdown. Even after the CTL-ALT-F1, the screen is still garbled. In fact is 
it moving/dynamic garbling. 
 
What is interesting, is for about 1 second right before the reboot happens, 
the screen returns to normal, and I can see the output of from the SysV init 
shutdown process ([  OK  ]'s etc).
Comment 7 Dax Kelson 2002-08-23 00:48:47 EDT
Something else I noticed. As long as the laptop is plugged into the wall no 
problems when the screensaver/blanking kicks in and restores. 
 
Only when it is on battery power and it blanks (after not a few minutes elapse 
with no user interaction) does the screen garble on restore. 
Comment 8 Kjartan Maraas 2002-08-26 16:49:24 EDT
I see graphic "noise" on the cursor after suspending from X. If I do it from the
console I get garbled output on the console. What's kindof weird is that when I
suspend the screen gets brighter, and over time it blacks out again. Looks like
all LCD isn't being nulled out properly. This has been the same over various
BIOS upgrades.

I'll attach lspci output and more.
Comment 9 Kjartan Maraas 2002-08-26 16:50:27 EDT
01:00.0 VGA compatible controller: ATI Technologies Inc Radeon Mobility M6 LY

01:00.0 VGA compatible controller: ATI Technologies Inc Radeon Mobility M6 LY
(prog-if 00 [VGA])
        Subsystem: Compaq Computer Corporation: Unknown device b111
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr-
Stepping+ SERR- FastB2B-
        Status: Cap+ 66Mhz+ UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort-
<TAbort- <MAbort- >SERR- <PERR-        Latency: 66 (2000ns min), cache line size 08
        Interrupt: pin A routed to IRQ 11
        Region 0: Memory at 48000000 (32-bit, prefetchable) [size=128M]
        Region 1: I/O ports at 3000 [size=256]
        Region 2: Memory at 40200000 (32-bit, non-prefetchable) [size=64K]
        Expansion ROM at <unassigned> [disabled] [size=128K]
        Capabilities: [58] AGP version 2.0
                Status: RQ=47 SBA+ 64bit- FW- Rate=x1,x2,x4
                Command: RQ=31 SBA+ AGP+ 64bit- FW- Rate=x1
        Capabilities: [50] Power Management version 2
                Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA
PME(D0-,D1-,D2-,D3hot-,D3cold-)
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-
00: 02 10 59 4c 87 00 b0 02 00 00 00 03 08 42 00 00
10: 08 00 00 48 01 30 00 00 00 00 20 40 00 00 00 00
20: 00 00 00 00 00 00 00 00 00 00 00 00 11 0e 11 b1
30: 00 00 00 00 58 00 00 00 00 00 00 00 0b 01 08 00
Comment 10 Tuomo Soini 2002-12-04 03:51:58 EST
Dell Inspiron 4150 bios upgrade from rev A00 to rev A03 didn't help.

Workaround so that machine can be used:
Display timeout: DISABLED
and
Display Close on AC: Suspend
Comment 11 Mike A. Harris 2002-12-04 19:27:27 EST
*** Bug 72183 has been marked as a duplicate of this bug. ***
Comment 12 Dax Kelson 2002-12-04 21:33:29 EST
Another workaround after the screen has garbled:

1. Switch to text terminal: CTL-ALT-F1 (note, the screen garbles stays)
2. Close the lid until the LCD turns off
3. Open the lid (screen is now OK)
4. Return to X: ALT-F7

I left the BIOS at it's default values.

I also tried BIOS A04 (which in the release notes says it has new ATI video
bios) with the same results.
Comment 13 Kjartan Maraas 2003-02-10 09:56:23 EST
Maybe this is interesting:

http://cpbotha.net/dri_resume.html
Comment 14 drew.middlesworth 2003-02-18 23:56:13 EST
I am also seeing the same problem with an Inspiron 4150, and was hoping this
would be fixed before the release of Redhat 8.1. I've tried the latest Phoebe
beta with no luck. Flashing the system bios to A05 also did not help. Closing
the lid to the system and opening it will garble the display, and the only way
to fix the display is to ctl-alt-f1, close the lid, alt-f7, open the lid. 

A similar problem with users of the Rage mobility M3 with the r128 driver was to
add the line to the XF86Config:
Option "Display" "BIOS"
http://www.spinics.net/lists/xf-xpert/msg07580.html
But I don't believe that option is avaliable with the radeon driver

A few other people who also experience this problem
http://www.cs.hmc.edu/~me/linux/dell_inspiron_4150.html
http://users.rcn.com/jdreyer/i4150/
http://perso.wanadoo.es/djsucre/i4150/english.html
http://mypage.iu.edu/~abisen/linux/i4150.html

If any additional information is needed, just let me know
Comment 15 Matthew Saltzman 2003-03-28 15:21:55 EST
Me too, Dell Latitude C640 BIOS A07 ATI Radeon Mobility M7 LW (Radeon Mobility
M7500) 3D acell enabled (haven't tried without).
Comment 16 Matthew Saltzman 2003-04-26 18:49:11 EDT
Appears to be fixed (at least for me) in XFree86-4.3.0-5.
Comment 17 Dax Kelson 2003-04-26 22:20:08 EDT
I installed the XFree86-4.3.0-5 RPMs from Rawhide on my RHL9 install. Tested and
verified that everything seems to be working properly now.

With stock RHL9, my only problem was that -- while on battery -- the
don't-touch-the-mouse/keyboard for 5 min screen blank wouldn't restore the
screen. It would be garbled. The work around was to switch to text VT and
close/open lid.

Now with XFree86-4.3.0-5, no problem!

BTW, my Dell Inspiron 4150 is using the A04 BIOS rev (A05 is latest, I haven't
tried it).
Comment 18 Matthew Saltzman 2003-04-26 22:37:11 EDT
Actually, the suspend-resume problem seems to have been fixed with the original
RPMs in Shrike.  This update fixed the screen-blank problem and made me very happy.

Note You need to log in before you can comment on or make changes to this bug.