Bug 707829 - guest kernel panic when start guest rhel3.9-32bit with 16 vcpus
guest kernel panic when start guest rhel3.9-32bit with 16 vcpus
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kvm (Show other bugs)
5.7
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: Gleb Natapov
Virtualization Bugs
:
: 707865 (view as bug list)
Depends On:
Blocks: Rhel5KvmTier2
  Show dependency treegraph
 
Reported: 2011-05-26 01:54 EDT by FuXiangChun
Modified: 2013-12-08 19:55 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-07-18 05:21:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
kernel panic snapshot (184.95 KB, image/png)
2011-05-26 01:56 EDT, FuXiangChun
no flags Details
bios with "IBM ENSW" mptables oem (128.00 KB, application/octet-stream)
2011-05-30 07:18 EDT, Gleb Natapov
no flags Details

  None (edit)
Description FuXiangChun 2011-05-26 01:54:01 EDT
Description of problem:
 use below two kernels to start guest, guest still is kernel panic.
kernel-hugemem-2.4.21-50.EL.i686.rpm  
kernel-smp-2.4.21-66.EL.i686.rpm


Version-Release number of selected component (if applicable):
#uname -r
2.6.18-262.el5

# rpm -qa|grep kvm
kvm-83-235.el5

How reproducible:


Steps to Reproduce:
1./usr/libexec/qemu-kvm -M rhel5.4.0 -no-hpet -rtc-td-hack -startdate now -name rhel3.9 -smp 16 -m 16G -uuid `uuidgen` -boot c -drive file=/root/images/rhel39.qcow2,media=disk,if=ide,cache=none,boot=on,format=qcow2,werror=stop -net nic,vlan=1,macaddr=F0:4D:A2:3C:b3:9d,model=rtl8139 -net tap,vlan=1,script=/etc/qemu-ifup -cdrom /root/rhel-iso-files/RHEL3.9-i386-DVD.iso -notify all -balloon none -monitor stdio -spice disable-ticketing,port=5911 -qxl 1

2.guest snapshot in attachent
3.
  
Actual results:
guest kernel panic

Expected results:
guest work well and support 16 vcpus

Additional info:
Comment 1 FuXiangChun 2011-05-26 01:56:19 EDT
Created attachment 500985 [details]
kernel panic snapshot
Comment 2 Gleb Natapov 2011-05-30 03:17:01 EDT
*** Bug 707865 has been marked as a duplicate of this bug. ***
Comment 3 Gleb Natapov 2011-05-30 07:18:35 EDT
Created attachment 501784 [details]
bios with "IBM ENSW" mptables oem

Looks like this guest does not really support 16 cpus, only 15. Only some machines are white listed to run with more then 15 cpu. Can you try to run with the bios.bin I attached. I change it to pretend we are one of such machines (although guest will try to use some other HW we do not emulate with this bios, but it should detect that HW is not present and continue).
Comment 4 FuXiangChun 2011-07-18 02:18:06 EDT
according to Comment 3, guest boot successfully, but guest only can identify 13 cpus. 

# uname -r
2.6.18-272.el5

# rpm -qa|grep kvm
kvm-83-239.el5

testing steps:

1.replace orignal bios.bin file with the one Gleb provices in host /usr/share/kvm/bios.bin

2. /usr/libexec/qemu-kvm -M rhel5.4.0 -no-hpet -rtc-td-hack -startdate now -name rhel3.9 -smp 16 -m 16G -uuid `uuidgen` -boot c -drive file=/root/rhel39.qcow2,media=disk,if=ide,cache=none,boot=on,format=qcow2,werror=stop -net nic,vlan=1,macaddr=F0:4D:A2:3C:b3:9d,model=rtl8139 -net tap,vlan=1,script=/etc/qemu-ifup -notify all -balloon none -monitor stdio -spice disable-ticketing,port=5911 -qxl 1

3. choice kernel-smp-2.4.21-66.EL kernel to start guest

4. confirm cpus in guest. 
   cat /proc/cpuinfo
Comment 5 Gleb Natapov 2011-07-18 05:21:08 EDT
OK. So the panic in comment #0 is indeed the guest bug (actually not a bug, but limitation). Why it finds only 13 cpus with modified BIOS is not important since we do not implement this type of machine anyway. Closing as not a bug.

Note You need to log in before you can comment on or make changes to this bug.