Bug 70793 - RSS is wrong
RSS is wrong
Status: CLOSED RAWHIDE
Product: Red Hat Linux Beta
Classification: Retired
Component: kernel (Show other bugs)
beta4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
:
: 71473 (view as bug list)
Depends On:
Blocks: 67217
  Show dependency treegraph
 
Reported: 2002-08-05 08:49 EDT by Tim Waugh
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-15 07:20:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Waugh 2002-08-05 08:49:25 EDT
Description of Problem: 
When viewing process info, RSS shows meaningless numbers. 
 
Version-Release number of selected component (if applicable): 
gnome-system-monitor-2.0.0-2 
 
How Reproducible: 
100% 
 
Steps to Reproduce: 
1. Start app. 
2. Click on a process 
3. Look at the RSS 
 
Actual Results: 
(Examples:) 
Total:  34.8 Mb 
RSS:    752 Mb 
Shared: 16.5 Mb 
 
Total:  34.1 Mb 
RSS:    -1946157056 bytes 
Shared: 16.2 Mb
Comment 1 Havoc Pennington 2002-08-05 11:13:03 EDT
Confirmed.

Upstream is http://bugzilla.gnome.org/show_bug.cgi?id=89927
Comment 2 Havoc Pennington 2002-08-13 21:05:08 EDT
*** Bug 71473 has been marked as a duplicate of this bug. ***
Comment 3 Tim Waugh 2002-08-15 07:20:42 EDT
This turned out to be a kernel bug.  Fixed in 2.4.18-10.98.
Comment 4 Jay Turner 2002-08-16 00:49:59 EDT
Fix confirmed with kernel-2.4.18-11.

Note You need to log in before you can comment on or make changes to this bug.