This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 708601 - LiveCD installation crash in libparted
LiveCD installation crash in libparted
Status: CLOSED DUPLICATE of bug 704669
Product: Fedora
Classification: Fedora
Component: parted (Show other bugs)
15
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-28 05:22 EDT by Clemens Eisserer
Modified: 2011-05-31 12:07 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-31 12:07:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Clemens Eisserer 2011-05-28 05:22:17 EDT
Description of problem:

The following existing partition table drove gparted mad while installing fedora's xfce livecd, using the custom layout partitioning interface.

What I did was:
- Delete sda1, sda5, sda4, sda3
- Create new swap partition at the "end" of the device, use all available space
- Instead of beeing assigned sda3, the new partition was sda2, ntfs suddenly behind it. both sda1 and sda2 had 80GB -> larger than the device is actually.


Disk identifier: 0x000f31d9
   Device Boot      Start         End      Blocks   Id  System
/dev/sda1            2048   188418047    94208000   83  Linux
/dev/sda2   *   205162496   231364607    13101056    7  HPFS/NTFS/exFAT
/dev/sda3       231368704   234440703     1536000   82  Linux swap / Solaris
/dev/sda4       188418048   205162495     8372224    5  Extended
/dev/sda5       188420096   205162495     8371200   83  Linux

Partition table entries are not in disk order

In the end it crashed in libparted:

[root@cebox usb]# /usr/bin/liveinst 
Backtrace has 20 calls on stack:
  20: /lib64/libparted.so.0(ped_assert+0x2e) [0x7f2e7cdf4abe]
  19: /lib64/libparted.so.0(+0x3c036) [0x7f2e7ce1e036]
  18: /lib64/libparted.so.0(+0x3c41e) [0x7f2e7ce1e41e]
  17: /lib64/libparted.so.0(+0x3cae6) [0x7f2e7ce1eae6]
  16: /lib64/libparted.so.0(ped_disk_add_partition+0x1a3) [0x7f2e7cdfa873]
  15: /lib64/libparted.so.0(+0x3e279) [0x7f2e7ce20279]
  14: /lib64/libparted.so.0(+0x3ef95) [0x7f2e7ce20f95]
  13: /lib64/libparted.so.0(ped_disk_new+0x58) [0x7f2e7cdfacd8]
  12: /usr/lib64/python2.7/site-packages/_pedmodule.so(_ped_Disk_init+0x66) [0x7f2e7d073be6]
  11: /usr/lib64/libpython2.7.so.1.0(+0x9d8d8) [0x7f2e8cdd68d8]
  10: /usr/lib64/libpython2.7.so.1.0(PyObject_Call+0x53) [0x7f2e8cd81fe3]
  9: /usr/lib64/libpython2.7.so.1.0(PyEval_EvalFrameEx+0x3b73) [0x7f2e8ce170a3]
  8: /usr/lib64/libpython2.7.so.1.0(PyEval_EvalCodeEx+0x855) [0x7f2e8ce1a125]
  7: /usr/lib64/libpython2.7.so.1.0(+0x6daa3) [0x7f2e8cda6aa3]
  6: /usr/lib64/libpython2.7.so.1.0(PyObject_Call+0x53) [0x7f2e8cd81fe3]
  5: /usr/lib64/libpython2.7.so.1.0(PyEval_EvalFrameEx+0x1340) [0x7f2e8ce14870]
  4: /usr/lib64/libpython2.7.so.1.0(PyEval_EvalCodeEx+0x855) [0x7f2e8ce1a125]
  3: /usr/lib64/libpython2.7.so.1.0(+0x6daa3) [0x7f2e8cda6aa3]
  2: /usr/lib64/libpython2.7.so.1.0(PyObject_Call+0x53) [0x7f2e8cd81fe3]
  1: /usr/lib64/libpython2.7.so.1.0(+0x57b6f) [0x7f2e8cd90b6f]
/usr/sbin/liveinst: line 108:  4233 Aborted                 anaconda-cleanup $ANACONDA $*


localuser:root being added to access control list
17:43:23 Starting graphical installation.
Loading /lib/kbd/keymaps/i386/qwertz/de-latin1-nodeadkeys.map.gz
Backtrace has 20 calls on stack:
  20: /lib64/libparted.so.0(ped_assert+0x2e) [0x7fa39b052abe]
  19: /lib64/libparted.so.0(+0x3c036) [0x7fa39b07c036]
  18: /lib64/libparted.so.0(+0x3c41e) [0x7fa39b07c41e]
  17: /lib64/libparted.so.0(+0x3cae6) [0x7fa39b07cae6]
  16: /lib64/libparted.so.0(ped_disk_add_partition+0x1a3) [0x7fa39b058873]
  15: /lib64/libparted.so.0(+0x3e279) [0x7fa39b07e279]
  14: /lib64/libparted.so.0(+0x3ef95) [0x7fa39b07ef95]
  13: /lib64/libparted.so.0(ped_disk_new+0x58) [0x7fa39b058cd8]
  12: /usr/lib64/python2.7/site-packages/_pedmodule.so(_ped_Disk_init+0x66) [0x7fa39b2d1be6]
  11: /usr/lib64/libpython2.7.so.1.0(+0x9d8d8) [0x7fa3ade388d8]
  10: /usr/lib64/libpython2.7.so.1.0(PyObject_Call+0x53) [0x7fa3adde3fe3]
  9: /usr/lib64/libpython2.7.so.1.0(PyEval_EvalFrameEx+0x3b73) [0x7fa3ade790a3]
  8: /usr/lib64/libpython2.7.so.1.0(PyEval_EvalCodeEx+0x855) [0x7fa3ade7c125]
  7: /usr/lib64/libpython2.7.so.1.0(+0x6daa3) [0x7fa3ade08aa3]
  6: /usr/lib64/libpython2.7.so.1.0(PyObject_Call+0x53) [0x7fa3adde3fe3]
  5: /usr/lib64/libpython2.7.so.1.0(PyEval_EvalFrameEx+0x1340) [0x7fa3ade76870]
  4: /usr/lib64/libpython2.7.so.1.0(PyEval_EvalCodeEx+0x855) [0x7fa3ade7c125]
  3: /usr/lib64/libpython2.7.so.1.0(+0x6daa3) [0x7fa3ade08aa3]
  2: /usr/lib64/libpython2.7.so.1.0(PyObject_Call+0x53) [0x7fa3adde3fe3]
  1: /usr/lib64/libpython2.7.so.1.0(+0x57b6f) [0x7fa3addf2b6f]
[root@cebox usb]# Install




Version-Release number of selected component (if applicable):

The version shipped with the xfce livecd


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:
bogus mapping & crash

Expected results:
should work as expected and not crash

Additional info:
Comment 1 Brian Lane 2011-05-31 12:07:21 EDT

*** This bug has been marked as a duplicate of bug 704669 ***

Note You need to log in before you can comment on or make changes to this bug.