Bug 70922 - gaim works incorrectly with UTF-8
Summary: gaim works incorrectly with UTF-8
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gaim (Show other bugs)
(Show other bugs)
Version: 8.0
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Christopher Blizzard
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 67218 79579 CambridgeTarget
TreeView+ depends on / blocked
 
Reported: 2002-08-06 22:16 UTC by Marc Deslauriers
Modified: 2007-04-18 16:45 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-07-31 12:05:17 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fix for the display problem in utf-8 locales (483 bytes, patch)
2002-09-03 20:07 UTC, Matt Wilson
no flags Details | Diff

Description Marc Deslauriers 2002-08-06 22:16:28 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020804

Description of problem:
When using gaim, accented characters (like i`t) do not show up in message
windows. Doing a LANG=en_US before starting gaim resolves this issue.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Open Gaim
2.Send or receive a message containing accented characters
3.
	

Actual Results:  Received characters do not display. Sent characters are corrupted.

Expected Results:  This must be working, or else it is unuseable.


Additional info:

Comment 1 Warren Togami 2002-08-11 08:08:11 UTC
I could be wrong about this, but isn't gaim still a Gnome 1.4.x application, and
Gnome didn't support UTF-8 back then?

Comment 2 Marc Deslauriers 2002-08-20 21:29:20 UTC
This is still broken in the (null) beta.


Comment 3 Christopher Blizzard 2002-08-30 14:45:40 UTC
Can you try the 0.59.1 build in rawhide?  It included this change (which is
vague, but might help)

        * Now using libiconv for better i18n support (Thanks Junichi
          Uekawa)


Comment 4 Marc Deslauriers 2002-08-30 19:38:12 UTC
Unfortunately, gaim-0.59.1-0 from rawhide did not resolve this issue.


Comment 5 Marc Deslauriers 2002-08-30 22:28:01 UTC
FWIW, I just compiled CVS and the problem is fixed, although I don't know if
it's from being a gtk2 app now or because they fixed utf8 support...

Comment 6 Warren Togami 2002-08-31 07:01:31 UTC
I don't know for sure about gtk, but I thought Gnome1 (which uses gtk1) totally
didn't support Unicode, but now Gnome2 (using gtk2) does support Unicode.

gaim (in Null) still uses gtk1, I think.


Comment 7 Christopher Blizzard 2002-09-01 00:15:24 UTC
If the gaim folks manage to get a really stable gtk2/gnome2 version out I'll
probably errata it for 8.0 since not having an applet really sucks.

At this time, though, it's not very stable.

Comment 8 Marc Deslauriers 2002-09-01 00:25:19 UTC
That's fine with me.

Comment 9 Owen Taylor 2002-09-02 16:01:03 UTC
Note that gtk1 supports UTF-8 just as well as any other multibyte
locale-specific encoding. A good number of programs may have bugs
related to such encodings, but they certainly can work fine.

THe difference with GTK+-2.0 is that it *always* uses UTF-8.


Comment 10 Matt Wilson 2002-09-03 20:07:09 UTC
Created attachment 74764 [details]
fix for the display problem in utf-8 locales

Comment 11 Matt Wilson 2002-09-03 20:18:24 UTC
packages for the font problem are at: http://people.redhat.com/msw/gaim/

The iso-8859-1 v/s utf-8 problem will need more work.


Comment 12 Marc Deslauriers 2002-09-03 21:21:23 UTC
I had to recompile the src rpm as the binary one you provided didn't work on (null).

I think the patch fixes the other problem people were having, but unfortunately,
I have the UTF-8 vs ISO-8859-1 bug.


Comment 13 Matt Wilson 2002-09-05 20:26:50 UTC
*** Bug 72975 has been marked as a duplicate of this bug. ***

Comment 14 Warren Togami 2003-01-12 09:53:09 UTC
What is the status of this bug?


Comment 15 Marc Deslauriers 2003-01-12 14:29:31 UTC
gtk2 gaim from CVS fixed this last october. Unfortunatly, the last "release"
version, which is still based on gtk1 still does not work correctly with a utf-8
locale.

Maybe the gaim guys will release the first gtk2 version soon...can someone check
with them as it would be great to have the gtk2 gaim in the next release...

Comment 16 Warren Togami 2003-01-12 20:50:12 UTC
I did ask.  It seems VERY UNLIKELY that they will make a release of gaim 0.60
anytime soon.  The two main developers seem to be causing mass frustration from
other developers by ignoring patches for weeks.  My friend submitted one patch
that prevents gaim from crashing when the configured URL handler doesn't exist
(the URL handling code is in massive need of rewriting beyond this) but he got
pretty much zero response.  Due to this he gave up.  I personally feel that gaim
gtk2 has several important improvements over the current stable gaim so I am
still thinking about working on gaim myself, but it would indeed be frustrating
to submit patches and be ignored.  (I also need to get a few higher priorities
out of the way first.)

Comment 17 Warren Togami 2003-07-30 23:18:21 UTC
gaim-0.66 in Rawhide with gtk2 should theoretically have no problem here. 
Please confirm.


Comment 18 Marc Deslauriers 2003-07-31 12:05:17 UTC
This bug has been resolved by gaim 0.6x. It can be closed.


Note You need to log in before you can comment on or make changes to this bug.