Bug 709313 - [abrt] ibus-1.3.99.20110408-3.fc15: connection.py:630:call_blocking:DBusException: org.freedesktop.DBus.Error.Failed: Can not find engine pinyin.
[abrt] ibus-1.3.99.20110408-3.fc15: connection.py:630:call_blocking:DBusExcep...
Status: CLOSED DUPLICATE of bug 707370
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
15
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: fujiwara
Fedora Extras Quality Assurance
abrt_hash:fb2e7ac31f0cc9f5743d6a52ef4...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-31 07:02 EDT by plainbox
Modified: 2011-06-01 21:25 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-06-01 21:25:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description plainbox 2011-05-31 07:02:51 EDT
abrt version: 2.0.1
architecture:   i686
cmdline:        /usr/bin/python /usr/share/ibus/ui/gtk/main.py
comment:        left input method chinese - pinyin on while computer went into suspend. on login the input method was set to chinese when asked for login password, i cannot type my password, chinese characters appears, and i forgot the shortcut to turn off this input method.  had to click switch user, that set it back to english and was able to log back in. turning off chinese - pinyin input method from the keyboard icon on the top right crashes it (the input method program) but even as i type this window, i can change back to chinese input method and it works fine.
component:      ibus
executable:     /usr/share/ibus/ui/gtk/main.py
kernel:         2.6.38.5-24.fc15.i686
os_release:     Fedora release 15 (Lovelock)
package:        ibus-1.3.99.20110408-3.fc15
reason:         connection.py:630:call_blocking:DBusException: org.freedesktop.DBus.Error.Failed: Can not find engine pinyin.
time:           Thu May 12 16:28:53 2011
uid:            500
username:       hanfei

backtrace:
:connection.py:630:call_blocking:DBusException: org.freedesktop.DBus.Error.Failed: Can not find engine pinyin.
:
:Traceback (most recent call last):
:  File "/usr/share/ibus/ui/gtk/panel.py", line 526, in __im_menu_item_activate_cb
:    self.__focus_ic.set_engine(engine)
:  File "/usr/lib/python2.7/site-packages/ibus/inputcontext.py", line 238, in set_engine
:    return self.__context.SetEngine(engine.name)
:  File "/usr/lib/python2.7/site-packages/dbus/proxies.py", line 140, in __call__
:    **keywords)
:  File "/usr/lib/python2.7/site-packages/dbus/connection.py", line 630, in call_blocking
:    message, timeout)
:DBusException: org.freedesktop.DBus.Error.Failed: Can not find engine pinyin.
:
:Local variables in innermost frame:
:byte_arrays: False
:self: <dbus.connection.Connection object at 0x98a9bcc>
:args: (dbus.String(u'pinyin'),)
:utf8_strings: False
:bus_name: 'org.freedesktop.IBus'
:get_args_opts: {'byte_arrays': False, 'utf8_strings': False}
:object_path: dbus.ObjectPath('/org/freedesktop/IBus/InputContext_1')
:timeout: -1.0
:signature: u's'
:dbus_interface: 'org.freedesktop.IBus.InputContext'
:message: <dbus.lowlevel.MethodCallMessage object at 0x9835790>
:method: 'SetEngine'
Comment 1 fujiwara 2011-05-31 07:28:37 EDT
(In reply to comment #0)
> comment:        left input method chinese - pinyin on while computer went into
> suspend. on login the input method was set to chinese when asked for login
> password, i cannot type my password, chinese characters appears, and i forgot
> the shortcut to turn off this input method.  had to click switch user, that set
> it back to english and was able to log back in. turning off chinese - pinyin
> input method from the keyboard icon on the top right crashes it (the input
> method program) but even as i type this window, i can change back to chinese
> input method and it works fine.

I cannot reproduce your problem.
Do you mean the SetEngine error is reported in comment #0 whenever you log into
GNOME desktop?

How about restarting ibus?
1. Right click on ibus panel icon.
2. Choose "Restart" menu item

Are you able to test your GNOME desktop with a new account besides the current
account?
Comment 2 fujiwara 2011-06-01 21:25:59 EDT

*** This bug has been marked as a duplicate of bug 707370 ***

Note You need to log in before you can comment on or make changes to this bug.