Bug 709431 - [abrt] kernel: WARNING: at kernel/exit.c:910 do_exit+0x46/0x732(): TAINTED Warning Issued
Summary: [abrt] kernel: WARNING: at kernel/exit.c:910 do_exit+0x46/0x732(): TAINTED Wa...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 15
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:17af4da9c1e55ffa1dc7746af38...
: 737284 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-05-31 17:36 UTC by Garve
Modified: 2011-10-06 22:22 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-29 17:46:29 UTC
Type: ---


Attachments (Terms of Use)

Description Garve 2011-05-31 17:36:45 UTC
abrt version: 2.0.1
architecture:   x86_64
cmdline:        ro root=UUID=02d75961-c821-4ac4-8c2c-dff297ab9150 rd_NO_LUKS rd_NO_LVM rd_NO_MD rd_NO_DM LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYTABLE=de-latin1-nodeadkeys rhgb quiet
comment:        Plugged out an USB stick.
component:      kernel
kernel:         2.6.38.6-27.fc15.x86_64
kernel_tainted: 640
os_release:     Fedora release 15 (Lovelock)
package:        kernel
reason:         WARNING: at kernel/exit.c:910 do_exit+0x46/0x732()
reported_to:    kerneloops: URL=http://submit.kerneloops.org/submitoops.php
time:           Tue May 31 19:32:31 2011

backtrace:
:WARNING: at kernel/exit.c:910 do_exit+0x46/0x732()
:Hardware name: K50IJ               
:Modules linked in: vfat fat usb_storage uas fuse 8021q garp stp llc cpufreq_ondemand acpi_cpufreq freq_table mperf ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 ip6table_filter ip6_tables snd_hda_codec_via snd_hda_intel snd_hda_codec snd_hwdep snd_seq snd_seq_device snd_pcm microcode arc4 iTCO_wdt joydev iTCO_vendor_support serio_raw uvcvideo videodev v4l2_compat_ioctl32 ath9k snd_timer mac80211 snd asus_laptop sparse_keymap ath9k_common ath9k_hw ath soundcore cfg80211 snd_page_alloc atl1e rfkill ipv6 i915 drm_kms_helper drm i2c_algo_bit i2c_core video [last unloaded: scsi_wait_scan]
:Pid: 1471, comm: gvfs-gdu-volume Tainted: G      D     2.6.38.6-27.fc15.x86_64 #1
:Call Trace:
: [<ffffffff8105510e>] warn_slowpath_common+0x83/0x9b
: [<ffffffff81055140>] warn_slowpath_null+0x1a/0x1c
: [<ffffffff81058457>] do_exit+0x46/0x732
: [<ffffffff8147588c>] ? _raw_spin_unlock_irqrestore+0x17/0x19
: [<ffffffff8105681e>] ? kmsg_dump+0x49/0xd7
: [<ffffffff81476b8e>] oops_end+0xbc/0xc5
: [<ffffffff8146c0b4>] no_context+0x203/0x212
: [<ffffffff81474206>] ? schedule+0x653/0x66a
: [<ffffffff8146c257>] __bad_area_nosemaphore+0x194/0x1b7
: [<ffffffff8100d3da>] ? show_trace+0x15/0x17
: [<ffffffff8146c2d6>] bad_area+0x47/0x4e
: [<ffffffff81478cdf>] do_page_fault+0x247/0x37a
: [<ffffffff8123060f>] ? vsnprintf+0x83/0x401
: [<ffffffff81080b33>] ? arch_local_irq_save+0x15/0x1b
: [<ffffffff8147588c>] ? _raw_spin_unlock_irqrestore+0x17/0x19
: [<ffffffff8147588c>] ? _raw_spin_unlock_irqrestore+0x17/0x19
: [<ffffffff81055f02>] ? console_unlock+0x17d/0x18a
: [<ffffffff81476095>] page_fault+0x25/0x30
: [<ffffffff81216da9>] ? blk_peek_request+0x159/0x1b6
: [<ffffffff811444c8>] ? sync_buffer+0x0/0x2e
: [<ffffffff812fd96e>] scsi_request_fn+0x48/0x421
: [<ffffffff811444c8>] ? sync_buffer+0x0/0x2e
: [<ffffffff81216858>] __generic_unplug_device+0x34/0x38
: [<ffffffff81216b10>] generic_unplug_device+0x2d/0x3d
: [<ffffffff812145e2>] ? blk_backing_dev_unplug+0x0/0x14
: [<ffffffff812145de>] blk_unplug+0x26/0x2a
: [<ffffffff812145e2>] ? blk_backing_dev_unplug+0x0/0x14
: [<ffffffff812145f4>] blk_backing_dev_unplug+0x12/0x14
: [<ffffffff81143aac>] blk_run_address_space+0x24/0x26
: [<ffffffff811444ed>] sync_buffer+0x25/0x2e
: [<ffffffff81474805>] __wait_on_bit+0x48/0x7b
: [<ffffffff814748aa>] out_of_line_wait_on_bit+0x72/0x7d
: [<ffffffff811444c8>] ? sync_buffer+0x0/0x2e
: [<ffffffff8106f24f>] ? wake_bit_function+0x0/0x31
: [<ffffffff8114448c>] __wait_on_buffer+0x26/0x28
: [<ffffffff811444c4>] wait_on_buffer+0x36/0x3a
: [<ffffffff811451a0>] __bread+0x5b/0x73
: [<ffffffffa036ae77>] fat_get_entry+0x190/0x1f5 [fat]
: [<ffffffffa036b422>] __fat_readdir+0x1d4/0x81d [fat]
: [<ffffffff8112f5e7>] ? filldir+0x0/0xc7
: [<ffffffff8112f5e7>] ? filldir+0x0/0xc7
: [<ffffffff8112f5e7>] ? filldir+0x0/0xc7
: [<ffffffffa036bcb1>] fat_readdir+0x28/0x2a [fat]
: [<ffffffff8112f8a6>] vfs_readdir+0x76/0xac
: [<ffffffff8112f9c2>] sys_getdents+0x7e/0xce
: [<ffffffff81009bc2>] system_call_fastpath+0x16/0x1b

event_log:
:2011-05-31-19:35:03> Submitting oops report to http://submit.kerneloops.org/submitoops.php
:2011-05-31-19:35:04  Kernel oops report was uploaded
:2011-05-31-19:35:04> Logging into Bugzilla at https://bugzilla.redhat.com
:2011-05-31-19:35:06  Can't login. Server said: RPC failed at server.  The username or password you entered is not valid.
:2011-05-31-19:35:06* (exited with 1)

Comment 1 Josh Boyer 2011-09-27 15:19:23 UTC
Can you recreate this with the latest 2.6.40.x F15 kernel?

Comment 2 Garve 2011-09-27 19:12:58 UTC
Hi!

No, it didn't happen again so far.

Comment 3 Josh Boyer 2011-09-29 17:46:29 UTC
Thank you for letting us know.  I'm going to close the bug report out.  If you get the same backtrace with a newer kernel, please reopen.

Comment 4 Dave Jones 2011-10-06 22:22:22 UTC
*** Bug 737284 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.