Bug 737284 - WARNING: at kernel/exit.c:910 do_exit+0x38/0x61c() : Tainted: G D
Summary: WARNING: at kernel/exit.c:910 do_exit+0x38/0x61c() : Tainted: G D
Keywords:
Status: CLOSED DUPLICATE of bug 709431
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 15
Hardware: i686
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:bca2cf1f6360814a3ebb5f64d13...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-10 16:30 UTC by Dave
Modified: 2011-10-06 22:22 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-10-06 22:22:21 UTC


Attachments (Terms of Use)

Description Dave 2011-09-10 16:30:10 UTC
abrt version: 2.0.3
architecture:   i686
cmdline:        ro root=/dev/mapper/vg_home-lv_root rd_LVM_LV=vg_home/lv_root rd_LVM_LV=vg_home/lv_swap rd_NO_LUKS rd_NO_MD rd_NO_DM LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYTABLE=us rhgb quiet
comment:        The kernel crashed during an update.
component:      kernel
kernel:         2.6.38.6-26.rc1.fc15.i686.PAE
os_release:     Fedora release 15 (Lovelock)
package:        kernel
reason:         WARNING: at kernel/exit.c:910 do_exit+0x38/0x61c()
time:           Sat Sep 10 10:21:26 2011

backtrace:
:WARNING: at kernel/exit.c:910 do_exit+0x38/0x61c()
:Hardware name: System Product Name
:Modules linked in: ip6t_ipv6header ip6table_filter ip6_tables ipt_MASQUERADE iptable_nat nf_nat nf_conntrack_netbios_ns ts_kmp nf_conntrack_amanda vboxnetadp vboxnetflt vboxdrv tun sco bnep l2cap bluetooth rfkill tcp_lp fuse ppdev parport_pc lp parport sunrpc cpufreq_ondemand acpi_cpufreq mperf ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 snd_hda_codec_analog usblp snd_hda_intel snd_hda_codec snd_ctxfi snd_hwdep snd_seq snd_seq_device joydev forcedeth serio_raw snd_pcm microcode snd_timer nv_tco asus_atk0110 snd soundcore snd_page_alloc i2c_nforce2 ipv6 firewire_ohci firewire_core crc_itu_t ata_generic pata_acpi sata_nv pata_amd usb_storage uas nouveau ttm drm_kms_helper drm i2c_algo_bit i2c_core video [last unloaded: ip6_tables]
:Pid: 20001, comm: umount Tainted: G      D     2.6.38.6-26.rc1.fc15.i686.PAE #1
:Call Trace:
: [<c07e15f2>] ? printk+0x2d/0x2f
: [<c044205d>] warn_slowpath_common+0x7c/0x91
: [<c0444e9e>] ? do_exit+0x38/0x61c
: [<c0444e9e>] ? do_exit+0x38/0x61c
: [<c0442094>] warn_slowpath_null+0x22/0x24
: [<c0444e9e>] do_exit+0x38/0x61c
: [<c0469b90>] ? arch_local_irq_save+0x12/0x17
: [<c07e8ffb>] ? _raw_spin_unlock_irqrestore+0x13/0x15
: [<c044350e>] ? kmsg_dump+0x3a/0xb8
: [<c07e15f2>] ? printk+0x2d/0x2f
: [<c07ea4b3>] oops_end+0xa2/0xa8
: [<c07e0fb3>] no_context+0x164/0x16c
: [<c07e10d5>] __bad_area_nosemaphore+0x11a/0x122
: [<c07e15f2>] ? printk+0x2d/0x2f
: [<c07e1132>] bad_area+0x3c/0x42
: [<c07ebf24>] do_page_fault+0x1c3/0x30c
: [<c04307c7>] ? update_curr+0xa5/0x132
: [<c042f703>] ? update_stats_wait_end+0xad/0xf2
: [<c0431ab5>] ? hrtick_update+0x2e/0x31
: [<c040fef7>] ? __switch_to_xtra+0x113/0x13b
: [<c07ebd61>] ? do_page_fault+0x0/0x30c
: [<c07e9ae7>] error_code+0x67/0x6c
: [<c043007b>] ? cpuacct_stats_show+0x41/0x58
: [<c05e48d5>] ? __percpu_counter_add+0xe/0x6d
: [<c04b92c3>] __add_bdi_stat+0x33/0x37
: [<c04b9ab9>] account_page_dirtied+0x52/0x70
: [<c050bfdc>] __set_page_dirty+0x56/0x8a
: [<c050c087>] mark_buffer_dirty+0x77/0x7a
: [<c0583ec3>] jbd2_journal_update_superblock+0x96/0x101
: [<c07e8ffb>] ? _raw_spin_unlock_irqrestore+0x13/0x15
: [<c058423d>] jbd2_journal_destroy+0x15d/0x1b4
: [<c045901d>] ? autoremove_wake_function+0x0/0x39
: [<c056395d>] ext4_put_super+0x6b/0x2c4
: [<c04ff64d>] ? evict_inodes+0xb1/0xb9
: [<c04ef2b7>] generic_shutdown_super+0x58/0xb8
: [<c04ef339>] kill_block_super+0x22/0x60
: [<c04ef54a>] deactivate_locked_super+0x1f/0x40
: [<c04efedb>] deactivate_super+0x2e/0x31
: [<c0501a88>] mntput_no_expire+0xb5/0xb9
: [<c0502326>] sys_umount+0x270/0x297
: [<c04f538e>] ? path_put+0x1a/0x1d
: [<c040969f>] sysenter_do_call+0x12/0x28

Comment 1 Dave 2011-09-11 18:39:08 UTC
Package: kernel
Architecture: i686
OS Release: Fedora release 15 (Lovelock)

Comment
-----
The kernel crashed during an update.

Comment 2 Dave 2011-09-11 18:39:36 UTC
Package: kernel
Architecture: i686
OS Release: Fedora release 15 (Lovelock)

Comment
-----
The kernel crashed during an update.

Comment 3 Josh Boyer 2011-09-12 11:16:54 UTC
Can you recreate this without the vbox modules loaded?

Comment 4 Chuck Ebbert 2011-09-14 09:48:50 UTC
This is a follow-on error from bug 737389. The kernel is killing the process and has encountered an additional problem while doing that. I don't have the source for that old kernel handy, but it looks to be one of these two warnings:

       WARN_ON(atomic_read(&tsk->fs_excl));
       WARN_ON(blk_needs_flush_plug(tsk));

The "D" taint flag was set to mark that this was hit when the task was dying.

Comment 5 Dave Jones 2011-10-06 22:22:21 UTC

*** This bug has been marked as a duplicate of bug 709431 ***


Note You need to log in before you can comment on or make changes to this bug.