Bug 709557 - lircd unable to create socket/pidfile in /var/run
Summary: lircd unable to create socket/pidfile in /var/run
Keywords:
Status: CLOSED DUPLICATE of bug 656613
Alias: None
Product: Fedora
Classification: Fedora
Component: lirc
Version: 15
Hardware: All
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Jarod Wilson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-06-01 01:52 UTC by sgtsnookums
Modified: 2011-06-01 03:16 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-06-01 03:16:34 UTC
Type: ---


Attachments (Terms of Use)

Description sgtsnookums 2011-06-01 01:52:33 UTC
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:2.0.1) Gecko/20100101 Firefox/4.0.1

lircd exits immediately and complains it cannot create the file /var/run/lircd/lircd.pid because the directory /var/run/lircd does not exist. Manually creating this directory leaves lircd unable to create the socket file /var/run/lircd/lircd for external programs to listen on because of SELinux policy.

Reproducible: Always

Steps to Reproduce:
1. Start lircd (systemctl start lirc.service)
Actual Results:  
lircd exits immediately

Expected Results:  
lircd stays running as a daemon

After manually creating /var/run/lircd and adding a local policy module for lircd to create the socket, socket has permissions 0755, so applications cannot connect to it. Manually changing permissions to 0666 resolves this issue as well.

Comment 1 Jarod Wilson 2011-06-01 03:16:34 UTC

*** This bug has been marked as a duplicate of bug 656613 ***


Note You need to log in before you can comment on or make changes to this bug.