Bug 70958 - up2date-2.9.33-7.x.9 fails to run
up2date-2.9.33-7.x.9 fails to run
Product: Red Hat Public Beta
Classification: Retired
Component: up2date (Show other bugs)
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Adrian Likins
Jay Turner
Depends On:
  Show dependency treegraph
Reported: 2002-08-07 05:33 EDT by jeroen
Modified: 2015-01-07 18:58 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-08-07 17:02:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description jeroen 2002-08-07 05:33:58 EDT
This is a 2 part bugreport. First, the up2date which came with limbo2 didn't
calculate the dependencies correctly when i tried to update some packages just
now. Since i've got gstreamer-0.4.0 installed and that requires the rc3 version
of vorbis-tools/libogg/libvorbis i specifically deselected those packages in the

After calculating the dependencies it apparently ignored what i did and used
those newer packages anyway, resulting in a conflict where gstreamer will not
work with the 1.0 packages of ogg vorbis.

Thinking this might be fixed in a newer version of up2date (rawhide), i
downloaded & updated my up2date packages. I downloaded & installed the following

That last one is required by up2date.

After succesfully updating the packages, i tried to run up2date again without
success. It immediately returns with an error:

[root@anduril Downloads]# up2date
creating readOnlyTransaction
Traceback (most recent call last):
  File "/usr/sbin/up2date", line 18, in ?
    from up2date_client import rpcServer
  File "/usr/share/rhn/up2date_client/rpcServer.py", line 7, in ?
    import up2dateAuth
  File "/usr/share/rhn/up2date_client/up2dateAuth.py", line 4, in ?
    import rpmSource
  File "/usr/share/rhn/up2date_client/rpmSource.py", line 11, in ?
    import up2dateUtils
  File "/usr/share/rhn/up2date_client/up2dateUtils.py", line 15, in ?
    import rpmUtils
  File "/usr/share/rhn/up2date_client/rpmUtils.py", line 221, in ?
    rpm_version = getRpmVersion()
  File "/usr/share/rhn/up2date_client/rpmUtils.py", line 210, in getRpmVersion
    ts = transaction.initReadOnlyTransaction()
  File "/usr/share/rhn/up2date_client/transaction.py", line 25, in

Perhaps i need to update another (python?) dependency, but i have no idea which one.
Comment 1 Michael Young 2002-08-07 06:33:53 EDT
This sounds like bug 70852, though fixing the dependencies won't get this
version of up2date to work.
Comment 2 Adrian Likins 2002-08-07 17:02:23 EDT
rpm change broke this, should be fixed in 2.9.35 or so
Comment 3 Jay Turner 2002-08-16 10:27:32 EDT
Fix confirmed with up2date-2.9.45-1.

Note You need to log in before you can comment on or make changes to this bug.