Bug 709675 - Changing cdrom from /dev/sr0 to ISO image can not be detected by guest after execute eject in windows guest
Changing cdrom from /dev/sr0 to ISO image can not be detected by guest after ...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kvm (Show other bugs)
5.7
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Markus Armbruster
Virtualization Bugs
:
: 717498 (view as bug list)
Depends On:
Blocks: Rhel5KvmTier2
  Show dependency treegraph
 
Reported: 2011-06-01 07:08 EDT by Mike Cao
Modified: 2011-08-10 16:19 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-10 16:19:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Cao 2011-06-01 07:08:10 EDT
Description of problem:


Version-Release number of selected component (if applicable):
# uname -r
2.6.18-264.el5
# rpm -q kvm
kvm-83-235.el5


How reproducible:
100%

Steps to Reproduce:
1.start windows guest with /dev/sr0
eg:/usr/libexec/qemu-kvm -M rhel5.6.0 -m 2048 -smp 4,sockets=4,cores=1,threads=1 -name windows2008_qcow2 -uuid cddeab65-2ded-43db-094a-fd4f8ec2d69f -monitor stdio -localtime -no-kvm-pit-reinjection -boot c -drive file=/home/windows08.qcow2,if=ide,bus=0,unit=0,format=qcow2,cache=none -net nic,macaddr=54:52:00:4f:26:51,vlan=0,model=rtl8139 -net tap,vlan=0,downscript=no -serial pty -parallel none -usb -usbdevice tablet -spice port=8001,host=0,ic=on,disable-ticketing -qxl 1 -balloon none -drive file=/home/virtio-drivers.vfd,if=floppy,format=raw,cache=none \
-drive file=/dev/sr0,if=ide,media=cdrom,bus=1,unit=0,readonly=on,format=raw 

2.right-click the media disk in the windows and select "eject" 
  (eg: D:\ is the cdrom disk in the guest ,right-click D:\, then select "eject" ,this step is *must*)

3.change cdrom from /dev/sr0 to iso image
(qemu) change ide1-cd0 en_windows_server_2008_datacenter_enterprise_standard_sp2_x64_dvd_342336.iso

Actual results:
the ISO image could be detected in qemu-monitor ,but could *not* be detected in the guest
(qemu)info block
ide1-cd0: type=cdrom removable=1 locked=0 file=en_windows_server_2008_datacenter_enterprise_standard_sp2_x64_dvd_342336.iso ro=1 drv=raw encrypted=0

Expected results:
the ISO image could be detected in the guest.

Additional info:
Without step2 ,the ISO image could be detected in the guest.
Comment 1 juzhang 2011-06-29 04:39:45 EDT
*** Bug 717498 has been marked as a duplicate of this bug. ***
Comment 2 Markus Armbruster 2011-06-29 07:50:10 EDT
What exactly do you mean by "could *not* be detected in the guest"?

Please try

4. Load the media.  I'm not familiar with Windows, so I don't know how exactly this is done.  In Linux, it's "eject -t".

I'd expect this to make the new image available.
Comment 3 Markus Armbruster 2011-06-29 07:54:53 EDT
One more question: what if you use file=some-other.iso in step 1.?  Same result?
Comment 4 Mike Cao 2011-06-30 02:05:00 EDT
(In reply to comment #2)
> What exactly do you mean by "could *not* be detected in the guest"?

after step3, the iso image can be found in qemu monitor
(qemu)info block 
ide1-cd0: type=cdrom removable=1 locked=0 file=/home/en_windows_server_2008_r2_standard_enterprise_datacenter_and_web_with_sp1_x64_dvd_617601.iso ro=1 drv=raw encrypted=0

but in the guest ,we can not find it .

> 
> Please try
> 
> 4. Load the media.  I'm not familiar with Windows, so I don't know how exactly
> this is done.  In Linux, it's "eject -t".
windows should load media itself .seems no way for me to load it in windows guest ,I will try with Linux guest and add another comment later

> I'd expect this to make the new image available.
yes ,the image was installed yesterday .
Comment 5 Mike Cao 2011-06-30 02:16:40 EDT
(In reply to comment #3)
> One more question: what if you use file=some-other.iso in step 1.?  Same
> result?

yes ,same results

what's more ,if I change the cdrom to bare-metal eg :(qemu)change ide1-cd0 /dev/sr0 ,the media in bare matal should be found in the guest ,while can not be found if change the cdrom to XXX.iso
Comment 6 Mike Cao 2011-06-30 02:17:39 EDT
(In reply to comment #2)
> What exactly do you mean by "could *not* be detected in the guest"?
> 
> Please try
> 
> 4. Load the media.  I'm not familiar with Windows, so I don't know how exactly
> this is done.  In Linux, it's "eject -t".

Tried on linux guest ,it works ,
armbru ,any suggestion how to do this step on windows guest ?
Comment 7 Markus Armbruster 2011-08-09 05:13:22 EDT
Mike Cao attempted to reproduce this on RHEL-6, but ran into bug 729219.

Note You need to log in before you can comment on or make changes to this bug.