Bug 71002 - afpd ignores afpd.conf
afpd ignores afpd.conf
Status: CLOSED DUPLICATE of bug 69647
Product: Red Hat Linux
Classification: Retired
Component: netatalk (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-07 14:21 EDT by David Weingart
Modified: 2015-03-04 20:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-07 14:21:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Weingart 2002-08-07 14:21:07 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0.0) Gecko/20020529

Description of problem:
afpd is not reading the afpd.conf file when the daemon is launched. 

This makes it impossible to configure anything but the default AFP server. Any
additional servers or server options are ignored. It was 100% reproducible on my
system.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Edit afpd.conf. Add a new server at a different port.
2. service atalk restart
3. Attempt to connect to the new server from a client machine
	

Actual Results:  Server did not respond.

Expected Results:  The server should be visible, and I should be able to mount
any shared volumes.

Additional info:

The solution I found was to add the -F flag to the init script to specify the
location of afpd.conf.

I added "-F /etc/atalk/afpd.conf" to the two places in the script where afpd is
invoked. This solved the problem entitrely for me.
Comment 1 Phil Knirsch 2002-08-08 07:29:07 EDT

*** This bug has been marked as a duplicate of 69647 ***

Note You need to log in before you can comment on or make changes to this bug.