Bug 71039 - Crash in regcomp()
Crash in regcomp()
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: glibc (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
: 66794 (view as bug list)
Depends On:
Blocks: 67217
  Show dependency treegraph
 
Reported: 2002-08-07 22:48 EDT by Havoc Pennington
Modified: 2016-11-24 10:25 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-11 18:13:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Havoc Pennington 2002-08-07 22:48:12 EDT
The following test program will abort in free() if run with MALLOC_CHECK_=2
using glibc-2.2.90-17. I believe this is the cause of the "mcedit crashes on
startup" bug that has been reported several times.

#include <sys/types.h>
#include <regex.h>
#include <stdlib.h>

int
main (int argc, char **argv)
{
  regex_t r;

  regcomp (&r, "^@! */.*/(k|ba||pdk|z)sh", REG_EXTENDED);

  return 0;
}
Comment 1 Havoc Pennington 2002-08-07 22:53:57 EDT
Bug #66794 is the mc bug.
Comment 3 Havoc Pennington 2002-08-11 18:13:10 EDT
*** Bug 66794 has been marked as a duplicate of this bug. ***
Comment 4 Jakub Jelinek 2002-08-16 02:31:11 EDT
Should be fixed in glibc-2.2.90-19 and later.

Note You need to log in before you can comment on or make changes to this bug.