Bug 66794 - mc-problem, mcedit segfaults
Summary: mc-problem, mcedit segfaults
Status: CLOSED DUPLICATE of bug 71039
Alias: None
Product: Red Hat Linux Beta
Classification: Retired
Component: mc   
(Show other bugs)
Version: beta2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
: 67154 68144 71283 71407 (view as bug list)
Depends On:
Blocks: 65252 67217
TreeView+ depends on / blocked
 
Reported: 2002-06-16 22:05 UTC by Inger Karin Haarbye
Modified: 2007-04-18 16:43 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-11 22:11:55 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Inger Karin Haarbye 2002-06-16 22:05:20 UTC
Description of Problem:

Mila beta2:  mc looks very weird, with lots of wrong characters. When trying to
edit a file, mcedit segfaults.

Version-Release number of selected component (if applicable):
mc-4.5.55-6

How Reproducible:
all the time - I think...

Steps to Reproduce:
1.  from console run mc
2.  trying to edit a file with F4 or "mcedit"
3. 

Actual Results:
mc has funny characters and some double/extra characters. mcedit segfaults.

Expected Results:


Additional Information:

Comment 1 Inger Karin Haarbye 2002-07-04 10:19:11 UTC
The bug is still present in Limbo - makes it impossible to use mc.

Comment 2 Havoc Pennington 2002-07-04 16:17:53 UTC
Most likely mc never worked in multibyte locales and breaks in UTF-8. You might
try LANG=en_US.ISO-8859-1 and see if the bug goes away.

Comment 3 Inger Karin Haarbye 2002-07-04 16:28:09 UTC
The characters look OK, but copying in mc (F5) segfaults and mcedit (or F4) hangs still with 
LANG=en_US.ISO-8859-1.

Comment 4 Inger Karin Haarbye 2002-07-30 20:42:54 UTC
Limbo2 RedHat 7.3.93: Copying is working, but mcedit (and F4) is not working 
and causes the console to hang.

Comment 5 Havoc Pennington 2002-08-08 02:50:24 UTC
*** Bug 67154 has been marked as a duplicate of this bug. ***

Comment 6 Havoc Pennington 2002-08-08 02:51:21 UTC
*** Bug 68144 has been marked as a duplicate of this bug. ***

Comment 7 Havoc Pennington 2002-08-08 02:52:57 UTC
*** Bug 68144 has been marked as a duplicate of this bug. ***

Comment 8 Havoc Pennington 2002-08-08 02:54:16 UTC
Possible diagnosis is bug #71039

Comment 9 Havoc Pennington 2002-08-08 02:55:28 UTC
*** Bug 67154 has been marked as a duplicate of this bug. ***

Comment 10 Havoc Pennington 2002-08-11 22:11:50 UTC
*** Bug 71283 has been marked as a duplicate of this bug. ***

Comment 11 Havoc Pennington 2002-08-11 22:13:22 UTC

*** This bug has been marked as a duplicate of 71039 ***

Comment 12 Havoc Pennington 2002-08-13 22:07:43 UTC
*** Bug 71407 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.