Bug 71044 - redhat-config-packages crashes at end of "reading system status"
Summary: redhat-config-packages crashes at end of "reading system status"
Status: CLOSED DUPLICATE of bug 70972
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: redhat-config-packages (Show other bugs)
(Show other bugs)
Version: limbo
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-08-08 06:54 UTC by Panu Matilainen
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-08 06:54:57 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Panu Matilainen 2002-08-08 06:54:53 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020712

Description of problem:
At the end of "reading system status" on startup redhat-config-packages crashes.


Version-Release number of selected component (if applicable):
redhat-config-packages-0.5-1

How reproducible:
Always

Steps to Reproduce:
1.run 'redhat-config-packages'
	

Actual Results:  [pmatilai@chip pmatilai]$ redhat-config-packages
Traceback (most recent call last):
  File "/usr/share/redhat-config-packages/MainWindow.py", line 113, in ?
    comps = im.readCompsViaMethod(hdlist, progress.update)
  File "/usr/share/redhat-config-packages/method.py", line 224, in
readCompsViaMethod
    update_method = update_method)
  File "/usr/share/redhat-config-packages/comps.py", line 379, in __init__
    self.readCompsFile(file, self.packages)
  File "/usr/share/redhat-config-packages/comps.py", line 446, in readCompsFile
    for req in h[rpm.RPMTAG_REQUIRENAME]:
TypeError: iteration over non-sequence

Expected Results:  ..should've started the proggie...

Additional info:
System: Limbo2 (upgraded all the way through 7->7.1->7.2->7.3) with all updates
available through RHN (downgraded up2date* to 2.9.30 to keep it working but this
happened before that too). The crash didn't happen on plain Limbo2, but I needed
to install comps.rpm manually to get it working in the first place.

Comment 1 Jeremy Katz 2002-08-08 07:32:48 UTC

*** This bug has been marked as a duplicate of 70972 ***


Note You need to log in before you can comment on or make changes to this bug.