Bug 70972 - traceback reading package information
Summary: traceback reading package information
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: redhat-config-packages (Show other bugs)
(Show other bugs)
Version: 1.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Keywords:
: 71044 76032 80841 (view as bug list)
Depends On:
Blocks: 67217
TreeView+ depends on / blocked
 
Reported: 2002-08-07 14:23 UTC by Tim Waugh
Modified: 2008-05-01 15:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-08 07:32:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Tim Waugh 2002-08-07 14:23:53 UTC
Description of Problem: 
Traceback when starting app.  This is on a system upgraded to re0806.1. 
 
Version-Release number of selected component (if applicable): 
redhat-config-packages-0.5-1 
comps-7.3.93-0.20020806 
comps-extras-7.2.93-0 
 
How Reproducible: 
100% 
 
Steps to Reproduce: 
1. Start redhat-config-packages. 
 
Actual Results: 
Traceback (most recent call last): 
  File "/usr/share/redhat-config-packages/MainWindow.py", line 113, in ? 
    comps = im.readCompsViaMethod(hdlist, progress.update) 
  File "/usr/share/redhat-config-packages/method.py", line 224, in 
readCompsViaMethod 
    update_method = update_method) 
  File "/usr/share/redhat-config-packages/comps.py", line 379, in __init__ 
    self.readCompsFile(file, self.packages) 
  File "/usr/share/redhat-config-packages/comps.py", line 446, in 
readCompsFile 
    for req in h[rpm.RPMTAG_REQUIRENAME]: 
TypeError: iteration over non-sequence

Comment 1 Jeremy Katz 2002-08-08 02:17:14 UTC
Fixed in CVS

Comment 2 Jeremy Katz 2002-08-08 07:32:43 UTC
*** Bug 71044 has been marked as a duplicate of this bug. ***

Comment 3 Jay Turner 2002-09-03 12:36:00 UTC
No longer seeing this with redhat-config-packages-1.0.0-1.

Comment 4 Jeremy Katz 2002-10-31 22:50:18 UTC
*** Bug 76032 has been marked as a duplicate of this bug. ***

Comment 5 Jeremy Katz 2003-06-29 20:43:01 UTC
*** Bug 80841 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.