Bug 710991 - [abrt] ibus-1.3.99.20110408-5.fc15: connection.py:630:call_blocking:DBusException: org.freedesktop.DBus.Error.Failed: Context which does not has focus can not change engine to pinyin.
[abrt] ibus-1.3.99.20110408-5.fc15: connection.py:630:call_blocking:DBusExcep...
Status: CLOSED DUPLICATE of bug 707370
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
15
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: fujiwara
Fedora Extras Quality Assurance
abrt_hash:6d35073d07196ad402b8a2b1319...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-06 02:33 EDT by yaozhanp
Modified: 2011-06-15 01:14 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-06-15 01:14:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description yaozhanp 2011-06-06 02:33:11 EDT
abrt version: 2.0.1
architecture:   x86_64
cmdline:        /usr/bin/python /usr/share/ibus/ui/gtk/main.py
component:      ibus
executable:     /usr/share/ibus/ui/gtk/main.py
kernel:         2.6.38.6-27.fc15.x86_64
os_release:     Fedora release 15 (Lovelock)
package:        ibus-1.3.99.20110408-5.fc15
reason:         connection.py:630:call_blocking:DBusException: org.freedesktop.DBus.Error.Failed: Context which does not has focus can not change engine to pinyin.
time:           Sun Jun  5 22:38:03 2011
uid:            500
username:       byao

backtrace:
:connection.py:630:call_blocking:DBusException: org.freedesktop.DBus.Error.Failed: Context which does not has focus can not change engine to pinyin.
:
:Traceback (most recent call last):
:  File "/usr/share/ibus/ui/gtk/panel.py", line 526, in __im_menu_item_activate_cb
:    self.__focus_ic.set_engine(engine)
:  File "/usr/lib/python2.7/site-packages/ibus/inputcontext.py", line 238, in set_engine
:    return self.__context.SetEngine(engine.name)
:  File "/usr/lib/python2.7/site-packages/dbus/proxies.py", line 140, in __call__
:    **keywords)
:  File "/usr/lib/python2.7/site-packages/dbus/connection.py", line 630, in call_blocking
:    message, timeout)
:DBusException: org.freedesktop.DBus.Error.Failed: Context which does not has focus can not change engine to pinyin.
:
:Local variables in innermost frame:
:byte_arrays: False
:self: <dbus.connection.Connection object at 0x1100ad0>
:args: (dbus.String(u'pinyin'),)
:utf8_strings: False
:bus_name: 'org.freedesktop.IBus'
:get_args_opts: {'byte_arrays': False, 'utf8_strings': False}
:object_path: dbus.ObjectPath('/org/freedesktop/IBus/InputContext_44')
:timeout: -1.0
:signature: u's'
:dbus_interface: 'org.freedesktop.IBus.InputContext'
:message: <dbus.lowlevel.MethodCallMessage object at 0x1066918>
:method: 'SetEngine'

event_log:
:2011-06-05-23:31:20> Empty login or password, please check your configuration
:2011-06-05-23:31:20* (exited with 1)
Comment 1 fujiwara 2011-06-06 03:58:22 EDT
(In reply to comment #0)
> :  File "/usr/lib/python2.7/site-packages/ibus/inputcontext.py", line 238, in
> set_engine
> :    return self.__context.SetEngine(engine.name)

I cannot reproduce your problem.
Do you mean the SetEngine error is reported in comment #0 whenever you log into
GNOME desktop?

> reason:         connection.py:630:call_blocking:DBusException:
> org.freedesktop.DBus.Error.Failed: Context which does not has focus can not
> change engine to pinyin.

I wonder which application has the input focus when your problem is happened.

How about restarting ibus?
1. Right click on ibus panel icon.
2. Choose "Restart" menu item

Are you able to test your GNOME desktop with a new account besides the current
account?
Comment 2 fujiwara 2011-06-15 01:14:22 EDT
I still cannot reproduce your problem.
It would be great if you could provide the furthermore information.

*** This bug has been marked as a duplicate of bug 707370 ***

Note You need to log in before you can comment on or make changes to this bug.