This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 71149 - gnome-settings-daemon startup error
gnome-settings-daemon startup error
Status: CLOSED DUPLICATE of bug 71020
Product: Red Hat Public Beta
Classification: Retired
Component: control-center (Show other bugs)
limbo
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
:
Depends On:
Blocks: 67217
  Show dependency treegraph
 
Reported: 2002-08-09 06:36 EDT by adam.huffman
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-14 17:51:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description adam.huffman 2002-08-09 06:36:29 EDT
Description of Problem:

On a newly installed limbo-2 system, I am now having trouble when logging in to
GNOME.  The following dialog appears:

There was an error starting the GNOME Settings Daemon.

Some things, such as themes, sounds, or background settings may not work correctly.

The Settings Daemon restarted too many times.

The last error message was:

Child process did not give an error message, unknown failure occurred.

GNOME will still try to restart the Settings Daemon next time you log in.

Version-Release number of selected component (if applicable):


How Reproducible:

Every time.

Steps to Reproduce:
1. Login via GDM
2. 
3. 

Actual Results:

Settings Daemon error dialog appears

Expected Results:

Settings Daemon starts normally

Additional Information:
	
The desktop would not start at all until I removed .gnome* and .gconf*
Comment 1 Havoc Pennington 2002-08-13 16:34:19 EDT
Did you try using the desktop despite that error dialog? It should have
continued to work. This dialog is not about gconf, it's about gnome-settings-daemon.

In any case, can you try bonobo-activation 1.0.3 and gnome-session 2.0.5 and 
see if the problem persists? Please let me know if these packages make a difference.
Comment 2 adam.huffman 2002-08-14 10:35:04 EDT
In fact I had to add GConf2-1.2.1 too to resolve the dependencies and when all
these were installed the following appeared:

"Your session only lasted less than 10 seconds.  If you have not logged out
yourself, this could mean that there is some installation problem or that you
may be out of diskspace. Try logging in with one of the failsafe sessions to see
if you can fix this problem"

The details, from .xsession-errors:

** (process: 1770): WARNING **: CORBA_ORB_DEstroy: OIRB still has 2 refs.
SESSION_MANAGER=local/blah:/tmp/.ICE-unix/1698
gnome-session: relocation error: /usr/lib/libbonobo-activation.so.4: undefined
symbol: linc_get_tmpdir

When I click on "OK" the GDM greeter reappears eventually
Comment 3 Havoc Pennington 2002-08-14 10:53:32 EDT
You need linc 0.5.2 as well. (I think I added that dependency to the very latest
bonobo-activation but it may not have hit rawhide yet)

It turns out though this may have just been due to a bogus default session 
in the gnome-session package, that is fixed in gnome-session 2.0.5-2.
Comment 4 adam.huffman 2002-08-14 11:06:05 EDT
Installed linc-0.5.2 and the session starts up normally now (couldn't see
gnome-session 2.0.5-2 on rawhide)
Comment 5 Nathan G. Grennan 2002-08-14 17:51:00 EDT
This bug is a duplicate of 71020 and it is fixed by newer bonobo-activation and
control-center.
Comment 6 Havoc Pennington 2002-08-15 16:57:28 EDT

*** This bug has been marked as a duplicate of 71020 ***

Note You need to log in before you can comment on or make changes to this bug.