Bug 711557 - Anaconda crashes on installing to disk on new F15 livecd rebuilds
Summary: Anaconda crashes on installing to disk on new F15 livecd rebuilds
Keywords:
Status: CLOSED DUPLICATE of bug 711573
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 15
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-06-07 19:02 UTC by Ben Williams
Modified: 2011-06-08 20:06 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-06-07 20:02:34 UTC


Attachments (Terms of Use)

Description Ben Williams 2011-06-07 19:02:00 UTC
create updated f15 livecd using the fedora-livecd-desktop.ks with livecd-creator

iso is created but install to disk bombs out


Traceback (most recent call last):

File "/usr/bin/anaconda-cleanup", line 41, in <module>

from pyanaconda.cmdline import InstallInterface

File "/usr/lib64/python2.7/site-packages/pyanaconda/cmdline.py", line 25, in <module>

import parted

File "/usr/lib64/python2.7/site-packages/parted/__init__.py", line 53, in <module>

from partition import Partition

File "/usr/lib64/python2.7/site-packages/parted/partition.py", line 249, in <module>

partitionFlag[__flag] = _ped.partition_flag_get_name(__flag)

ValueError: Invalid flag provided.

localuser:root being added to access control list

Traceback (most recent call last):

File "/usr/sbin/anaconda", line 507, in <module>

from pyanaconda import kickstart

File "/usr/lib64/python2.7/site-packages/pyanaconda/kickstart.py", line 21, in <module>

from storage.deviceaction import *

File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/__init__.py", line 31, in <module>

import parted

file "/usr/lib64/python2.7/site-packages/parted/__init__.py", line 53, in <module>
#
from partition import Partition

File "/usr/lib64/python2.7/site-packages/parted/partition.py", line 249, in <module>
#
partitionFlag[__flag] = _ped.partition_flag_get_name(__flag)
#
ValueError: Invalid flag provided.

Version-Release number of selected component (if applicable):


How reproducible:
everytime

Steps to Reproduce:
1.f15 updated machine yum install livecd-tools fedora-kickstarts
2.livecd-creator -c /usr/share/spinkickstarts/fedora-livecd-desktop.ks to create iso

3.boot iso and try to install to disk
  
Actual results:


Expected results:


Additional info:

Comment 1 Brian Lane 2011-06-07 20:02:34 UTC

*** This bug has been marked as a duplicate of bug 711573 ***


Note You need to log in before you can comment on or make changes to this bug.