Bug 711573 - Fedora 15 liveinst fails with a python error before opening
Summary: Fedora 15 liveinst fails with a python error before opening
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: pyparted
Version: 15
Hardware: All
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: David Cantrell
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 711557 712840 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-06-07 19:23 UTC by Scott Dowdle
Modified: 2011-06-15 05:30 UTC (History)
11 users (show)

Fixed In Version: pyparted-3.5-3.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-06-15 05:30:50 UTC


Attachments (Terms of Use)

Description Scott Dowdle 2011-06-07 19:23:46 UTC
Description of problem: If liveinst is run graphically it just fails with no error.  When run from the command line, the following error:

[liveuser@localhost ~]$ /usr/bin/liveinst
Traceback (most recent call last):
  File "/usr/bin/anaconda-cleanup", line 41, in <module>
    from pyanaconda.cmdline import InstallInterface
  File "/usr/lib/python2.7/site-packages/pyanaconda/cmdline.py", line 25, in
<module>
    import parted
  File "/usr/lib/python2.7/site-packages/parted/__init__.py", line 53, in
<module>
    from partition import Partition
  File "/usr/lib/python2.7/site-packages/parted/partition.py", line 249, in
<module>
    partitionFlag[__flag] = _ped.partition_flag_get_name(__flag)
ValueError: Invalid flag provided.
localuser:root being added to access control list
Traceback (most recent call last):
  File "/usr/sbin/anaconda", line 507, in <module>
    from pyanaconda import kickstart
  File "/usr/lib/python2.7/site-packages/pyanaconda/kickstart.py", line 21, in
<module>
    from storage.deviceaction import *
  File "/usr/lib/python2.7/site-packages/pyanaconda/storage/__init__.py", line
31, in <module>
    import parted
  File "/usr/lib/python2.7/site-packages/parted/__init__.py", line 53, in
<module>
    from partition import Partition
  File "/usr/lib/python2.7/site-packages/parted/partition.py", line 249, in
<module>
    partitionFlag[__flag] = _ped.partition_flag_get_name(__flag)
ValueError: Invalid flag provided.

This is on a Fedora REMIX with the latest packages installed as of June 7, 2011.  The bug was first brought to my attention on the Fedora Remix mailing list:

http://lists.fedoraproject.org/pipermail/remixes/2011-June/000046.html

I was able to verify that the bug still existed even with the updates of the day applied.

Version-Release number of selected component (if applicable):
anaconda-15.31-1.fc15

anaconda has not been updated yet since the initial Fedora 15 release but a number of other components have... including the kernel.

I'm not sure what additional info would be helpful.  Ask and I will supply.

This was on a KVM virtual machine reusing an existing .img disk file that worked with tons of previous install testing.

Comment 1 Brian Lane 2011-06-07 20:00:10 UTC
This is because I updated parted w/o updating pyparted. It needs a patch from master cherry-picked to add the GPT legacy_boot flag support.

Comment 2 Brian Lane 2011-06-07 20:02:34 UTC
*** Bug 711557 has been marked as a duplicate of this bug. ***

Comment 3 Scott Dowdle 2011-06-07 20:53:42 UTC
Brian C. Lane,

Sounds like you know how to fix it so please do so when you have a chance.  The only additional thing I have to offer is a diff of two package lists... comparing the package lists of my last working build to my first broken build... and sure enough, parted is only the list.

40,41c40,41
< apr-1.4.2-3.fc15.i686
< apr-util-1.3.10-7.fc15.i686
---
> apr-1.4.5-1.fc15.i686
> apr-util-1.3.12-1.fc15.i686
104,107c104,107
< bind-libs-9.8.0-3.P1.fc15.i686
< bind-libs-lite-9.8.0-3.P1.fc15.i686
< bind-license-9.8.0-3.P1.fc15.noarch
< bind-utils-9.8.0-3.P1.fc15.i686
---
> bind-libs-9.8.0-5.P2.fc15.i686
> bind-libs-lite-9.8.0-5.P2.fc15.i686
> bind-license-9.8.0-5.P2.fc15.noarch
> bind-utils-9.8.0-5.P2.fc15.i686
278,279c278,279
< evolution-3.0.1-1.fc15.i686
< evolution-data-server-3.0.1-1.fc15.i686
---
> evolution-3.0.2-1.fc15.i686
> evolution-data-server-3.0.2-1.fc15.i686
311c311
< flash-plugin-10.3.181.14-release.i386
---
> flash-plugin-10.3.181.22-release.i386
394c394
< gnome-dvb-daemon-0.2.0-1.fc15.i686
---
> gnome-dvb-daemon-0.2.1-1.fc15.i686
422c422
< gnome-settings-daemon-3.0.1-4.fc15.i686
---
> gnome-settings-daemon-3.0.1-6.fc15.i686
706c706
< libcgroup-0.37.1-2.fc15.i686
---
> libcgroup-0.37.1-3.fc15.i686
904c904
< libtorrent-0.12.7-1.fc15.i686
---
> libtorrent-0.12.8-1.fc15.i686
1005c1005
< logrotate-3.7.9-8.fc15.i686
---
> logrotate-3.7.9-11.fc15.i686
1115,1117c1115,1117
< NetworkManager-0.8.999-3.git20110526.fc15.i686
< NetworkManager-glib-0.8.999-3.git20110526.fc15.i686
< NetworkManager-gnome-0.8.999-3.git20110526.fc15.i686
---
> NetworkManager-0.8.9997-1.git20110531.fc15.i686
> NetworkManager-glib-0.8.9997-1.git20110531.fc15.i686
> NetworkManager-gnome-0.8.9997-1.git20110531.fc15.i686
1200c1200
< parted-2.3-8.fc15.i686
---
> parted-2.3-9.fc15.i686
1425c1425
< rdesktop-1.6.0-11.fc15.i686
---
> rdesktop-1.6.0-12.fc15.i686
1466c1466
< rtorrent-0.8.7-6.fc15.i686
---
> rtorrent-0.8.8-1.fc15.i686
1482,1483c1482,1483
< selinux-policy-3.9.16-24.fc15.noarch
< selinux-policy-targeted-3.9.16-24.fc15.noarch
---
> selinux-policy-3.9.16-26.fc15.noarch
> selinux-policy-targeted-3.9.16-26.fc15.noarch
1487c1487
< setroubleshoot-3.0.31-1.fc15.i686
---
> setroubleshoot-3.0.35-1.fc15.i686
1489c1489
< setroubleshoot-server-3.0.31-1.fc15.i686
---
> setroubleshoot-server-3.0.35-1.fc15.i686
1500c1500
< shotwell-0.9.2-1.fc15.i686
---
> shotwell-0.9.3-1.fc15.i686
1505c1505
< sip-4.12.1-3.fc15.i686
---
> sip-4.12.1-5.fc15.i686
1595c1595
< Thunar-1.2.1-5.fc15.i686
---
> Thunar-1.2.2-1.fc15.i686
1679c1679
< xfce4-settings-4.8.1-4.fc15.i686
---
> xfce4-settings-4.8.2-1.fc15.i686
1743c1743
< xorg-x11-server-common-1.10.1-14.fc15.i686
---
> xorg-x11-server-common-1.10.2-1.fc15.i686
1745,1746c1745,1746
< xorg-x11-server-Xephyr-1.10.1-14.fc15.i686
< xorg-x11-server-Xorg-1.10.1-14.fc15.i686
---
> xorg-x11-server-Xephyr-1.10.2-1.fc15.i686
> xorg-x11-server-Xorg-1.10.2-1.fc15.i686

Comment 4 Ben Williams 2011-06-08 17:03:39 UTC
Scott if you please push the update, I produce updated livecd for the community having an updated livecds are saving alot of new users problems

Comment 5 Brian Lane 2011-06-08 17:21:10 UTC
You can work around this by not installing the latest f15 parted.

Comment 6 Scott Dowdle 2011-06-08 18:53:10 UTC
(In reply to comment #5)
> You can work around this by not installing the latest f15 parted.

Some of us remixers setup our own local mirrors but primarily just rsync from the stock Fedora repos.  Others of us use the stock Fedora repos remotely.  In both cases, once something is in the official repos, it is a bit of engineering to not use a current package and use an older one instead... but I'm sure I'm not telling you anything you don't already know.  Point taken.

Comment 7 Fedora Update System 2011-06-08 19:27:58 UTC
pyparted-3.5-3.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/pyparted-3.5-3.fc15

Comment 8 Fedora Update System 2011-06-10 13:28:36 UTC
Package pyparted-3.5-3.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing pyparted-3.5-3.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/pyparted-3.5-3.fc15
then log in and leave karma (feedback).

Comment 9 satellitgo 2011-06-10 15:00:32 UTC
Fedora-16-Nightly-20110609.22-i686-Live-soas.iso
burned to CD and boots
Problems booting=
Boot line: (delete quiet)  selinux=0 and setenforce=0 safe mode boot: sed: can't read /etc/rc.d/init.d/halt: No such file or directory after started Network Manager  sees em1 NIC Link but NM does not see it-long pause-[211.798771] ---[ end trace..........]  cat5  unplug / replug sees it as up -no farther progress towards boot then starting sandbox and get boot  (5+ minutes) get gdm login 

liveinst f5 root:
installs  properly to 8 Gb USB "custom ext4 as /" no swap 
 "Congratulations your Generic installation is complete"
USB boots fine to firstboot  (no smolt profile shown (empty screen)
Generic release 16 (Generic) gdm login  Sugar starts and jabber works

Looks like  pyparted was updated in build

Comment 10 Arun S A G 2011-06-10 18:11:56 UTC
I tried to build a  livecd after updating to the latest version of pyparted (pyparted-3.5-3). 

I encountered the following bug:

https://bugzilla.redhat.com/show_bug.cgi?id=712468


Here is my kickstart file: 

http://zer0c00l.in/downloads/fedora-aos.ks


Is it problem with my kickstart package selection or anaconda?

liveinst -C isn't working either.

Comment 11 Brian Lane 2011-06-13 17:16:27 UTC
*** Bug 712840 has been marked as a duplicate of this bug. ***

Comment 12 Peque 2011-06-14 01:37:58 UTC
Works with pyparted-3.5-3.fc15.

Thanks! :-D

Comment 13 Fedora Update System 2011-06-15 05:30:43 UTC
pyparted-3.5-3.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.