Bug 712152 - [abrt] telepathy-sunshine-0.2.0-1.fc14: protocol.py:33:<module>:AttributeError: 'module' object has no attribute 'Protocol'
[abrt] telepathy-sunshine-0.2.0-1.fc14: protocol.py:33:<module>:AttributeErro...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: telepathy-sunshine (Show other bugs)
14
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Julian Sikorski
Fedora Extras Quality Assurance
abrt_hash:bfc3523d
:
Depends On: 631458
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-09 11:40 EDT by Maciek Borzecki
Modified: 2011-06-28 16:29 EDT (History)
2 users (show)

See Also:
Fixed In Version: python-telepathy-0.15.19-2.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-06-28 16:29:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: backtrace (7.46 KB, text/plain)
2011-06-09 11:40 EDT, Maciek Borzecki
no flags Details

  None (edit)
Description Maciek Borzecki 2011-06-09 11:40:22 EDT
abrt version: 1.1.18
architecture: i686
Attached file: backtrace, 7637 bytes
component: telepathy-sunshine
executable: /usr/libexec/telepathy-sunshine
kernel: 2.6.35.13-91.fc14.i686
package: telepathy-sunshine-0.2.0-1.fc14
reason: protocol.py:33:<module>:AttributeError: 'module' object has no attribute 'Protocol'
release: Fedora release 14 (Laughlin)
time: 1307633925
uid: 500

comment
-----
started crashing after latest update, relevant output from yum history info:
Packages Altered:
    Updated sssd-1.5.7-1.fc14.i686
    Update       1.5.8-1.fc14.i686
    Updated sssd-client-1.5.7-1.fc14.i686
    Update              1.5.8-1.fc14.i686
    Updated telepathy-sunshine-0.1.8-2.fc14.noarch
    Update                     0.2.0-1.fc14.noarch

How to reproduce
-----
1. setup a gadu-gadu account in empathy
2.  wait
3.
Comment 1 Maciek Borzecki 2011-06-09 11:40:24 EDT
Created attachment 503924 [details]
File: backtrace
Comment 2 Julian Sikorski 2011-06-10 00:37:56 EDT
I am definitely not seeing this on fc15. Is the problem happening every time you start empathy?
Comment 3 Maciek Borzecki 2011-06-10 01:50:48 EDT
Yes, each time empathy is started and gadu is enabled I see the crash. I looked into protocol.py and the SunshineProtocol is defined as follows:

import telepathy
...
class SunshineProtocol(telepathy.server.Protocol,
                        telepathy.server.ProtocolInterfacePresence,
                        ProtocolInterfaceAvatars):

Then looking into ../python/site-packages/telepathy/server Protocol class does not pop up anywhere. 
The tree for telepathy-python here http://cgit.freedesktop.org/telepathy/telepathy-python/ shows that protocol.py (which includes Protocol class) was added between 0.15.18 and 0.15.19. I guess F14 needs a backport of python-telepathy from F15.
Comment 4 Julian Sikorski 2011-06-10 02:01:37 EDT
Sorry about that, I forgot about that requirement. I'm CCing the python-telepathy maintainer.
Comment 5 Brian Pepple 2011-06-14 11:07:25 EDT
Ugh... I really don't like updating libraries in our stable releases. Let me look to see that it doesn't negatively effect papyon & tp-butterfly, and I look into updating it. Please in the future, use more care before pushing updates into our stable branches.
Comment 6 Julian Sikorski 2011-06-14 11:27:46 EDT
Yeah, sorry about that, it is definitely my mistake. I asked for the update since according to koji you tried to build it already, and I assumed it was not pushed solely due to build failure.
Comment 7 Brian Pepple 2011-06-14 12:24:10 EDT
(In reply to comment #6)
> Yeah, sorry about that, it is definitely my mistake. I asked for the update
> since according to koji you tried to build it already, and I assumed it was not
> pushed solely due to build failure.

I've approved your commit request, so if you want to look into building python-telepathy for F14 you can, since it will probably be a few days before I'll get a chance to look into it.
Comment 8 Julian Sikorski 2011-06-14 15:52:11 EDT
Maciek, please try the package from koji:
https://koji.fedoraproject.org/koji/buildinfo?buildID=247764
I was using an equivalent one for some time on f14, but I'd rather be safe than sorry again.
Comment 9 Fedora Update System 2011-06-14 17:21:34 EDT
python-telepathy-0.15.19-2.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/python-telepathy-0.15.19-2.fc14
Comment 10 Fedora Update System 2011-06-15 14:31:09 EDT
Package python-telepathy-0.15.19-2.fc14:
* should fix your issue,
* was pushed to the Fedora 14 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing python-telepathy-0.15.19-2.fc14'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/python-telepathy-0.15.19-2.fc14
then log in and leave karma (feedback).
Comment 11 Fedora Update System 2011-06-28 16:29:32 EDT
python-telepathy-0.15.19-2.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.