Bug 71223 - kernel BUG at transaction.c:1224
kernel BUG at transaction.c:1224
Status: CLOSED DUPLICATE of bug 71545
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
8.0
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Stephen Tweedie
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-10 07:57 EDT by Pawel Salek
Modified: 2007-04-18 12:45 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:49:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pawel Salek 2002-08-10 07:57:49 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020804

Description of problem:
I attempted to copy data from failing IDE hard disk to a new one. This triggered
a kernel bug.

Version-Release number of selected component (if applicable):
kernel-2.4.18-7.92 (IIRC, I have up2dated kernel just after the failure to 7.93).

EXT3-fs error (device ide1(22,2)): ext3_free_blocks: Freeing block in system
zone - block = 16
Assertion failure in journal_forget_R11cff26b() at transaction.c:1224:
"!jh->b_committed_data"
------------[ cut here ]------------
kernel BUG at transaction.c:1224!
invalid operand: 0000
cmpci soundcore autofs ne2k-pci 8390 8139too mii ipt_REJECT iptable_filter ip_
CPU:    0
EIP:    0010:[<d082c7d6>]    Not tainted
EFLAGS: 00013282

EIP is at journal_forget_R11cff26b [jbd] 0x1a6 (2.4.18-7.80)
eax: 00000062   ebx: cdaf9894   ecx: 00000001   edx: 00000001
esi: c92767d4   edi: cf966c30   ebp: cf88dd18   esp: cf88dcf0
ds: 0018   es: 0018   ss: 0018
Process rm (pid: 7533, stackpage=cf88d000)
Stack: d0833480 d0832e96 d0832d30 000004c8 d0832eaf cf966bbc c1a87dec c6efe4c4
       c9931104 cbddbb54 cf88dd4c d083c6c3 cbddbb54 cdaf9894 00000018 00000018
       ffffff0e c0142069 00000010 00000297 c6efe4c4 00000004 cf88c000 cf88dd94
Call Trace: [<d0833480>] .rodata.str1.32 [jbd] 0x0

[<d0832e96>] .rodata.str1.1 [jbd] 0x176
[<d0832d30>] .rodata.str1.1 [jbd] 0x10
[<d0832eaf>] .rodata.str1.1 [jbd] 0x18f
[<d083c6c3>] ext3_forget [ext3] 0x63
[<c0142069>] get_hash_table [kernel] 0x59
[<d083eaa9>] ext3_clear_blocks [ext3] 0x119
[<d082bef3>] journal_get_write_access_R2d7c0bce [jbd] 0x53
[<d083ec14>] ext3_free_data [ext3] 0xb4
[<c011792e>] schedule [kernel] 0x17e
[<d083efb6>] ext3_free_branches [ext3] 0x296
[<c0142ad8>] bread [kernel] 0x98
[<d083ede1>] ext3_free_branches [ext3] 0xc1
[<d083c812>] start_transaction [ext3] 0x92
[<d083f3e6>] ext3_truncate [ext3] 0x406
[<d082b23d>] start_this_handle [jbd] 0x9d
[<d082b420>] journal_start_R682d7ddb [jbd] 0xa0
[<d083c812>] start_transaction [ext3] 0x92
[<d083c988>] ext3_delete_inode [ext3] 0xf8
[<d0842681>] ext3_unlink [ext3] 0x111
[<d083c890>] ext3_delete_inode [ext3] 0x0
[<c01561ea>] iput [kernel] 0x10a
[<c014cd3d>] vfs_unlink [kernel] 0xed
[<c014cf72>] sys_unlink [kernel] 0x102
[<c01092df>] system_call [kernel] 0x33


Code: 0f 0b c8 04 30 2d 83 d0 e9 61 ff ff ff c7 04 24 80 34 83 d0
Comment 1 Stephen Tweedie 2002-08-12 06:08:35 EDT
When you say a "failing IDE drive", what was the manner of the failure?  Were
there any other log messages relating to ext3 or IDE failures?
Comment 2 Pawel Salek 2002-08-12 06:46:10 EDT
The disk had hardware reading problems and they were reported as IDE reading errors.

These were the only mesages printed (i.e IDE+ext3).
Comment 3 Pawel Salek 2003-03-18 07:12:58 EST
I should comment that this bug was traced to errors in vt8233a motherboard
support. This is fixed in current kernels.

*** This bug has been marked as a duplicate of 71545 ***
Comment 4 Red Hat Bugzilla 2006-02-21 13:49:22 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.