Bug 71545 - KT333 / VT8233A IDE Errors
KT333 / VT8233A IDE Errors
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.3
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
: 71223 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-14 19:37 EDT by Seth Bardash
Modified: 2007-04-18 12:45 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-04 20:13:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Seth Bardash 2002-08-14 19:37:17 EDT
Description of Problem: IDE driver fails to recognize UDMA133 controller and 
gives muliple errors of:

hda: dma_intr: status=0x51 { DriveReady SeekComplete Error }
hda: dma_intr: error=0x84 { DriveStatusError BadCRC }
............

Version-Release number of selected component (if applicable): 2.4.18-5


How Reproducible:
Every time.

Steps to Reproduce:
1. Install ISO 7.3 (2.4.18-3 kernel does not recognize IDE controller)
2. upgrade to 2.4.18-5 via up2date,
3. reboot -> 2.4.18-5 kernel

Actual Results: Systems boots but gets numerous error messages as listed above


Expected Results: Should come up and run UDMA-133 disks without errors

Additional Information:

Running Gigabyte GA-7VRXP motherboard with AMD XP2100+, 1 GB DRAM, 40 GB Maxtor 
UDMA-133 disk, CDROM, Floppy, ATI Xpert 98 Graphics card, Netgear FA310TX 2nd 
ethernet NIC.

Fixed the problem by using the patch at 
http://www.andrew.cmu.edu/user/qralston/dev/. 

This works and produces an RPM that is installable to fix the problem. Redhat 
needs to add these changes to the next release to handle this issue.
Comment 1 Pawel Salek 2002-08-19 07:45:04 EDT
I would like to confirm this: I see similar problem with my Asus A7V333
motheboard. Unfortunately, I have learnt it the hard way: most of the data on
the hard disk was lost.
Comment 2 Pawel Salek 2002-08-24 12:35:26 EDT
This is still not fixed in 2.4.18-10.
Comment 3 baulv 2002-08-24 12:51:50 EDT
see the same bug reported as #67366.
The drive giving the error is also a ATA133  MAXTOR_6L040J2 on a ASUS_A7V333 mobo.
http://www.maxtor.com/en/documentation/data_sheets/diamondmax_D740X_datasheet.pdf
Comment 4 Need Real Name 2002-08-26 16:34:23 EDT
I have the same problem, Asus A7V333 motherboard, 80GB WD. Very annoying.

Arjan, are you aware of James Ralston's fix here?

http://www.andrew.cmu.edu/user/qralston/dev/

I'd love to see this fixed for RHL 8.0

Thanks,
Jesper
Comment 5 Need Real Name 2002-08-26 16:35:35 EDT
Duh! The URL was already in the original comment. Never mind.
Comment 6 Seth Bardash 2002-10-04 20:13:30 EDT
I reported this originally on 8-14-02. Since then RH has released 2.4.18-10. 

At what point can we expect this to be fixed??? Do I need to downgrade from -10 
to -5 and add the patch to get this to work or can we expect 7.3 to properly 
support this soon??? 

There are quite a few motherboards out there with the VT8233A South Bridge.

Your product does not support this at this time. What is a reasonable date to 
expect this support?

Thanks

Seth
Comment 7 Seth Bardash 2002-10-08 19:08:55 EDT
OK. Update.... 2.4.18-10 now has a patch available from James Ralston @

http://www.andrew.cmu.edu/user/qralston/dev/

Also: This has been fixed in Red Hat 8.0 and works correctly on the 
Gigabyte GA-7VRXP motherboard with XP2200+ processors, DDR266 CL 2.0 Memory,
and a maxtor 40GB ATA-133 7200 RPM disk connected as /dev/hda
(We have tested this on 5 units for 5 days without any problems)

It would have been nice to have been informed that 8.0 fully supports the
8233A in the 2.4.18-14 kernel.
Comment 8 Pawel Salek 2003-03-18 07:13:00 EST
*** Bug 71223 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.