Bug 712280 - (ghc-ghc-mtl) Review Request: ghc-ghc-mtl - A mtl compatible with GHC-API monads and monad-transformers
Review Request: ghc-ghc-mtl - A mtl compatible with GHC-API monads and monad-...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Shakthi Kannan
Fedora Extras Quality Assurance
Ready
:
Depends On: ghc-MonadCatchIO-mtl
Blocks: 712284
  Show dependency treegraph
 
Reported: 2011-06-10 02:03 EDT by Narasimhan
Modified: 2014-11-12 18:19 EST (History)
5 users (show)

See Also:
Fixed In Version: ghc-exceptions-0.6.1-1.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-23 23:54:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
shakthimaan: fedora‑review+
limburgher: fedora‑cvs+


Attachments (Terms of Use)

  None (edit)
Description Narasimhan 2011-06-10 02:03:59 EDT
Spec file : http://narasim.fedorapeople.org/package_reviews/ghc-ghc-mtl.spec

SRPM link : http://narasim.fedorapeople.org/package_reviews/ghc-ghc-mtl-1.0.1.0-1.fc14.src.rpm

rpmlint output:

ghc-ghc-mtl-prof.i686: E: devel-dependency ghc-ghc-mtl-devel
Your package has a dependency on a devel package but it's not a devel package
itself.

ghc-ghc-mtl-prof.i686: W: no-documentation
The package contains no documentation (README, doc, etc). You have to include
documentation files.

ghc-ghc-mtl-prof.i686: W: devel-file-in-non-devel-package /usr/lib/ghc-6.12.3/ghc-mtl-1.0.1.0/libHSghc-mtl-1.0.1.0_p.a
A development file (usually source code) is located in a non-devel package. If
you want to include source code in your package, be sure to create a
development package.

4 packages and 1 specfiles checked; 1 errors, 2 warnings.

Required for yi.
Comment 1 Karel Klíč 2011-12-06 13:16:50 EST
Failed to build it in mock:

ERROR: Command failed: 
 # ['/usr/bin/yum-builddep', '--installroot', '/var/lib/mock/fedora-rawhide-i386/root/', '/var/lib/mock/fedora-rawhide-i386/root///builddir/build/SRPMS/ghc-ghc-mtl-1.0.1.0-1.fc17.src.rpm']
Getting requirements for ghc-ghc-mtl-1.0.1.0-1.fc17.src
 --> ghc-7.0.4-40.fc17.i686
Error: No Package found for ghc-doc
Comment 2 Narasimhan 2012-07-15 10:48:19 EDT
Not required for hint.
Comment 3 Narasimhan 2012-07-15 11:09:20 EDT
Reopening.
Comment 4 Narasimhan 2012-07-15 11:20:51 EDT
http://narasim.fedorapeople.org/package_reviews/ghc-ghc-mtl.spec

http://narasim.fedorapeople.org/package_reviews/ghc-ghc-mtl-1.0.1.1-1.fc16.src.rpm

rpmlint  -i ghc-ghc-mtl-1.0.1.1-1.fc16.src.rpm ghc-ghc-mtl-1.0.1.1-1.fc16.x86_64.rpm ghc-ghc-mtl-devel-1.0.1.1-1.fc16.x86_64.rpm ../ghc-ghc-mtl.spec 
ghc-ghc-mtl.src: W: spelling-error Summary(en_US) monads -> nomads, gonads
The value of this tag appears to be misspelled. Please double-check.

ghc-ghc-mtl.src: W: spelling-error Summary(en_US) monad -> nomad, gonad, Mona
The value of this tag appears to be misspelled. Please double-check.

ghc-ghc-mtl.src: W: spelling-error %description -l en_US monad -> nomad, gonad, Mona
The value of this tag appears to be misspelled. Please double-check.

ghc-ghc-mtl.x86_64: W: spelling-error Summary(en_US) monads -> nomads, gonads
The value of this tag appears to be misspelled. Please double-check.

ghc-ghc-mtl.x86_64: W: spelling-error Summary(en_US) monad -> nomad, gonad, Mona
The value of this tag appears to be misspelled. Please double-check.

ghc-ghc-mtl.x86_64: W: spelling-error %description -l en_US monad -> nomad, gonad, Mona
The value of this tag appears to be misspelled. Please double-check.

ghc-ghc-mtl-devel.x86_64: W: spelling-error Summary(en_US) monads -> nomads, gonads
The value of this tag appears to be misspelled. Please double-check.

ghc-ghc-mtl-devel.x86_64: W: spelling-error Summary(en_US) monad -> nomad, gonad, Mona
The value of this tag appears to be misspelled. Please double-check.

ghc-ghc-mtl-devel.x86_64: W: spelling-error %description -l en_US monad -> nomad, gonad, Mona
The value of this tag appears to be misspelled. Please double-check.

3 packages and 1 specfiles checked; 0 errors, 9 warnings.
Comment 5 Narasimhan 2012-07-16 08:30:44 EDT
ghc-hint works with version <1.1.0.0. Hence keeping the version of ghc-mtl to 1.0.1.1 for now.
Comment 7 Shakthi Kannan 2012-09-10 08:23:11 EDT
[+]MUST: rpmlint must be run on every package. The output should be posted in the review.

$ rpmlint ghc-ghc-mtl.spec 
0 packages and 1 specfiles checked; 0 errors, 0 warnings.

$ rpmlint ghc-ghc-mtl-1.0.1.1-1.fc16.src.rpm 
ghc-ghc-mtl.src: W: spelling-error Summary(en_US) monads -> nomads, gonads
ghc-ghc-mtl.src: W: spelling-error Summary(en_US) monad -> nomad, gonad, Mona
ghc-ghc-mtl.src: W: spelling-error %description -l en_US monad -> nomad, gonad, Mona
1 packages and 0 specfiles checked; 0 errors, 3 warnings.

$ rpmlint ghc-ghc-mtl-1.0.1.1-1.fc16.x86_64.rpm 
ghc-ghc-mtl.x86_64: W: spelling-error Summary(en_US) monads -> nomads, gonads
ghc-ghc-mtl.x86_64: W: spelling-error Summary(en_US) monad -> nomad, gonad, Mona
ghc-ghc-mtl.x86_64: W: spelling-error %description -l en_US monad -> nomad, gonad, Mona
1 packages and 0 specfiles checked; 0 errors, 3 warnings.

$ rpmlint ghc-ghc-mtl-devel-1.0.1.1-1.fc16.x86_64.rpm  
ghc-ghc-mtl-devel.x86_64: W: spelling-error Summary(en_US) monads -> nomads, gonads
ghc-ghc-mtl-devel.x86_64: W: spelling-error Summary(en_US) monad -> nomad, gonad, Mona
ghc-ghc-mtl-devel.x86_64: W: spelling-error %description -l en_US monad -> nomad, gonad, Mona
1 packages and 0 specfiles checked; 0 errors, 3 warnings.

[+]MUST: The package must be named according to the Package Naming Guidelines.
[+]MUST: The spec file name must match the base package %{name}, in the format %{name}.spec
[+]MUST: The package must meet the Packaging Guidelines.
        Naming-Yes
        Version-release - Matches
        License - OK
        No prebuilt external bits - OK
        Spec legibity - OK
        Package template - OK
        Arch support - OK
        Libexecdir - OK
        rpmlint - yes
        changelogs - OK
        Source url tag  - OK, validated.
        Build Requires list - OK
        Summary and description - OK
        API documentation - OK, in devel package

[+]MUST: The package must be licensed with a Fedora approved license and meet the Licensing Guidelines.

BSD

[+]MUST: The License field in the package spec file must match the actual license.
[+]MUST: If (and only if) the source package includes the text of the license(s) in its own file, then that file, containing the text of the license(s) for the package must be included in %doc.
LICENSE file is included.
[+]MUST: The spec file must be written in American English.
[+]MUST: The spec file for the package MUST be legible.
[+]MUST: The sources used to build the package must match the upstream source, as provided in the spec URL. Reviewers should use sha256sum for this task as it is used by the sources file once imported into git. If no upstream URL can be specified for this package, please see the Source URL Guidelines for how to deal with this.

$  sha256sum ghc-mtl-1.0.1.1.tar.gz 
f63a10a67a3e0f86d96738abd325e25a44b86c280bb531058097f37ec40b9512  ghc-mtl-1.0.1.1.tar.gz

$  rpm2cpio ghc-ghc-mtl-1.0.1.1-1.fc16.src.rpm | cpio -idv
ghc-ghc-mtl.spec
ghc-mtl-1.0.1.1.tar.gz
9 blocks

$  sha256sum ghc-mtl-1.0.1.1.tar.gz 
f63a10a67a3e0f86d96738abd325e25a44b86c280bb531058097f37ec40b9512  ghc-mtl-1.0.1.1.tar.gz

[+]MUST: The package MUST successfully compile and build into binary rpms on at least one primary architecture.

Built on x86_64. koji builds for f16,f17 and f18 done by packager.

[+]MUST: If the package does not successfully compile, build or work on an architecture, then those architectures should be listed in the spec in ExcludeArch.
[+]MUST: All build dependencies must be listed in BuildRequires.
[+]MUST: Packages must NOT bundle copies of system libraries.
Checked with rpmquery --list.
[NA]MUST: If the package is designed to be relocatable, the packager must state this fact in the request for review.
[+]MUST: A package must own all directories that it creates.
Checked with rpmquery --whatprovides.
[+]MUST: A Fedora package must not list a file more than once in the spec file's %files listings.
[+]MUST: Permissions on files must be set properly. Executables should be set with executable permissions, for example.
[+]MUST: Each package must consistently use macros.
[+]MUST: The package must contain code, or permissible content.
[+]MUST: Large documentation files must go in a -doc subpackage.
API documentation in -devel package.
[+]MUST: If a package includes something as %doc, it must not affect the runtime of the application.
[+]MUST: devel packages must require the base package using a fully versioned dependency: Requires: {name} = %{version}-%{release}
[NA]MUST: Packages must NOT contain any .la libtool archives, these must be removed in the spec if they are built.
[NA]MUST: Packages containing GUI applications must include a %{name}.desktop file, and that file must be properly installed with desktop-file-install in the %install section
[+]MUST: Packages must not own files or directories already owned by other packages.
[+]MUST: All filenames in rpm packages must be valid UTF-8.

Should items
[+]SHOULD: If the source package does not include license text(s) as a separate file from upstream, the packager SHOULD query upstream to include it. 
[-]SHOULD: The description and summary sections in the package spec file should contain translations for supported Non-English languages, if available. 
[-]SHOULD: The reviewer should test that the package builds in mock. 
[+]SHOULD: The reviewer should test that the package functions as described. A package should not segfault instead of running, for example.
Loaded Blaze.Text.Double into ghci. Loads fine.
[+]SHOULD: If scriptlets are used, those scriptlets must be sane. This is vague, and left up to the reviewers judgement to determine sanity.

cabal2spec-diff is OK.

Please write each BR in a separate line before import.

APPROVED.
Comment 8 Narasimhan 2012-09-10 08:30:08 EDT
Thanks for the review. Yes, will make the required changes before importing.

New Package SCM Request
=======================
Package Name: ghc-ghc-mtl
Short Description: A mtl compatible with GHC-API monads and monad-transformers
Owners: narasim
Branches: f16 f17 f18
InitialCC: haskell-sig
Comment 9 Jon Ciesla 2012-09-10 08:41:10 EDT
Git done (by process-git-requests).
Comment 10 Fedora Update System 2012-09-18 10:49:35 EDT
ghc-ghc-mtl-1.0.1.1-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/ghc-ghc-mtl-1.0.1.1-1.fc17
Comment 11 Fedora Update System 2012-09-18 10:49:49 EDT
ghc-ghc-mtl-1.0.1.1-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/ghc-ghc-mtl-1.0.1.1-1.fc18
Comment 12 Fedora Update System 2012-09-18 10:50:12 EDT
ghc-ghc-mtl-1.0.1.1-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/ghc-ghc-mtl-1.0.1.1-1.fc16
Comment 13 Fedora Update System 2012-09-18 15:23:19 EDT
ghc-ghc-mtl-1.0.1.1-1.fc18 has been pushed to the Fedora 18 testing repository.
Comment 14 Jens Petersen 2014-10-22 23:59:19 EDT
Package Change Request
======================
Package Name: ghc-ghc-mtl
New Branches: epel7 el6
Owners: petersen
InitialCC: haskell-sig
Comment 15 Jon Ciesla 2014-10-23 08:20:21 EDT
Git done (by process-git-requests).
Comment 16 Fedora Update System 2014-10-24 06:06:31 EDT
ghc-exceptions-0.6.1-1.el7, ghc-ghc-mtl-1.2.1.0-1.el7 has been submitted as an update for Fedora EPEL 7.
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2014-3568/ghc-exceptions-0.6.1-1.el7,ghc-ghc-mtl-1.2.1.0-1.el7
Comment 17 Fedora Update System 2014-11-12 18:19:04 EST
ghc-exceptions-0.6.1-1.el7, ghc-ghc-mtl-1.2.1.0-1.el7, ghc-hint-0.4.2.0-2.el7 has been pushed to the Fedora EPEL 7 stable repository.

Note You need to log in before you can comment on or make changes to this bug.