Bug 712726 - libvirtd.stp is in the wrong path
libvirtd.stp is in the wrong path
Status: CLOSED DUPLICATE of bug 737657
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
15
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Libvirt Maintainers
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-12 14:46 EDT by Josh Stone
Modified: 2012-06-06 20:54 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-06 20:54:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Josh Stone 2011-06-12 14:46:09 EDT
Description of problem:
The file /usr/share/systemtap/tapsets/libvirtd.stp is not in the correct place for systemtap to find it -- should be .../tapset/...

Version-Release number of selected component (if applicable):
libvirt-0.8.8-4.fc15.x86_64
systemtap-1.4-9.fc15.x86_64

How reproducible:
100%

Steps to Reproduce:
$ stap -l 'libvirt.**'
  
Actual results:
Nothing printed; $? is 1.

Expected results:
You can manually add that search path to see what should have been:
$ stap -l 'libvirt.**' -I /usr/share/systemtap/tapsets/
libvirt.daemon.client.auth_allow
libvirt.daemon.client.auth_deny
libvirt.daemon.client.auth_fail
libvirt.daemon.client.connect
libvirt.daemon.client.disconnect
libvirt.daemon.client.tls_allow
libvirt.daemon.client.tls_deny
libvirt.daemon.client.tls_fail

Additional info:
Looking to rawhide, the path appears to be corrected as of libvirt-0.9.1.
Comment 1 Fedora Admin XMLRPC Client 2011-09-22 13:52:30 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 2 Fedora Admin XMLRPC Client 2011-09-22 13:55:57 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 3 Fedora Admin XMLRPC Client 2011-11-30 15:02:34 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 4 Fedora Admin XMLRPC Client 2011-11-30 15:02:39 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 5 Fedora Admin XMLRPC Client 2011-11-30 15:07:10 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 6 Fedora Admin XMLRPC Client 2011-11-30 15:07:15 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 7 Eric Blake 2011-12-07 10:48:29 EST
We should backport this to F15.

commit a7e80bde110d2dfc19c41cf805a5f555d204b849
Author: Daniel P. Berrange <berrange@redhat.com>
Date:   Tue Apr 5 16:18:37 2011 +0100

    Fix typo in systemtap tapset directory name
    
    The systemtap directory for tapsets is called
    
      /usr/share/systemtap/tapset
    
    Not
    
     /usr/share/systemtap/tapsets
    
    * daemon/Makefile.am,libvirt.spec.in: s/tapsets/tapset/
Comment 8 Cole Robinson 2012-06-06 20:54:38 EDT

*** This bug has been marked as a duplicate of bug 737657 ***

Note You need to log in before you can comment on or make changes to this bug.