This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 737657 - libvirtd.stp should be in /usr/share/systemtap/tapset/
libvirtd.stp should be in /usr/share/systemtap/tapset/
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
15
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Libvirt Maintainers
Fedora Extras Quality Assurance
:
: 712726 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-12 15:54 EDT by William Cohen
Modified: 2012-06-06 20:54 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-06 20:53:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description William Cohen 2011-09-12 15:54:52 EDT
Description of problem:

The libvirtd.stp tapset is installed in the wrong place. It is in:

/usr/share/systemtap/tapsets/libvirtd.stp

It SHOULD be in:

/usr/share/systemtap/tapset/libvirtd.stp

Version-Release number of selected component (if applicable):

libvirt-0.8.8-7.fc15.x86_64

How reproducible:

Everytime

Steps to Reproduce:
1. Install systemap and libvirtd rpms on machine
2. stap -L "libvirt.daemon.*.*"
  
Actual results:

No probes listed


Expected results:

$ stap -L "libvirt.daemon.*.*"
libvirt.daemon.client.auth_allow fd:long authtype:long authname:string identity:string $arg1:long $arg2:long $arg3:long
libvirt.daemon.client.auth_deny fd:long authtype:long authname:string identity:string $arg1:long $arg2:long $arg3:long
libvirt.daemon.client.auth_fail fd:long authtype:long authname:string $arg1:long $arg2:long
libvirt.daemon.client.connect fd:long readonly:long localAddr:string remoteAddr:string $arg1:long $arg2:long $arg3:long $arg4:long
libvirt.daemon.client.disconnect fd:long $arg1:long
libvirt.daemon.client.tls_allow fd:long x509dname:string $arg1:long $arg2:long
libvirt.daemon.client.tls_deny fd:long x509dname:string $arg1:long $arg2:long
libvirt.daemon.client.tls_fail fd:long $arg1:long



Additional info:
Comment 1 Fedora Admin XMLRPC Client 2011-09-22 13:53:17 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 2 Fedora Admin XMLRPC Client 2011-09-22 13:57:08 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 3 Fedora Admin XMLRPC Client 2011-11-30 15:03:59 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 4 Fedora Admin XMLRPC Client 2011-11-30 15:04:04 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 5 Fedora Admin XMLRPC Client 2011-11-30 15:08:23 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 6 Fedora Admin XMLRPC Client 2011-11-30 15:08:27 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 7 Eric Blake 2012-01-04 12:36:17 EST
Fixed here:

commit a7e80bde110d2dfc19c41cf805a5f555d204b849
Author: Daniel P. Berrange <berrange@redhat.com>
Date:   Tue Apr 5 16:18:37 2011 +0100

    Fix typo in systemtap tapset directory name
Comment 8 Cole Robinson 2012-06-06 20:53:34 EDT
Not that important for this point in F15 cycle, and fix is already in F16+. Closing as WONTFIX
Comment 9 Cole Robinson 2012-06-06 20:54:38 EDT
*** Bug 712726 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.