This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 713082 - multiprocessing.Pipe problem: "handle out of range in select()"
multiprocessing.Pipe problem: "handle out of range in select()"
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: python (Show other bugs)
6.1
Unspecified Linux
high Severity urgent
: rc
: ---
Assigned To: Dave Malcolm
Petr Šplíchal
:
Depends On:
Blocks: 849992
  Show dependency treegraph
 
Reported: 2011-06-14 04:45 EDT by Igor Lvovsky
Modified: 2016-05-31 21:42 EDT (History)
5 users (show)

See Also:
Fixed In Version: python-2.6.6-21.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 849992 (view as bug list)
Environment:
Last Closed: 2011-12-06 05:24:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Igor Lvovsky 2011-06-14 04:45:01 EDT
Description of problem:

In vdsm-4.9 code we use multiprocessing.Pipe to communicate with subprocesses.
In several scenarios when we trying to run sufficiently large amount of VMs, the pipe ends raise the exception: "handle out of range in select()".
Actually, it's kind of regression from vdsm-4.5 (we didn't use multiprocessing in vdsm-4.5)

We found same issue (including the patch and reproducer) in python's issue tracker:
 http://bugs.python.org/issue10527


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 6 errata-xmlrpc 2011-12-06 05:24:22 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1564.html

Note You need to log in before you can comment on or make changes to this bug.