Bug 849992 - multiprocessing.Pipe problem: "handle out of range in select()"
multiprocessing.Pipe problem: "handle out of range in select()"
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: python (Show other bugs)
7.0
Unspecified Linux
high Severity urgent
: rc
: ---
Assigned To: Bohuslav "Slavek" Kabrda
Branislav Náter
:
Depends On: 713082
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-21 08:44 EDT by Branislav Náter
Modified: 2014-06-18 00:22 EDT (History)
4 users (show)

See Also:
Fixed In Version: python-2.7.5-4.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 713082
Environment:
Last Closed: 2014-06-13 07:50:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 3 Dave Malcolm 2013-02-21 17:14:38 EST
Fix committed to Fedora git "master" branch for F19 as:
http://pkgs.fedoraproject.org/cgit/python.git/commit/?id=2938c661975c582a54dca69a7dc212f12673afa8

and tested locally.

Building python-2.7.3-27.fc19 for rawhide
Task info: http://koji.fedoraproject.org/koji/taskinfo?taskID=5041648
Comment 4 Dave Malcolm 2013-02-22 11:05:00 EST
(In reply to comment #3)
> Building python-2.7.3-27.fc19 for rawhide
> Task info: http://koji.fedoraproject.org/koji/taskinfo?taskID=5041648
This build failed due to (apparently unrelated) bug 913732 - though test_multiprocessing did run successfully.
Comment 5 Dave Malcolm 2013-03-04 17:19:55 EST
Built into rawhide as part of python-2.7.3-32.fc19 (which added a workaround for bug 913732):
  http://koji.fedoraproject.org/koji/buildinfo?buildID=399980
Comment 6 Bohuslav "Slavek" Kabrda 2013-08-01 05:30:49 EDT
This is fixed upstream as of Python 2.7.4 and thus is fixed in the newest python build for rhel7: python-2.7.5-4.el7
Comment 8 Branislav Náter 2013-11-15 09:32:20 EST
Fix is present in python-2.7.5-10.el7. Verified using automated test. No "handle out of range" error messages present.

<snip>
('Received on', 598, 'Hi dude')
('Received on', 599, 'Hi dude')
:: [   PASS   ] :: Running the reproducer (Expected 0, got 0)
:: [   PASS   ] :: File 'output' should not contain 'handle out of range' 
<snip>
Comment 9 Ludek Smid 2014-06-13 07:50:09 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.