Bug 71387 - up2date-nox will always fail.
Summary: up2date-nox will always fail.
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: up2date   
(Show other bugs)
Version: limbo
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: Adrian Likins
QA Contact: Jay Turner
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 67217
TreeView+ depends on / blocked
 
Reported: 2002-08-12 21:41 UTC by Ivo Sarak
Modified: 2015-01-07 23:59 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-16 23:35:33 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ivo Sarak 2002-08-12 21:41:28 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020712

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
Register, Entitle this machine and run up2date-nox.

Actual Results:  [root@machine root]# up2date-nox -u
creating readOnlyTransaction

Fetching package list for channel: redhat-beta-limbo-i386...
########################################

Fetching Obsoletes list for channel: redhat-beta-limbo-i386...
########################################

Testing package set / solving RPM inter-dependencies...
[root@machine root]#

or additional 'Segmentation Fault' message at the end.



Expected Results:  Proper update.

Additional info:

rpm -qa|grep up2date
up2date-2.9.33-7.x.9
up2date-gnome-2.9.33-7.x.9

Comment 1 Adrian Likins 2002-08-12 21:44:30 UTC
can you get a strace of that?

Comment 2 Michael Young 2002-08-12 23:02:12 UTC
I seem to recall you can get a segmentation fault by running /usr/sbin/up2date
-l directly (rather than via /usr/bin/up2date) with this broken version of up2date.

Comment 3 Adrian Likins 2002-08-12 23:07:16 UTC
Hmm, seems to work for me with 2.9.40'ish code. 

No idea how running it as /usr/sbin/up2date would cause
a segfault. I have seen weirder things though...

Comment 4 Ivo Sarak 2002-08-13 05:34:18 UTC
I can 'strace' it but what script I should run?

Comment 5 Adrian Likins 2002-08-13 21:00:38 UTC
strace /usr/sbin/up2date  -u


should do it

Comment 6 Ivo Sarak 2002-08-14 08:17:07 UTC
Sorry but I already made a upgrade to newer rpm&up2date from RawHide and up2date
does not crash for me anymore.

[root@machine up2date]# rpm -qa|grep rpm-
rpm-4.1-0.77
rpm-build-4.1-0.77
rpm-python-4.1-0.77
rpm-devel-4.1-0.77
gnorpm-0.96-14
[root@machine up2date]# rpm -qa|grep up2date
up2date-2.9.40-7.x.9
up2date-gnome-2.9.40-7.x.9
[root@machine up2date]#

Comment 7 Michael Schwendt 2002-08-16 23:32:40 UTC
> can you get a strace of that?

Adrian, the 2.9.33 version is the one from Limbo beta2 upgrades. It has been
reported earlier that this version would terminate _silently_ upon checking
dependencies. No traceback at all. There have been other bug reports about this.


Comment 8 Michael Schwendt 2002-08-16 23:35:28 UTC
Hence it is most likely a duplicate of bug #70871 (CLOSED because it works again
with 2.9.38) and probably also bug #71047 (still open).


Comment 9 Adrian Likins 2002-08-21 17:54:08 UTC
seems to be working now, closing


Note You need to log in before you can comment on or make changes to this bug.