This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 714048 - smartmontools 5.38 of RHEL5 does not support LSI Megaraid
smartmontools 5.38 of RHEL5 does not support LSI Megaraid
Status: CLOSED DUPLICATE of bug 519261
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: smartmontools (Show other bugs)
5.6
x86_64 Linux
unspecified Severity high
: rc
: ---
Assigned To: Michal Hlavinka
qe-baseos-daemons
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-17 04:44 EDT by Gerrit Slomma
Modified: 2012-09-13 04:01 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-06-17 05:12:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Gerrit Slomma 2011-06-17 04:44:42 EDT
Description of problem:

smartmontools of RHEL5 does not support LSI Megaraid.

Version-Release number of selected component (if applicable):

(5.5) smartmontools.x86_64 1:5.38-2.el5
(5.6) smartmontools.x86_64 1:5.38-2.el5

How reproducible:

Every time.

Steps to Reproduce:
1. # smartctl -a -d megaraid,7 /dev/sda
smartctl version 5.38 [x86_64-redhat-linux-gnu] Copyright (C) 2002-8 Bruce Allen
Home page is http://smartmontools.sourceforge.net/

=======> INVALID ARGUMENT TO -d: megaraid,7
=======> VALID ARGUMENTS ARE: ata, scsi, marvell, sat, 3ware,N, hpt,L/M/N cciss,N <=======

Use smartctl -h to get a usage summary
2.
3.
  
Actual results:

smartctl does not give smart-parameters for disks behind a LSI Megaraid.

Expected results:

rebuild smartmontools 5.39.1 of RHEL6 does support LSI Megaraid

# rpm -ivh /usr/src/redhat/SRPMS/libcap-ng-0.6.4-3.el6_0.1.src.rpm
# rpm -ivh /usr/src/redhat/SRPMS/smartmontools-5.39.1-2.el6.src.rpm
# rpmbuild -bs --define "_source_filedigest_algorithm md5" --define "_binary_filedigest_algorithm md5" --define "dist .el5_0" /usr/src/redhat/SPECS/libcap-ng.spec
# yum localinstall /usr/src/redhat/RPMS/x86_64/libcap-ng-devel-0.6.4-3.el5_0.1.x86_64.rpm /usr/src/redhat/RPMS/x86_64/libcap-ng-0.6.4-3.el5_0.1.x86_64.rpm
# rpmbuild -bp --define "dist .el5" /usr/src/redhat/SPECS/smartmontools.spec
# cd /usr/src/redhat/BUILD/smartmontools-5.39.1
# ./configure
# make
# ./smartctl -a -d megaraid,7 /dev/sda
smartctl 5.39.1 2010-01-28 r3054 [x86_64-unknown-linux-gnu] (local build)
Copyright (C) 2002-10 by Bruce Allen, http://smartmontools.sourceforge.net

Device: SEAGATE  ST9146852SS      Version: 5203
Serial number: 3TB1KCKN00009044L0XU
Device type: disk
Transport protocol: SAS
Local Time is: Fri Jun 17 10:26:37 2011 CEST
Device supports SMART and is Enabled
Temperature Warning Disabled or Not Supported
SMART Health Status: OK

Current Drive Temperature:     33 C
Drive Trip Temperature:        68 C
Elements in grown defect list: 0
Vendor (Seagate) cache information
  Blocks sent to initiator = 4262702523
  Blocks received from initiator = 4170515895
  Blocks read from cache and sent to initiator = 5748988
  Number of read and write commands whose size <= segment size = 48525028
  Number of read and write commands whose size > segment size = 3245041
Vendor (Seagate/Hitachi) factory information
  number of hours powered up = 7695.23
  number of minutes until next internal SMART test = 2

Error counter log:
           Errors Corrected by           Total   Correction     Gigabytes    Total
               ECC          rereads/    errors   algorithm      processed    uncorrected
           fast | delayed   rewrites  corrected  invocations   [10^9 bytes]  errors
read:   83539995        0         0  83539995   83539995       5409.558           0
write:         0        0         0         0          0       2153.566           0
verify: 67200769        0         0  67200769   67200769       5998.535           0

Non-medium error count:      392
No self-tests have been logged
Long (extended) Self Test duration: 1367 seconds [22.8 minutes]

smartmontools of RHEL5 should be rebased to the same version as in RHEL6

Additional info:

# lspci|grep LSI
01:00.0 RAID bus controller: LSI Logic / Symbios Logic LSI MegaSAS 9260 (rev 04)
Comment 1 Michal Hlavinka 2011-06-17 05:12:56 EDT

*** This bug has been marked as a duplicate of bug 519261 ***

Note You need to log in before you can comment on or make changes to this bug.