Bug 7142 - ppp-2.3.10-3.i386.rpm -
ppp-2.3.10-3.i386.rpm -
Product: Red Hat Linux
Classification: Retired
Component: ppp (Show other bugs)
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Nalin Dahyabhai
: 9730 9764 10204 (view as bug list)
Depends On:
  Show dependency treegraph
Reported: 1999-11-19 10:58 EST by apcot
Modified: 2008-05-01 11:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2000-01-17 09:19:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description apcot 1999-11-19 10:58:36 EST
Have RH 6.1.  Updated PPP to latest RH 6.1 patch ppp-2.3.10-3.i386.rpm.
PPP stops working with the following error:

/usr/sbin/pppd: The remote system is required to authenticate itself but I
/usr/sbin/pppd: couldn't find any suitable secret (password) for it to use
to do

Reverted back to RH6.0 ppp distribution (ppp-2.3.7-2) and all works ok. No
changes to script files in either case.

Version: Linux version 2.2.12-20smp (root@porky.devel.redhat.com) (gcc
version egcs-2.91.66 19990314/Linux (egcs-1.1.2 release)) #1 SMP

Anyone have any ideas?

Comment 1 Chris Siebenmann 1999-11-20 05:32:59 EST
I believe if you add 'noauth' in an appropriate spot in the
PPP options (either globally or for that system), this will
stop. Pppd apparently now insists on PAP/CHAP authentication
in some situations where it didn't used to.
Comment 2 apcot 1999-11-21 22:53:59 EST
This solved the problem.  Thanks.
Comment 3 Michael K. Johnson 1999-11-22 15:40:59 EST
You probably already have a default route set up on your machine and
you then ask pppd to set up a default route as well (with PPP, to do
so is the default, so you wouldn't need to do so explicitly).  pppd
won't do it.

The next revision of our initscripts package will solve the problem
completely by deleting the default route before trying to install a
new one.
Comment 4 Josh 1999-11-26 21:02:59 EST
Yes, I too received the same problem.  I can reproduce it easily.  Also, I
tried reinstalling my system (for various reasons, mainly experimental),
downloaded all available patches for 6.1, and after updating my PPP to the
latest version (2.3.10-3.i386), I got the same problem.

I will remove this package and place the old one back.

Comment 5 chirico 1999-11-29 05:22:59 EST
I had the same problem, that is I lost my ppp connectivity after upgrading to
the latest initscripts package. It seems that if the variable GATEWAYDEV is
blank the /etc/sysconfig/network-scripts/if-up script put a defaultroute on
every interface it mounts. On my system I solved putting a line


in /etc/sysconfig/network. Now PPP works well and the route table is OK.
Comment 6 Nalin Dahyabhai 2000-01-17 09:19:59 EST
As I understand it, this should be fixed in the latest errata release of the
initscripts package (http://www.redhat.com/support/errata/RHSA1999052-04.html).
Please reopen this bug if it does not solve this problem.
Comment 7 Nalin Dahyabhai 2000-02-28 17:06:59 EST
*** Bug 9764 has been marked as a duplicate of this bug. ***
Comment 8 Nalin Dahyabhai 2000-02-28 17:14:59 EST
*** Bug 9730 has been marked as a duplicate of this bug. ***
Comment 9 Nalin Dahyabhai 2000-03-16 09:01:59 EST
*** Bug 10204 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.