Bug 71432 - Hundreds of gnome-panel-screenshot windows...
Hundreds of gnome-panel-screenshot windows...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: gnome-panel (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
: MoveUpstream, Triaged
: 72836 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-13 12:20 EDT by David Woodhouse
Modified: 2008-05-01 11:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-07 18:50:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description David Woodhouse 2002-08-13 12:20:57 EDT
It's far too easy to end up with hundreds (well, at least tens) of
gnome-panel-screenshot windows, especially if attempting to use SysRq or if you
have cats.

Perhaps they could be rate-limited, or a limit imposed on the number of open
windows?
Comment 1 Havoc Pennington 2002-08-13 12:44:16 EDT
jrb didn't you do something here?
Comment 2 Jonathan Blandford 2002-08-13 13:30:07 EDT
I just fixed a leak where they weren't going away.  Can't help with the cat
problem.  I'm not 100% sure how to do that too -- maybe make it a factory and
only allow 10 at once or something.
Comment 3 Havoc Pennington 2002-08-28 10:20:44 EDT
*** Bug 72836 has been marked as a duplicate of this bug. ***
Comment 4 Warren Togami 2002-08-28 12:43:07 EDT
Please considering limiting the number of open gnome-panel-screenshot windows. 
You may not think of this as too much of a problem for desktops, but this is
also DEADLY for an entire LTSP network. =(

Does Gnome have any other hotkeys that could be launching other windows like this?
Comment 5 Owen Taylor 2002-08-28 20:56:38 EDT
Still haven't fixed the "unattended cat" problem, but 
gnome-panel-2.0.8-9 only allows one screenshot operation
in progress at the same time and puts up a wait cursor, 
which helps a lot in accidentally generating a ton of 
screenshots. (Why isn't this print screen key working?
bang bang bang. Now I have ten screenshots...)

It would be trival to change the patch to wait until
until the user actually closed the new screenshot window,
but I'm not sure if people would consider that an
onerous restriction.
Comment 6 Warren Togami 2002-08-29 00:56:11 EDT
I have a patch for the cat problem, already gone through extensive in-house QA
testing (my dog didn't step on the keyboard for 2 hours, definitive proof). 
Unfortunately, I cannot find the appropriate Bugzilla component for filing.

(Thanks for fixing this!  This bug had me worried.)
Comment 7 Havoc Pennington 2003-01-07 18:50:00 EST
I'm counting this as fixed then, it sounds like any further refinement 
is noncritical. Maybe file a gnome.org bug if more tweaks are desired.

Note You need to log in before you can comment on or make changes to this bug.