Bug 714668 - Legacy SysV initscript file must go into an optional subpackage.
Legacy SysV initscript file must go into an optional subpackage.
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: firstboot (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Martin Gracik
Fedora Extras Quality Assurance
:
: 697522 706789 (view as bug list)
Depends On:
Blocks: SysVtoSystemd
  Show dependency treegraph
 
Reported: 2011-06-20 07:51 EDT by Jóhann B. Guðmundsson
Modified: 2013-07-04 08:57 EDT (History)
5 users (show)

See Also:
Fixed In Version: firstboot-16.0-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-12 06:30:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Spec file which drops SysV support for firstboot.service (10.49 KB, text/plain)
2011-06-27 06:17 EDT, Jóhann B. Guðmundsson
no flags Details

  None (edit)
Description Jóhann B. Guðmundsson 2011-06-20 07:51:18 EDT
Description of problem:

Currently your component is providing both native systemd service files and
legacy sysv init script in the same package which is in violation of the
packaging guidelines[1]. 

Once a native systemd service file is shipped and if the intention is to
continue to maintain and ship the old sysv initscript the old sysvinit must go
into an optional subpackage.

"SysV Initscripts
Packages may also provide a SysV initscript file, but are not required to do
so. This format is considered legacy, but Fedora still contains init mechanisms
such as upstart which do not support the systemd unit file format. If present,
the SysV initscript(s) must go into an optional subpackage, so as not to
confuse sysadmins. The guidelines for SysV initscripts can be found here:
Packaging:SysVInitScript"

1.http://fedoraproject.org/wiki/Packaging:Guidelines:Systemd

Version-Release number of selected component (if applicable):

firstboot-1.116-1.fc16

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Martin Gracik 2011-06-27 05:10:55 EDT
*** Bug 706789 has been marked as a duplicate of this bug. ***
Comment 2 Jóhann B. Guðmundsson 2011-06-27 06:09:54 EDT
*** Bug 697522 has been marked as a duplicate of this bug. ***
Comment 3 Jóhann B. Guðmundsson 2011-06-27 06:17:44 EDT
Created attachment 510060 [details]
Spec file which drops SysV support for firstboot.service

I think this is correct spec file for firstboot which drops sysv support note that you need to use correct firstboot native service not the current hack ones which call the old sysv init script I'm pretty sure that I have submitted the correct native hack free systemd service files sometime during the F15 development cycle.
Comment 4 Tom "spot" Callaway 2011-09-09 11:22:57 EDT
1.118-1 dropped the old sysv initscripts. firstboot-16.3-1.fc16 (newer) is in testing. This can be closed when it hits stable.

Note You need to log in before you can comment on or make changes to this bug.