This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 715495 - hinotify failing to build on x86_64
hinotify failing to build on x86_64
Status: CLOSED DUPLICATE of bug 715799
Product: Fedora
Classification: Fedora
Component: ghc-hinotify (Show other bugs)
rawhide
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ben Boeckel
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-23 00:27 EDT by Jens Petersen
Modified: 2011-06-24 23:18 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-06-24 23:18:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jens Petersen 2011-06-23 00:27:53 EDT
Description of problem:
Haven't investigated carefully but ghc-hinotify is failing to build
on F16 rawhide (ghc-7.0.4).

http://koji.fedoraproject.org/koji/taskinfo?taskID=3154150


+ ./Setup build
Preprocessing library hinotify-0.3.1...
Building hinotify-0.3.1...
[1 of 2] Compiling System.INotify.Masks ( dist/build/System/INotify/Masks.hs, dist/build/System/INotify/Masks.o )
/tmp/ghc27001_0/ghc27001_0.s: Assembler messages:
/tmp/ghc27001_0/ghc27001_0.s: Error: .size expression for s1zU_ret does not evaluate to a constant
/tmp/ghc27001_0/ghc27001_0.s: Error: .size expression for s1zT_ret does not evaluate to a constant
/tmp/ghc27001_0/ghc27001_0.s: Error: .size expression for s1zW_ret does not evaluate to a constant
/tmp/ghc27001_0/ghc27001_0.s: Error: .size expression for s1zY_ret does not evaluate to a constant
/tmp/ghc27001_0/ghc27001_0.s: Error: .size expression for s1A0_ret does not evaluate to a constant
/tmp/ghc27001_0/ghc27001_0.s: Error: .size expression for s1A2_ret does not evaluate to a constant
/tmp/ghc27001_0/ghc27001_0.s: Error: .size expression for hinotifyzm0zi3zi1_SystemziINotifyziMasks_zdwmaskIsSet_entry does not evaluate to a constant
/tmp/ghc27001_0/ghc27001_0.s: Error: .size expression for s1CK_ret does not evaluate to a constant
/tmp/ghc27001_0/ghc27001_0.s: Error: .size expression for s1wo_ret does not evaluate to a constant
/tmp/ghc27001_0/ghc27001_0.s: Error: .size expression for s1CI_ret does not evaluate to a constant
/tmp/ghc27001_0/ghc27001_0.s: Error: .size expression for s1wv_ret does not evaluate to a constant
/tmp/ghc27001_0/ghc27001_0.s: Error: .size expression for s1CL_ret does not evaluate to a constant
/tmp/ghc27001_0/ghc27001_0.s: Error: .size expression for s1wC_ret does not evaluate to a constant
/tmp/ghc27001_0/ghc27001_0.s: Error: .size expression for s1CM_ret does not evaluate to a constant
/tmp/ghc27001_0/ghc27001_0.s: Error: .size expression for s1wJ_ret does not evaluate to a constant
/tmp/ghc27001_0/ghc27001_0.s: Error: .size expression for s1CN_ret does not evaluate to a constant
/tmp/ghc27001_0/ghc27001_0.s: Error: .size expression for s1wQ_ret does not evaluate to a constant
/tmp/ghc27001_0/ghc27001_0.s: Error: .size expression for s1CO_ret does not evaluate to a constant
/tmp/ghc27001_0/ghc27001_0.s: Error: .size expression for s1CJ_ret does not evaluate to a constant
/tmp/ghc27001_0/ghc27001_0.s: Error: .size expression for hinotifyzm0zi3zi1_SystemziINotifyziMasks_zdwgo_entry does not evaluate to a constant
/tmp/ghc27001_0/ghc27001_0.s: Error: .size expression for hinotifyzm0zi3zi1_SystemziINotifyziMasks_zdfShowMask22_entry does not evaluate to a constant
/tmp/ghc27001_0/ghc27001_0.s: Error: .size expression for hinotifyzm0zi3zi1_SystemziINotifyziMasks_zdfShowMask24_entry does not evaluate to a constant
/tmp/ghc27001_0/ghc27001_0.s: Error: .size expression for hinotifyzm0zi3zi1_SystemziINotifyziMasks_zdfShowMask26_entry does not evaluate to a constant
/tmp/ghc27001_0/ghc27001_0.s: Error: .size expression for hinotifyzm0zi3zi1_SystemziINotifyziMasks_zdfShowMask28_entry does not evaluate to a constant
/tmp/ghc27001_0/ghc27001_0.s: Error: .size expression for hinotifyzm0zi3zi1_SystemziINotifyziMasks_zdfShowMask30_entry does not evaluate to a constant
/tmp/ghc27001_0/ghc27001_0.s: Error: .size expression for hinotifyzm0zi3zi1_SystemziINotifyziMasks_zdfShowMask32_entry does not evaluate to a constant
/tmp/ghc27001_0/ghc27001_0.s: Error: .size expression for hinotifyzm0zi3zi1_SystemziINotifyziMasks_zdfShowMask34_entry does not evaluate to a constant
/tmp/ghc27001_0/ghc27001_0.s: Error: .size expression for hinotifyzm0zi3zi1_SystemziINotifyziMasks_zdfShowMask36_entry does not evaluate to a constant
/tmp/ghc27001_0/ghc27001_0.s: Error: .size expression for hinotifyzm0zi3zi1_SystemziINotifyziMasks_zdfShowMask38_entry does not evaluate to a constant
/tmp/ghc27001_0/ghc27001_0.s: Error: .size expression for hinotifyzm0zi3zi1_SystemziINotifyziMasks_zdfShowMask40_entry does not evaluate to a constant
/tmp/ghc27001_0/ghc27001_0.s: Error: .size expression for hinotifyzm0zi3zi1_SystemziINotifyziMasks_zdfShowMask42_entry does not evaluate to a constant
/tmp/ghc27001_0/ghc27001_0.s: Error: .size expression for hinotifyzm0zi3zi1_SystemziINotifyziMasks_zdfShowMask44_entry does not evaluate to a constant
/tmp/ghc27001_0/ghc27001_0.s: Error: .size expression for hinotifyzm0zi3zi1_SystemziINotifyziMasks_zdfShowMask46_entry does not evaluate to a constant
/tmp/ghc27001_0/ghc27001_0.s: Error: .size expression for hinotifyzm0zi3zi1_SystemziINotifyziMasks_zdfShowMask48_entry does not evaluate to a constant
/tmp/ghc27001_0/ghc27001_0.s: Error: .size expression for hinotifyzm0zi3zi1_SystemziINotifyziMasks_zdfShowMask50_entry does not evaluate to a constant
/tmp/ghc27001_0/ghc27001_0.s: Error: .size expression for hinotifyzm0zi3zi1_SystemziINotifyziMasks_zdfShowMask52_entry does not evaluate to a constant
/tmp/ghc27001_0/ghc27001_0.s: Error: .size expression for hinotifyzm0zi3zi1_SystemziINotifyziMasks_zdfShowMask54_entry does not evaluate to a constant
/tmp/ghc27001_0/ghc27001_0.s: Error: .size expression for hinotifyzm0zi3zi1_SystemziINotifyziMasks_zdfShowMask56_entry does not evaluate to a constant
/tmp/ghc27001_0/ghc27001_0.s: Error: .size expression for hinotifyzm0zi3zi1_SystemziINotifyziMasks_zdfShowMask58_entry does not evaluate to a constant
/tmp/ghc27001_0/ghc27001_0.s: Error: .size expression for s1wU_ret does not evaluate to a constant
/tmp/ghc27001_0/ghc27001_0.s: Error: .size expression for hinotifyzm0zi3zi1_SystemziINotifyziMasks_joinMasks_entry does not evaluate to a constant
/tmp/ghc27001_0/ghc27001_0.s: Error: .size expression for s1NT_ret does not evaluate to a constant
/tmp/ghc27001_0/ghc27001_0.s: Error: .size expression for hinotifyzm0zi3zi1_SystemziINotifyziMasks_maskIsSet_entry does not evaluate to a constant
/tmp/ghc27001_0/ghc27001_0.s: Error: .size expression for s1Oa_ret does not evaluate to a constant
/tmp/ghc27001_0/ghc27001_0.s: Error: .size expression for s1O9_ret does not evaluate to a constant
/tmp/ghc27001_0/ghc27001_0.s: Error: .size expression for s1Ob_ret does not evaluate to a constant
/tmp/ghc27001_0/ghc27001_0.s: Error: .size expression for s1Oe_ret does not evaluate to a constant
/tmp/ghc27001_0/ghc27001_0.s: Error: .size expression for s1Oi_ret does not evaluate to a constant
/tmp/ghc27001_0/ghc27001_0.s: Error: .size expression for s1Ok_ret does not evaluate to a constant
/tmp/ghc27001_0/ghc27001_0.s: Error: .size expression for hinotifyzm0zi3zi1_SystemziINotifyziMasks_zdfOrdMaskzuzdccompare_entry does not evaluate to a constant
/tmp/ghc27001_0/ghc27001_0.s: Error: .size expression for s1PZ_ret does not evaluate to a constant
/tmp/ghc27001_0/ghc27001_0.s: Error: .size expression for hinotifyzm0zi3zi1_SystemziINotifyziMasks_zdfOrdMaskzuzdczl_entry does not evaluate to a constant
/tmp/ghc27001_0/ghc27001_0.s: Error: .size expression for s1Qf_ret does not evaluate to a constant
/tmp/ghc27001_0/ghc27001_0.s: Error: .size expression for hinotifyzm0zi3zi1_SystemziINotifyziMasks_zdfOrdMaskzuzdczgze_entry does not evaluate to a constant
/tmp/ghc27001_0/ghc27001_0.s: Error: .size expression for s1Qv_ret does not evaluate to a constant
/tmp/ghc27001_0/ghc27001_0.s: Error: .size expression for hinotifyzm0zi3zi1_SystemziINotifyziMasks_zdfOrdMaskzuzdczg_entry does not evaluate to a constant
/tmp/ghc27001_0/ghc27001_0.s: Error: .size expression for s1QL_ret does not evaluate to a constant
/tmp/ghc27001_0/ghc27001_0.s: Error: .size expression for hinotifyzm0zi3zi1_SystemziINotifyziMasks_zdfOrdMaskzuzdczlze_entry does not evaluate to a constant
/tmp/ghc27001_0/ghc27001_0.s: Error: .size expression for s1R1_ret does not evaluate to a constant
/tmp/ghc27001_0/ghc27001_0.s: Error: .size expression for hinotifyzm0zi3zi1_SystemziINotifyziMasks_zdfOrdMaskzuzdcmax_entry does not evaluate to a constant
/tmp/ghc27001_0/ghc27001_0.s: Error: .size expression for s1Rh_ret does not evaluate to a constant
/tmp/ghc27001_0/ghc27001_0.s: Error: .size expression for hinotifyzm0zi3zi1_SystemziINotifyziMasks_zdfOrdMaskzuzdcmin_entry does not evaluate to a constant
/tmp/ghc27001_0/ghc27001_0.s: Error: .size expression for s1Ry_ret does not evaluate to a constant
/tmp/ghc27001_0/ghc27001_0.s: Error: .size expression for s1Rz_ret does not evaluate to a constant
/tmp/ghc27001_0/ghc27001_0.s: Error: .size expression for s1RA_ret does not evaluate to a constant
/tmp/ghc27001_0/ghc27001_0.s: Error: .size expression for s1Rx_ret does not evaluate to a constant
/tmp/ghc27001_0/ghc27001_0.s: Error: .size expression for s1RC_ret does not evaluate to a constant
/tmp/ghc27001_0/ghc27001_0.s: Error: .size expression for s1RD_ret does not evaluate to a constant
/tmp/ghc27001_0/ghc27001_0.s: Error: .size expression for s1RB_ret does not evaluate to a constant
/tmp/ghc27001_0/ghc27001_0.s: Error: .size expression for s1RF_ret does not evaluate to a constant
/tmp/ghc27001_0/ghc27001_0.s: Error: .size expression for s1RG_ret does not evaluate to a constant
/tmp/ghc27001_0/ghc27001_0.s: Error: .size expression for s1RE_ret does not evaluate to a constant
/tmp/ghc27001_0/ghc27001_0.s: Error: .size expression for s1RI_ret does not evaluate to a constant
/tmp/ghc27001_0/ghc27001_0.s: Error: .size expression for s1RJ_ret does not evaluate to a constant
/tmp/ghc27001_0/ghc27001_0.s: Error: .size expression for s1RH_ret does not evaluate to a constant
/tmp/ghc27001_0/ghc27001_0.s: Error: .size expression for s1RL_ret does not evaluate to a constant
/tmp/ghc27001_0/ghc27001_0.s: Error: .size expression for s1RM_ret does not evaluate to a constant
/tmp/ghc27001_0/ghc27001_0.s: Error: .size expression for s1RK_ret does not evaluate to a constant
/tmp/ghc27001_0/ghc27001_0.s: Error: .size expression for hinotifyzm0zi3zi1_SystemziINotifyziMasks_zdfEqMaskzuzdczeze_entry does not evaluate to a constant
/tmp/ghc27001_0/ghc27001_0.s: Error: .size expression for s1Vc_ret does not evaluate to a constant
/tmp/ghc27001_0/ghc27001_0.s: Error: .size expression for hinotifyzm0zi3zi1_SystemziINotifyziMasks_zdfEqMaskzuzdczsze_entry does not evaluate to a constant
/tmp/ghc27001_0/ghc27001_0.s: Error: .size expression for s1Vx_ret does not evaluate to a constant
/tmp/ghc27001_0/ghc27001_0.s: Error: .size expression for hinotifyzm0zi3zi1_SystemziINotifyziMasks_zdfShowMaskzuzdcshowsPrec_entry does not evaluate to a constant
/tmp/ghc27001_0/ghc27001_0.s: Error: .size expression for s1VR_ret does not evaluate to a constant
/tmp/ghc27001_0/ghc27001_0.s: Error: .size expression for hinotifyzm0zi3zi1_SystemziINotifyziMasks_zdfShowMaskzuzdcshow_entry does not evaluate to a constant
/tmp/ghc27001_0/ghc27001_0.s: Error: .size expression for s1Wa_ret does not evaluate to a constant
/tmp/ghc27001_0/ghc27001_0.s: Error: .size expression for s1Wd_ret does not evaluate to a constant
/tmp/ghc27001_0/ghc27001_0.s: Error: .size expression for s1Wf_entry does not evaluate to a constant
/tmp/ghc27001_0/ghc27001_0.s: Error: .size expression for s1Wc_ret does not evaluate to a constant
/tmp/ghc27001_0/ghc27001_0.s: Error: .size expression for s1zL_entry does not evaluate to a constant
/tmp/ghc27001_0/ghc27001_0.s: Error: .size expression for s1Wg_entry does not evaluate to a constant
/tmp/ghc27001_0/ghc27001_0.s: Error: .size expression for s1Wb_ret does not evaluate to a constant
/tmp/ghc27001_0/ghc27001_0.s: Error: .size expression for s1Wh_entry does not evaluate to a constant
/tmp/ghc27001_0/ghc27001_0.s: Error: .size expression for hinotifyzm0zi3zi1_SystemziINotifyziMasks_zdfShowMaskzuzdcshowList_entry does not evaluate to a constant
/tmp/ghc27001_0/ghc27001_0.s: Error: .size expression for hinotifyzm0zi3zi1_SystemziINotifyziMasks_UserSpace_entry does not evaluate to a constant
/tmp/ghc27001_0/ghc27001_0.s: Error: .size expression for hinotifyzm0zi3zi1_SystemziINotifyziMasks_Extra_entry does not evaluate to a constant
/tmp/ghc27001_0/ghc27001_0.s: Error: .size expression for hinotifyzm0zi3zi1_SystemziINotifyziMasks_Helper_entry does not evaluate to a constant
/tmp/ghc27001_0/ghc27001_0.s: Error: .size expression for hinotifyzm0zi3zi1_SystemziINotifyziMasks_Special_entry does not evaluate to a constant
/tmp/ghc27001_0/ghc27001_0.s: Error: .size expression for hinotifyzm0zi3zi1_SystemziINotifyziMasks_All_entry does not evaluate to a constant
/tmp/ghc27001_0/ghc27001_0.s: Error: .size expression for hinotifyzm0zi3zi1_SystemziINotifyziMasks_UserSpace_con_entry does not evaluate to a constant
/tmp/ghc27001_0/ghc27001_0.s: Error: .size expression for hinotifyzm0zi3zi1_SystemziINotifyziMasks_UserSpace_static_entry does not evaluate to a constant
/tmp/ghc27001_0/ghc27001_0.s: Error: .size expression for hinotifyzm0zi3zi1_SystemziINotifyziMasks_Extra_con_entry does not evaluate to a constant
/tmp/ghc27001_0/ghc27001_0.s: Error: .size expression for hinotifyzm0zi3zi1_SystemziINotifyziMasks_Extra_static_entry does not evaluate to a constant
/tmp/ghc27001_0/ghc27001_0.s: Error: .size expression for hinotifyzm0zi3zi1_SystemziINotifyziMasks_Helper_con_entry does not evaluate to a constant
/tmp/ghc27001_0/ghc27001_0.s: Error: .size expression for hinotifyzm0zi3zi1_SystemziINotifyziMasks_Helper_static_entry does not evaluate to a constant
/tmp/ghc27001_0/ghc27001_0.s: Error: .size expression for hinotifyzm0zi3zi1_SystemziINotifyziMasks_Special_con_entry does not evaluate to a constant
/tmp/ghc27001_0/ghc27001_0.s: Error: .size expression for hinotifyzm0zi3zi1_SystemziINotifyziMasks_Special_static_entry does not evaluate to a constant
/tmp/ghc27001_0/ghc27001_0.s: Error: .size expression for hinotifyzm0zi3zi1_SystemziINotifyziMasks_All_con_entry does not evaluate to a constant
/tmp/ghc27001_0/ghc27001_0.s: Error: .size expression for hinotifyzm0zi3zi1_SystemziINotifyziMasks_All_static_entry does not evaluate to a constant
error: Bad exit status from /var/tmp/rpm-tmp.jCmesa (%build)
Comment 1 Matt Domsch 2011-06-24 23:18:43 EDT

*** This bug has been marked as a duplicate of bug 715799 ***

Note You need to log in before you can comment on or make changes to this bug.