This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 715799 - FTBFS ghc-hinotify-0.3.1-9.fc16
FTBFS ghc-hinotify-0.3.1-9.fc16
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: ghc-hinotify (Show other bugs)
rawhide
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: Ben Boeckel
Jens Petersen
http://linux.dell.com/files/fedora/Fi...
: Triaged
: 715495 (view as bug list)
Depends On: 717495
Blocks: F16FTBFS
  Show dependency treegraph
 
Reported: 2011-06-23 11:11 EDT by FTBFS
Modified: 2011-07-22 00:21 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-07-22 00:21:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
root.log (352.72 KB, text/plain)
2011-06-23 11:11 EDT, FTBFS
no flags Details
build.log (16.24 KB, text/plain)
2011-06-23 11:11 EDT, FTBFS
no flags Details
mock.log (1.23 KB, text/plain)
2011-06-23 11:11 EDT, FTBFS
no flags Details

  None (edit)
Description FTBFS 2011-06-23 11:11:30 EDT
ghc-hinotify-0.3.1-9.fc16.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
If you believe this is actually a bug in another package, do NOT change the component in this bug or close this bug.  Instead, add the appropriate bug number from the other package to the "Depends on" line in this bug.  If the other package does not yet have a bug created that you think matches, please create one.  Doing so helps us properly track bugs and their dependencies, just as we track package dependencies.  (If you close this bug, and the other package is not fixed before the next FTBFS run, a new bug will get created.  Please follow the above advice to avoid such duplication.)
Comment 1 FTBFS 2011-06-23 11:11:35 EDT
Created attachment 507203 [details]
root.log


root.log for x86_64
Comment 2 FTBFS 2011-06-23 11:11:36 EDT
Created attachment 507204 [details]
build.log


build.log for x86_64
Comment 3 FTBFS 2011-06-23 11:11:38 EDT
Created attachment 507205 [details]
mock.log


mock.log for x86_64
Comment 4 Matt Domsch 2011-06-24 23:18:43 EDT
*** Bug 715495 has been marked as a duplicate of this bug. ***
Comment 5 Jens Petersen 2011-06-27 02:51:51 EDT
I tried building with ghc-7.0.4-26.fc16 on f15 and it built fine,
so this seems to be due to done other change in F16.

Off the top of my head I'd say the main suspects that
I can imagine are either the kernel or glibc perhaps.
Comment 6 Jens Petersen 2011-06-27 02:55:22 EDT
Hm, "sys/inotify.h" is from glibc-headers at least.
Comment 7 Jens Petersen 2011-06-27 03:10:27 EDT
But both it and linux/inotify.h look unchanged since f15.
Also gcc and cpp in f16 and f15 are same currently.
Comment 8 Jens Petersen 2011-06-27 03:28:32 EDT
Updating f15 to latest rawhide kernel doesn't seem to make a difference either.
Comment 9 Jens Petersen 2011-06-28 02:03:59 EDT
Ok it should have clicked a little earlier: asm => binutils.

Downgrading from binutils-2.21.52.0.1-5.fc16 to binutils-2.21.51.0.6-5.fc15 fixes the problem though.
Comment 10 Jens Petersen 2011-06-28 02:41:34 EDT
Testing little more (I call it "binary bisecting"):
build is ok with binutils-2.21.51.0.6-2.fc16 but
breaks with binutils-2.21.51.0.7-1.fc16.

So I guess some upstream change in binutils between
2.21.51.0.6 and 2.21.51.0.7 is the cause of the problem.
Comment 11 Jens Petersen 2011-07-21 23:48:41 EDT
Ah, I see: removing -fvia-C from hinotify.cabal makes it build again.

This might actually be a bug in the ghc C backend: see bug 717495.
Comment 12 Jens Petersen 2011-07-22 00:21:33 EDT
Should be fixed with ghc-hinotify-0.3.1-11.fc16.

Note You need to log in before you can comment on or make changes to this bug.