Bug 71551 - TB NCHardwareList.:288:save KeyError: options
TB NCHardwareList.:288:save KeyError: options
Status: CLOSED DUPLICATE of bug 65073
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network (Show other bugs)
7.3
i686 Linux
high Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-14 23:10 EDT by Need Real Name
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-25 16:44:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-08-14 23:10:26 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020513

Description of problem:
Trying to change the pcmcia card chipset causes the bug after you delete and try
to choose another chipset.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Delete current chipset
2.choose another one--it will say that it doesn't match the one on file
3.Another window pops up stating that the card couldn't be initialized
4.Then the good ol' Bug window appears with Python script errors
	

Actual Results:  Traceback (innermost last):
  File "/usr/sbin/neat", line 1402, in ?
    gtk.mainloop()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 2676, in mainloop
    _gtk.gtk_main()
  File "/usr/lib/python1.5/site-packages/libglade.py", line 28, in __call__
    ret = apply(self.func, a)
  File "/usr/sbin/neat", line 449, in on_applyButton_clicked
    self.save()
  File "/usr/sbin/neat", line 287, in save
    self.saveHardware()
  File "/usr/sbin/neat", line 302, in saveHardware
    hardwarelist.save()
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/NCHardwareList.py",
line 288, in save
    modules[hw.Card.ModuleName]['options'][confkey] = str(hw.Card.__dict__[selfkey])
KeyError: options

Local variables in innermost frame:
isdn: <netconfpkg.NCisdnhardware.ConfISDN instance at 8562b28>
hw: <netconfpkg.HardwareList.Hardware instance at 84fc3e8>
selfkey: IRQ
wvdial: <netconfpkg.ConfSMB.ConfSMB instance at 8508ca8>
modules: <netconfpkg.NCHardwareList.MyConfModules instance at 8539df8>
confkey: irq
self: [<netconfpkg.HardwareList.Hardware instance at 84fc3e8>]


Expected Results:  It should have used the new chipset and netwrok configuration!!!

Additional info:

The Kdesktop environment seems very unstable in Red Hat 7.3. What gives?

I am running this on an IBM Thinkpad i1400 2621 42U model with 4.6GB HD memory
with 256MB of ram.
Comment 1 Harald Hoyer 2002-11-04 07:43:19 EST
first beta of erratum is available at:
ftp://people.redhat.com/harald/redhat-config-network/1.0.1-1/

Most of the bugs reported have been removed, but as in every software change,
there could be new bugs introduced.

Please report bugs against this with explicitly stating the 1.0.1 version... Thx
and please test.

*** This bug has been marked as a duplicate of 65073 ***

Note You need to log in before you can comment on or make changes to this bug.