Bug 71570 - "System Log" doesn't work, and should be integrated into "System Logs"
Summary: "System Log" doesn't work, and should be integrated into "System Logs"
Status: CLOSED DUPLICATE of bug 69711
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: gnome-utils (Show other bugs)
(Show other bugs)
Version: limbo
Hardware: All Linux
medium
low
Target Milestone: ---
Assignee: Tammy Fox
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-08-15 09:43 UTC by Mike MacCana
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-15 09:43:11 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mike MacCana 2002-08-15 09:43:07 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020724

Description of problem:
There are two programs in the System Tools menu in Limbo 2.
One is called System Log
The other is called System Logs (this component)

System Logs is a nice app that prompts the user for the root password, and then
shows a useful log viewing program.

System Log (gnome-system-log) launches, attempts to read /var/log/messages,
fails if the user isn't logged in as root with "/var/log/messages could not be
opened, no log files to open", and then exits.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Look in the System Tools menu of Limbo 2
2.Compare the two apps. 
	

Actual Results:  gnome-system-log will always fail unless the user is logged
into X as root (a Bad Thing).
In addition, redhat-logviewer doesn't show all the contents of
/var/log/messages, asa far as I can tell. 

Expected Results:  redhat-logviewer should include any logs that
gnome-system-log does.
After that, gnome-system-log should be removed from the distribution - there's a
big overlap in functionality and users aren't quite sure what program to click on

Additional info:

Comment 1 Tammy Fox 2002-08-15 16:34:14 UTC

*** This bug has been marked as a duplicate of 69711 ***


Note You need to log in before you can comment on or make changes to this bug.