Bug 715976 - PyQt / PyQwt version mismatch
PyQt / PyQwt version mismatch
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: PyQwt (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Tadej Janež
Fedora Extras Quality Assurance
http://linux.dell.com/files/fedora/Fi...
: Triaged
Depends On:
Blocks: F16FTBFS
  Show dependency treegraph
 
Reported: 2011-06-23 11:50 EDT by FTBFS
Modified: 2011-12-12 11:07 EST (History)
3 users (show)

See Also:
Fixed In Version: PyQwt-5.2.0-14.fc16.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-16 20:45:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
root.log (668.09 KB, text/plain)
2011-06-23 11:50 EDT, FTBFS
no flags Details
build.log (55.05 KB, text/plain)
2011-06-23 11:50 EDT, FTBFS
no flags Details
mock.log (1.28 KB, text/plain)
2011-06-23 11:50 EDT, FTBFS
no flags Details
root.log (933.55 KB, text/plain)
2011-06-23 11:50 EDT, FTBFS
no flags Details
build.log (53.09 KB, text/plain)
2011-06-23 11:50 EDT, FTBFS
no flags Details
mock.log (1.21 KB, text/plain)
2011-06-23 11:50 EDT, FTBFS
no flags Details

  None (edit)
Description FTBFS 2011-06-23 11:50:09 EDT
PyMca-4.4.1-3.p1.fc16.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
If you believe this is actually a bug in another package, do NOT change the component in this bug or close this bug.  Instead, add the appropriate bug number from the other package to the "Depends on" line in this bug.  If the other package does not yet have a bug created that you think matches, please create one.  Doing so helps us properly track bugs and their dependencies, just as we track package dependencies.  (If you close this bug, and the other package is not fixed before the next FTBFS run, a new bug will get created.  Please follow the above advice to avoid such duplication.)
Comment 1 FTBFS 2011-06-23 11:50:13 EDT
Created attachment 508171 [details]
root.log


root.log for i386
Comment 2 FTBFS 2011-06-23 11:50:14 EDT
Created attachment 508172 [details]
build.log


build.log for i386
Comment 3 FTBFS 2011-06-23 11:50:15 EDT
Created attachment 508173 [details]
mock.log


mock.log for i386
Comment 4 FTBFS 2011-06-23 11:50:18 EDT
Created attachment 508174 [details]
root.log


root.log for x86_64
Comment 5 FTBFS 2011-06-23 11:50:19 EDT
Created attachment 508175 [details]
build.log


build.log for x86_64
Comment 6 FTBFS 2011-06-23 11:50:21 EDT
Created attachment 508176 [details]
mock.log


mock.log for x86_64
Comment 7 Susi Lehtola 2011-06-24 05:52:40 EDT
Failed due to

Traceback (most recent call last):
  File "setup.py", line 390, in <module>
    from PyQt4 import Qwt5
  File "/usr/lib/python2.7/site-packages/PyQt4/Qwt5/__init__.py", line 32, in <module>
    from Qwt import *
RuntimeError: the PyQt4.QtCore module is version 1 but the PyQt4.Qwt5.Qwt module requires version -1
Comment 8 Susi Lehtola 2011-07-14 08:21:26 EDT
Issue is still present.
Comment 9 Tadej Janež 2011-07-15 09:01:52 EDT
I'll try to get a rawhide machine ready and then look into this.
Comment 10 Tadej Janež 2011-09-08 11:27:00 EDT
Hi!

I finally got the time to look into this.

Rebuilding PyQwt on F-16 fixes the problem. I tested it with a F-16 Alpha virtual machine. However, it introduces a new issue with rpath, which I would like to resolve before pushing the update. I raised the issue on the devel mailing list:
http://lists.fedoraproject.org/pipermail/devel/2011-September/156563.html
Comment 11 Fedora Update System 2011-09-18 16:22:34 EDT
PyQwt-5.2.0-14.fc16.1 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/PyQwt-5.2.0-14.fc16.1
Comment 12 Fedora Update System 2011-09-19 14:29:54 EDT
Package PyQwt-5.2.0-14.fc16.1:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing PyQwt-5.2.0-14.fc16.1'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/PyQwt-5.2.0-14.fc16.1
then log in and leave karma (feedback).
Comment 13 Fedora Update System 2011-10-08 10:18:29 EDT
PyQwt-5.2.0-14.fc16.2 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/PyQwt-5.2.0-14.fc16.2
Comment 14 Fedora Update System 2011-10-16 20:45:14 EDT
PyQwt-5.2.0-14.fc16.2 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 15 Pierre Pudlo 2011-12-12 04:31:11 EST
Same issue on Fedora 15. 

Is it possible to have an update of PyQwt-5.2.0-12.fc15 ?
Comment 16 Tadej Janež 2011-12-12 05:30:10 EST
Acknowledged.

Pierre, could you please file a new bug against PyQwt?
Comment 17 Pierre Pudlo 2011-12-12 10:36:14 EST
Ok. Is that what you expected ?
https://bugzilla.redhat.com/show_bug.cgi?id=766726
Comment 18 Tadej Janež 2011-12-12 11:07:20 EST
(In reply to comment #17)
> Ok. Is that what you expected ?

Perfect, thanks!

Note You need to log in before you can comment on or make changes to this bug.