This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 766726 - PyQt / PyQwt version mismatch
PyQt / PyQwt version mismatch
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: PyQwt (Show other bugs)
15
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Tadej Janež
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-12 10:34 EST by Pierre Pudlo
Modified: 2012-01-15 15:06 EST (History)
1 user (show)

See Also:
Fixed In Version: PyQwt-5.2.0-14.fc15.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-01-13 22:59:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Pierre Pudlo 2011-12-12 10:34:20 EST
Description of problem:
Unable to load Qwt library in python

Version-Release number of selected component (if applicable):
PyQt4-4.8.6-1.fc15.x86_64
PyQwt-5.2.0-12.fc15.x86_64

How reproducible:
allways

Steps to Reproduce:
1. type " from PyQt4.Qwt5 import * " in python 
2.
3.
  
Actual results:
  RuntimeError: the PyQt4.QtCore module is version 1 but the PyQt4.Qwt5.Qwt
  module requires version -1


Expected results:


Additional info:
Same bug, but on Fedora 16, seems to be resolved here : https://bugzilla.redhat.com/show_bug.cgi?id=715976
Comment 1 Pierre Pudlo 2011-12-17 03:10:00 EST
Building the SRPM of PyQwt while PyQt4-4.8.6-1 is installed seems to solve the problem.
Comment 2 Fedora Update System 2012-01-03 06:11:21 EST
PyQwt-5.2.0-14.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/PyQwt-5.2.0-14.fc15
Comment 3 Fedora Update System 2012-01-03 08:31:14 EST
PyQwt-5.2.0-14.fc15.1 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/PyQwt-5.2.0-14.fc15.1
Comment 4 Fedora Update System 2012-01-03 20:59:42 EST
Package PyQwt-5.2.0-14.fc15.1:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing PyQwt-5.2.0-14.fc15.1'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-0091/PyQwt-5.2.0-14.fc15.1
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2012-01-13 22:59:35 EST
PyQwt-5.2.0-14.fc15.1 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Fedora Update System 2012-01-15 15:06:19 EST
PyQwt-5.2.0-14.fc15.1 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.