Bug 716365 - [gdm] borked login: crashes immediately
Summary: [gdm] borked login: crashes immediately
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gdm
Version: rawhide
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F16Alpha, F16AlphaBlocker F16Alphas390x F16Alphappc
TreeView+ depends on / blocked
 
Reported: 2011-06-24 07:57 UTC by Joachim Frieben
Modified: 2012-03-14 13:06 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-06-28 18:03:26 UTC


Attachments (Terms of Use)
/var/log/gdm/:0.log (39.50 KB, text/plain)
2011-06-24 08:01 UTC, Joachim Frieben
no flags Details
/var/log/gdm/:0-greeter.log (27.69 KB, text/plain)
2011-06-24 08:02 UTC, Joachim Frieben
no flags Details
/var/log/gdm/:0-slave.log (12.58 KB, text/plain)
2011-06-24 08:03 UTC, Joachim Frieben
no flags Details

Description Joachim Frieben 2011-06-24 07:57:42 UTC
Description of problem:
After upgrading to the latest "rawhide" tree, graphical login is not possible anymore: the empty login panel flickers three times and then disappears.

Version-Release number of selected component (if applicable):
gdm-3.1.2-2.fc16

How reproducible:
Always.

Steps to Reproduce:
1. Boot system into runlevel 5.
  
Actual results:
An empty login panel without any widgets pops up three times and then disappears.

Expected results:
Login panel allows to choose a user and to enter the corresponding password, and user session starts.

Additional info:
None.

Comment 1 Joachim Frieben 2011-06-24 08:01:26 UTC
Created attachment 509686 [details]
/var/log/gdm/:0.log

Comment 2 Joachim Frieben 2011-06-24 08:02:04 UTC
Created attachment 509687 [details]
/var/log/gdm/:0-greeter.log

Comment 3 Joachim Frieben 2011-06-24 08:03:06 UTC
Created attachment 509689 [details]
/var/log/gdm/:0-slave.log

Comment 4 Petr Holasek 2011-06-24 11:16:22 UTC
I have the same problem, gdm reinstall or $ startx without any success.

Comment 5 Joachim Frieben 2011-06-24 14:41:13 UTC
(In reply to comment #4)
Executing 'startx' at runlevel 3 actually does work in my case.

Comment 6 Adam Williamson 2011-06-27 22:04:18 UTC
Confirming, same issue here on current Rawhide. My greeter.log shows the same backtrace as Christoph's (except less complete, I don't have debuginfo packages).

Comment 7 Adam Williamson 2011-06-28 17:14:48 UTC
propose as F16 Alpha blocker.

Comment 8 Adam Williamson 2011-06-28 17:57:20 UTC
*** Bug 717324 has been marked as a duplicate of this bug. ***

Comment 9 Adam Williamson 2011-06-28 17:57:57 UTC
From the dupe:

"it's a bug in the accessibility stack that gdm is hitting because it gets crashy on fatal-criticals in development versions.

I don't like that behaviour, so I've switched it off:

http://git.gnome.org/browse/gdm/commit/?id=fc6ee4aa6d71d2c448a9b62aca24ba318163c590

which i'll build into rawhide shortly."


Note You need to log in before you can comment on or make changes to this bug.